Интеграция phpBB 3.0.12 с Wordpress 3.9.9

Есть любые вопросы, связанные со стилями/темами для phpBB 3.0.x? Задайте их здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
byvoodoo
phpBB 1.4.0
Сообщения: 32
Зарегистрирован: 24.09.2015 15:57
Благодарил (а): 11 раз
Поблагодарили: 3 раза

Интеграция phpBB 3.0.12 с Wordpress 3.9.9

Сообщение byvoodoo » 24.09.2015 16:56

Успешно я интегрировал phpBB 3.0.12 с Wordpress 3.9.9 по нижеследующей инструкции:
1) Setup a fresh WordPress install for 4.1.1 (я брал версию 3.9.9 - так как она указана как максимальная для работы плагина WP-united)
2) Install and activate WP-UNITED plugin for wordpress
3) Create a new folder in the WordPress root called forum
4) Extract phpbb 3.0.12 to the forum folder you just made.
5) Install phpbb http://localhost/wordpress/forum/install/ (remember to delete the install folder when its complete)
6) Download and Install Automod for 3.0.x (Extract contents of root folder to the /forum/ directory where you installed phpbb. Overwrite all files)
7) Install Automod. Once again run the installer found at http://localhost/wordpress/forum/install/
8) Once auto mod is installed purge forum cache and open the automod tab in the phpbb ACP and download the phpbb mod http://spiritloveforum.com/kingsblend/w ... -phpbb.zip upload the zip and install the mod.
9) After the wp-united automod upload install there is a link you MUST click to install the database aspect of wp-united. It will be in a green box during the automod install. You will get errors if you are on conflicting versions of phpbb and wordpress. You will have to force install. The default options will work. The mod is written for 3.0.10 but it will work for 3.0.12 and even 3.0.13 but I personally have not tested version 3.13
10) Once successful go to the wordpress dashboard and run the wp-united setup.
11) You must point to the config file in the /forum/ root for phpbb.
12) Now you should be setup select the options you wish to use for the bridge.
13) When it comes to theme integration I found this mod WILL NOT work for a full CSS integration. YOU MUST TURN OFF THE SLIDER FOR THIS. All the way to the left.
14) You can play around with the way the theme integrates but I found that a statically cached simple header and footer works.
15) I spent a lot of time changing the wordpress twentythirteen theme and the prosilver theme to fit my needs color wise and element wise so some tweaking is involved. Google Chromes inspect element feature is a LIFESAVER.
Оригинал от сюда - https://wordpress.org/support/topic/wor ... phpbb-3012

Появилась проблема:
при выборе интеграции "форум в сайте" жутко тормозит форум. На эти тормоза выбор темы не влияет. Кто-нибудь сталкивался?

Закрыто

Вернуться в «Стили для phpBB 3.0.x»