Не работает навигация аккардеон на форуме

Есть любые вопросы, связанные со стилями/темами для phpBB 3.0.x? Задайте их здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Перенесено из форума Поддержка phpBB 3.0.х в форум Стили для phpBB 3.0.x 29.07.2016 18:53 модератором Sheer

Аватара пользователя
AnteFil
phpBB 1.4.4
Сообщения: 104
Зарегистрирован: 19.07.2014 15:16
Благодарил (а): 8 раз
Поблагодарили: 1 раз

Не работает навигация аккардеон на форуме

Сообщение AnteFil » 29.07.2016 18:44

Проблема с дизайном шаблона точнее с работоспособностью
Мне нужно что бы у меня получилось это

Код: Выделить всё

<div id="firstpane" class="menu_list">
<p class="menu_head">Header-1</p>
<div class="menu_body">
<a href="#">Link-1</a>
<a href="#">Link-2</a>
<a href="#">Link-3</a>	
</div>
При попытке это воткнуть в дизайн форума приблизительно так

Код: Выделить всё

<div id="firstpane" class="menu_list">
<!-- BEGIN forumrow -->
<!-- IF forumrow.S_IS_CAT -->
<p class="menu_head">{forumrow.FORUM_NAME}</p> 
<!-- ELSE -->
<div class="menu_body">
<a href="#">{forumrow.FORUM_NAME}</a>
</div>
<!-- ENDIF -->
<!-- BEGINELSE -->
<!-- END forumrow -->
 </div> 
У меня получаеться

Код: Выделить всё

<div id="firstpane" class="menu_list">
<p class="menu_head">Header-1</p>
<div class="menu_body"><a href="#">ИНФО1</a></div>
<div class="menu_body"><a href="#">ИНФО2</a></div>
<div class="menu_body"><a href="#">ИНФО3</a></div>
<div class="menu_body"><a href="#">ИНФО4</a></div>
<div class="menu_body"><a href="#">ИНФО5</a></div>
</div>
В цикле должен крутиться тег ссылки <a href="#">ИНФО1</a> а у меня получаеться захватывает тег <div class="menu_body"> и разделить не получаеться

Отправлено спустя 15 минут 25 секунд:
Логичнее всего сделать так

Код: Выделить всё

<div id="firstpane" class="menu_list">
<!-- BEGIN forumrow -->
<!-- IF forumrow.S_IS_CAT -->
<p class="menu_head">{forumrow.FORUM_NAME}</p> 
<div class="menu_body">
<!-- ELSE -->
<a href="#">{forumrow.FORUM_NAME}</a>
<!-- ENDIF -->
</div>
<!-- BEGINELSE -->
<!-- END forumrow -->
 </div> 
выносим тег </div> из цикла, но в этом случае идёт

Код: Выделить всё

<p class="menu_head">123</p>
<div class="menu_body"></div>
Вроде правильно но он оказывается пустым открывается и тут же закрывается
И потом идут ссылки

Код: Выделить всё

<a href="#">22222</a>
Отправлено спустя 37 секунд:
Ссылки не попадают в тег

Код: Выделить всё

<div class="menu_body">

Аватара пользователя
AnteFil
phpBB 1.4.4
Сообщения: 104
Зарегистрирован: 19.07.2014 15:16
Благодарил (а): 8 раз
Поблагодарили: 1 раз

Re: Не работает навигация аккардеон на форуме

Сообщение AnteFil » 30.07.2016 14:34

подскажите кто нить!

Аватара пользователя
romaamor
phpBB 3.0.0 RC2
Сообщения: 1528
Зарегистрирован: 31.03.2012 20:28
Откуда: Одесса
Благодарил (а): 522 раза
Поблагодарили: 126 раз

Re: Не работает навигация аккардеон на форуме

Сообщение romaamor » 30.07.2016 14:44

Мне помогло это чтиво -
http://htmlbook.ru/search/?as_q=%D0%BC% ... 9&ie=UTF-8

Вернуться в «Стили для phpBB 3.0.x»