FAQ: Обновление версии для phpBB 2.0.х

Темы по наиболее часто задаваемым вопросам по phpBB 2.0.x. Читать в первую очередь!
mEx
phpBB 1.4.4
Сообщения: 197
Зарегистрирован: 01.04.2007 1:39
Благодарил (а): 4 раза

Сообщение mEx » 02.10.2007 14:49

такой вопрос, у меня phpBB 2.0.22, с разными модами и т.д. если ставить на него phpBB 2+, как ляжет он на мой форум, моды и т.д.
Моды по идее будут конфликтовать, стоит ли это проворачивать?

Аватара пользователя
crash
Former team member
Сообщения: 6517
Зарегистрирован: 07.07.2004 17:12
Откуда: Бердск
Поблагодарили: 15 раз
Контактная информация:

Сообщение crash » 02.10.2007 15:50

mEx писал(а): меня phpBB 2.0.22, с разными модами и т.д. если ставить на него phpBB 2+,
этот вопрос было бы логичней задать на форуме поддержки phpbb2+
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

mongolor
phpBB 1.2.1
Сообщения: 21
Зарегистрирован: 21.06.2007 17:35
Контактная информация:

Сообщение mongolor » 10.12.2007 19:35

update_to_latest.php у меня когда его запускаешь, ничего не появляется, т.е. просто белая страница.

запускаю его из дериктории install как и сказано.

Может кто помочь?

Может быть есть отдельный список sql запросов, который можно выполнить непосредственно через phpmyadmin?

Добавлено спустя 40 секунд:

Ах да, апдейт идет с 21 на 22 версию

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 10.12.2007 23:10

mongolor
А не пробовали перед запуском залогиниться под admin'ом?
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

mongolor
phpBB 1.2.1
Сообщения: 21
Зарегистрирован: 21.06.2007 17:35
Контактная информация:

Сообщение mongolor » 11.12.2007 14:48

Палыч
Если запускать не под админом, то требует залогиниться.

Под своим админом я заходил, но есть еще учетная запись admin с id = 2 может под ней попробывать?

Аватара пользователя
/DiOs
Former team member
Сообщения: 1139
Зарегистрирован: 21.02.2006 7:53
Откуда: Ленинград

Сообщение /DiOs » 11.12.2007 14:52

mongolor писал(а):Может быть есть отдельный список sql запросов, который можно выполнить непосредственно через phpmyadmin?
А глазками в файл-то заглянуть слабО?
И если я неправ, пусть старшие товарищи поправят меня

mongolor
phpBB 1.2.1
Сообщения: 21
Зарегистрирован: 21.06.2007 17:35
Контактная информация:

Сообщение mongolor » 12.12.2007 15:06

/DiOs писал(а):А глазками в файл-то заглянуть слабО?
Заглядывал, не очень силен в MySQL чтобы слету определить что делает данный запрос, нужен ли он и не повредит ли он!

Аватара пользователя
/DiOs
Former team member
Сообщения: 1139
Зарегистрирован: 21.02.2006 7:53
Откуда: Ленинград

Сообщение /DiOs » 12.12.2007 15:16

mongolor писал(а):Заглядывал, не очень силен в MySQL
Да там не mysql, а в php надо буть сильнее. На уровне знания оператора CASE.
И если я неправ, пусть старшие товарищи поправят меня

mongolor
phpBB 1.2.1
Сообщения: 21
Зарегистрирован: 21.06.2007 17:35
Контактная информация:

Сообщение mongolor » 12.12.2007 16:01

Исправил ошибку!
Вот так:
прописал эти строки в начале фала апдейта

Код: Выделить всё

ini_set('error_reporting', E_ALL);
ini_set ('display_errors', 1); 
и вместо пустой страницы вылезло сообщение об ошибке в файле ../includes/db.php на 63 строке

посмотрел 63 строку а там

Код: Выделить всё

$cache = new cache($cache_dir, $cache_time);
ну я ее быстренько закоментил, сделал бэкап базы данных, и запустил update_to_latest.php, все прошло успешно, написало на экране Update completed.

Я со спокойной душой убрал коментирование 63 строки и все заработало :)

т.е. ошибка была вызвана установкой мода

Код: Выделить всё

mod_sql_caching_110

rubin
phpBB 1.0.0
Сообщения: 2
Зарегистрирован: 09.01.2008 11:45

Сообщение rubin » 09.01.2008 11:48

Обновился до 2.0.22..
Теперь никак не могу сменить язык по умолчанию с English на Russian - что можно исправить?
И второй вопрос - как убрать неактивные после обновления функции в админпанели? Форум просматривал - не нашел... Пытался править admin_board.php - записи остаются

Аватара пользователя
VVVas
Former team member
Сообщения: 4463
Зарегистрирован: 12.11.2004 0:20
Поблагодарили: 13 раз
Контактная информация:

Сообщение VVVas » 09.01.2008 12:25

rubin писал(а):что можно исправить?
Зайти в свой профиль.
rubin писал(а):как убрать неактивные после обновления функции в админпанели?
После правильного обновления таковых нет. Вы видимо не правильно обновились.
я люблю daft punk | новый sugoi.ru

rubin
phpBB 1.0.0
Сообщения: 2
Зарегистрирован: 09.01.2008 11:45

Сообщение rubin » 09.01.2008 14:04

Зайти в свой профиль.
Я про общую установку языка... чтобы гости при заходе видели русский, а не английский...
Возможно кривое обновление, попробую по новой

FirSveta
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 22.11.2007 12:56

Сообщение FirSveta » 03.03.2008 8:55

версия моего форума phpBB 2.0.22.,
на форуме отображается сообщение: Ваша версия phpBB не самая последняя. Для неё доступны обновления, пожалуйста зайдите по адресу http://www.phpbb.com/downloads.php для получения последней версии.
Последняя доступная версия phpBB 2.0.23. Ваша версия phpBB 2.0.22.

Но появилась новаяверсия phpBB3.0, могу ли я обновить форум до версии phpBB3.0 или только до 2.0.23?

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 03.03.2008 9:11

FirSveta
3.0.0 - Это не новая версия. Это совсем другая версия.
Обновить, в общепринятом смысле - не можете, сконвертировать - можете. Почитайте FAQ-3.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

B1zkit
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 03.05.2008 2:10

Сообщение B1zkit » 03.05.2008 3:45

при обновлении до версии 2.0.20 требуется изменить файл db/mssql.php , но у меня в этой папке находится только файл mysql.php и ни одна строка, указанная в codechanges там не присутствует.

Закрыто

Вернуться в «FAQ (phpBB 2.0.x)»