Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекращает поддержку phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2020 года.
С учетом этого, а также того, что версия 3.2.x больше не будет получать обновлений, за исключением связанных с проблемами безопасности
(только при их наличии и только до 7 ноября 2020 года), рекомендуется обновить конференции до версии 3.3.x.

3.2.11 ошибка PHP

Проблемы с установкой или работой phpBB 3.2.x? Получите помощь здесь!
Внимание: с 7 ноября 2020 года phpBB Group завершает дальнейшее развитие phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до отдельного объявления.

Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rodriguez66
phpBB 1.0.0
Сообщения: 5
Стаж: 4 месяца
Откуда: Екатеринбург

3.2.11 ошибка PHP

Сообщение rodriguez66 »

Привет!
При попытке запустить установку 3.2.11-ru получаю ошибку
You are running an unsupported PHP version. Please upgrade to PHP equal to or greater than 5.4.7 but less than 7.3-dev in order to install or update to phpBB 3.2

Вы используете неподдерживаемую версию PHP. Пожалуйста, обновите PHP до версии 5.4.7 или выше, но ниже 7.3-dev, чтобы установить или обновить phpBB 3.2.

говорит о том, что версия PHP не та..

Инфа о хостинге:
Apache 2.4.6-93.el7.centos
PHP 5.4.16-48.el7
Perl 5.16.3-295.el7
Kernel 3.10.0-1160.15.2.el7.x86_64

PS: до кучи нужно выполнить перенос с SMF 2.0.18. На версию 3.3.3 перенеслись только названия разделов и затерлись все пользователи. Темы даже не перенеслись. :evil:
Аватара пользователя
rodriguez66
phpBB 1.0.0
Сообщения: 5
Стаж: 4 месяца
Откуда: Екатеринбург

Re: 3.2.11 ошибка PHP

Сообщение rodriguez66 »

ах да, подскажите в чем проблема :oops:
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10628
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3007 раз

Re: 3.2.11 ошибка PHP

Сообщение Татьяна5 »

phpBB 3.2.x - системные требования
Всё так, версия php несовместима
Аватара пользователя
rodriguez66
phpBB 1.0.0
Сообщения: 5
Стаж: 4 месяца
Откуда: Екатеринбург

Re: 3.2.11 ошибка PHP

Сообщение rodriguez66 »

Татьяна5 писал(а): 19.03.2021 20:49 Всё так, версия php несовместима
но как же?
инфа из требований PHP 5.4.7 и выше, а версия на хостинге 5.4.16-48.el7, что явно выше. Может я что-то не понимаю? 3.3.3 нормально установилась
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10628
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3007 раз

Re: 3.2.11 ошибка PHP

Сообщение Татьяна5 »

rodriguez66 писал(а): 19.03.2021 20:51 3.3.3 нормально установилась
А вот это уже баг. Там минимальная версия 7.1.3
Аватара пользователя
rodriguez66
phpBB 1.0.0
Сообщения: 5
Стаж: 4 месяца
Откуда: Екатеринбург

Re: 3.2.11 ошибка PHP

Сообщение rodriguez66 »

Татьяна5 писал(а): 19.03.2021 20:53 ам минимальная версия 7.1.3
возможно с этим связаны косяки при попытке конвертации. Попробую на хостинге поменять версию PHP.
Спасибо :hat

Отправлено спустя 6 минут 25 секунд:
Новая информация: все таки на хостинге была версия PHP 7.3, которая доступна для 3.3.3, но недоступна для 3.2.11
PS интерфейс они забыли обновить...
Аватара пользователя
rodriguez66
phpBB 1.0.0
Сообщения: 5
Стаж: 4 месяца
Откуда: Екатеринбург

Re: 3.2.11 ошибка PHP

Сообщение rodriguez66 »

UPD: заменил PHP на 7.2 и установка завелась. Остался вопрос по переносу SMF 2.0.18 на PHPBB. Или лучше новую тему создать? Существующие темы по переносу вообще малоинформативны, что тут, что на офф сайте. :?
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10628
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3007 раз

Re: 3.2.11 ошибка PHP

Сообщение Татьяна5 »

Новую. По конвертации в 3.3 тем ещё нет

Вернуться в «Поддержка phpBB 3.2.x»