[3.1] Не работает поиск по сообщениям

Форум для авторов расширений для phpBB. Здесь можно попросить помощи в разработке у коллег.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB3.1.x | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

[3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » 13.09.2017 18:25

Я создаю новые топики и посты путем прямой записи в БД. Проблема в том что не работает поиск по данным постам.
В какой таблице нужно создавать запись, чтобы эти посты также индексировались при поиске ?


Аватара пользователя
Sheer
Поддержка
Поддержка
Сообщения: 9459
Зарегистрирован: 18.02.2007 19:01
Откуда: Рига, Латвия (страна-недоразумение)
Благодарил (а): 36 раз
Поблагодарили: 1943 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Sheer » 13.09.2017 18:59

Hardc0re писал(а):
13.09.2017 18:25
путем прямой записи в БД
... а чтобы созданные таким варварским способом сообщения попали в Поиск, нужно пересоздать поисковые индексы в ACP и еще синхронизировать форумы там же.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » 14.09.2017 12:17

rxu писал(а):
13.09.2017 18:27
FAQ] Как программно добавить тему / пост / личное сообщение
Не подскажете как передавать изображения и url в тексте чтобы они корректно отображались в постах ?
Если передаю просто текстом то в заголовок добавляет тег <t>

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 13387
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 297 раз
Поблагодарили: 1248 раз
Контактная информация:

Re: [3.1] Не работает поиск по сообщениям

Сообщение rxu » 14.09.2017 12:21

Hardc0re писал(а):
14.09.2017 12:17
в заголовок добавляет тег <t>
Это вы в БД напрямую смотрите? Если да, так и должно быть.
Изображение

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » 14.09.2017 12:27

rxu писал(а):
14.09.2017 12:21
Это вы в БД напрямую смотрите? Если да, так и должно быть.
нет, проблема была в длине строки, и тег <t> не закрывался, вот и на форуме заголовки отображались некорректно.

Но вопрос о том как передавать ссылки на изображения, чтобы они отображались как изображения и как добавлять ссылку на текст все еще открытый.

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 13387
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 297 раз
Поблагодарили: 1248 раз
Контактная информация:

Re: [3.1] Не работает поиск по сообщениям

Сообщение rxu » 14.09.2017 13:05

Hardc0re писал(а):
14.09.2017 12:27
как передавать ссылки на изображения
Стандартно, в тегах [img].
Hardc0re писал(а):
14.09.2017 12:27
как добавлять ссылку на текст
Что имеется ввиду?
Изображение

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » 14.09.2017 13:34

уже разобрался, большое спасибо.

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » 15.09.2017 12:19

Появилась новая проблема. В title страницы отображает тег <t>
Изображение

Также при поиске отображает теги, хот я самом топике все окей.
Изображение

Моя функция постинга:

Код: Выделить всё

function addToPhpBB($mode,$title,$text,$time,$topicId = 0)
{
    $poll = $uid = $bitfield = $options = '';

    generate_text_for_storage($title, $uid, $bitfield, $options, false, false, true);
    generate_text_for_storage($text, $uid, $bitfield, $options, true, true, true);

    $data = array(
        'forum_id'		=> Config::FORUM_ID,
        'icon_id'		=> false,
        'topic_id'      => $topicId,
        'enable_bbcode'		=> true,
        'enable_smilies'	=> true,
        'enable_urls'		=> true,
        'enable_sig'		=> true,

        'message'		=> $text,
        'message_md5'	=> md5($text),

        'bbcode_bitfield'	=> $bitfield,
        'bbcode_uid'		=> $uid,

        'post_edit_locked'	=> 0,
        'topic_title'		=> $title,
        'notify_set'		=> false,
        'notify'			=> false,
        'post_time' 		=> $time,
        'forum_name'		=> '',
        'enable_indexing'	=> true,
    );

    $url = submit_post($mode, $title, '', POST_NORMAL, $poll, $data);

    if(strcmp($mode, 'reply') == 0)
    {
        return $url[strlen($url)-1];
    }
    $post = strpos($url, 't=') + 2;
    $last = strpos($url, '&',$post);

    return substr($url, $post,$last - $post);
}

Аватара пользователя
Татьяна5
Former team member
Сообщения: 6858
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 134 раза
Поблагодарили: 1960 раз

Re: [3.1] Не работает поиск по сообщениям

Сообщение Татьяна5 » 15.09.2017 12:30

Hardc0re писал(а):
15.09.2017 12:19

Код: Выделить всё

generate_text_for_storage($title, $uid, $bitfield, $options, false, false, true);
Это лишнее

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » Вчера 9:18

В общем проблема с поиском состоит в том что не генерируется uid -_-, хотя в доках написано "will be modified by generate_text_for_storage"
Т.е. нужно как то самому генерировать $uid.
Изображение

Аватара пользователя
Татьяна5
Former team member
Сообщения: 6858
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 134 раза
Поблагодарили: 1960 раз

Re: [3.1] Не работает поиск по сообщениям

Сообщение Татьяна5 » Вчера 9:24

Лишний generate_text_for_storage уберите - будет генерироваться

Hardc0re
phpBB 1.0.0
Сообщения: 9
Зарегистрирован: 24.08.2017 12:18
Благодарил (а): 4 раза

Re: [3.1] Не работает поиск по сообщениям

Сообщение Hardc0re » Вчера 9:27

Уже давно убрал, генерирую только для текста.

Аватара пользователя
Татьяна5
Former team member
Сообщения: 6858
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 134 раза
Поблагодарили: 1960 раз

Re: [3.1] Не работает поиск по сообщениям

Сообщение Татьяна5 » Вчера 9:28

Сама функция в том файле подключена?
Такое впечатление, что не отрабатывает

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 13387
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 297 раз
Поблагодарили: 1248 раз
Контактная информация:

Re: [3.1] Не работает поиск по сообщениям

Сообщение rxu » Вчера 9:37

Hardc0re писал(а):
Вчера 9:18
не генерируется uid
Если phpBB 3.2, то uid не нужен, там другой парсер. Не мучайтесь.
Изображение

Ответить

Вернуться в «Для авторов»