Coppermine Photo Gallery и phpbb2

Ответы на вопросы, связанные с модами для phpBB 2.0.x, кроме относящихся к форуму Для авторов (phpBB 2.0.x).
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Зарегистрирован: 27.06.2005 1:07
Поблагодарили: 44 раза
Контактная информация:

Сообщение Rayden » 08.12.2007 14:42

Verades
Ох.... выставить в браузере принудительно кодировку Кирилица win-1251
phpBB2 FAQ
phpBB3 FAQ

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 08.12.2007 15:38

Verades
Или зарегиться на форуме и выставить в профиле русский язык. Намного удобне.
А где приказ, о чем нам нужно думать?!

Dvictori
phpBB 1.0.0
Сообщения: 5
Зарегистрирован: 08.12.2007 0:21

Сообщение Dvictori » 09.12.2007 0:47

У меня проблемка с кодировкой в Coppermine Photo Gallery, русский язык в скрипте работает - всё нормально, Но при вводе в настройках названия сайта, описания или добавления коментариев и т.д - вопросительные знаки. (скорее всего проблема в самой базе данных, а в ней я дуб!).
Раньше при заливке и установки какого-либо скрипта была такая же проблема... решал эту проблему путем добавления что-то вроде :
mysql_query ("set character_set_client='cp1251'"); mysql_query ("set character_set_results='cp1251'"); mysql_query ("set collation_connection='cp1251_general_ci'");

Добавлял я в скрипт, который конектит к базе данных...

Подскажите, как решить данную проблему... может в какой-то скрипт нужно дабавить что-то вроде этого...если так, то скажите в какой скрипт и куда именно...
Заранее благодарен!!!

"Dvictori
Какой коппермайн? Последние версии в ютф работают."

Coppermine version: 1.3.3

Добавлено спустя 1 час 33 минуты 54 секунды:

И ещё одно... поставил в базе данных MySQL кодировку cp1251_general_ci ... даже переустановил скрипт галереи... но нифига!
Потом залез в таблицу config, в ней также ??? - знаками вопросов отображает gallery_description и gallery_name ( также с названиями альбомов и коментариями ...)... Попробывал изменить в ручную, но всёравно они обратно в базе данных показывают вопросы (т.е если даже в ручную поменять, то они всёравно вопросы будет показывать)
Вообщем, кто сталкивался с этой проблемой, помогите!
Заранее спасибо!

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 09.12.2007 1:27

Dvictori
А Вы не пробовали в конфиге в настройках кодировки defolt выставить?
А где приказ, о чем нам нужно думать?!

Dvictori
phpBB 1.0.0
Сообщения: 5
Зарегистрирован: 08.12.2007 0:21

Сообщение Dvictori » 09.12.2007 16:24

Default? Менял, но может не на то...
Там в основном левые, не русские кодировки. Там только одна нормальная на сколько я знаю Unicode (utf-8), и её ставил та же фигня..

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 09.12.2007 17:19

Наоборот, поставить default, тот, кот. не рекомендуется. И посде этого переписать названия в настройках по-новой
А где приказ, о чем нам нужно думать?!

Dvictori
phpBB 1.0.0
Сообщения: 5
Зарегистрирован: 08.12.2007 0:21

Сообщение Dvictori » 09.12.2007 20:02

Да, меняю на другой ... переписываю названия всё гуд... только язык то галереи по этой кодировке не русской стоит...
Получается ещё хуже...Галлерея на арабском, зато название и описание сайта на русском :-)

Добавлено спустя 8 минут 35 секунд:

Впринципе если в файле Russian вместо windows-1251 написать целиком windows-1251_general_ci то название и описание будет норм.
Только мне не это так надо, как то, что при создании альбома, коментарии вообщем всего того что лезет в базу данных - отображается знаками вопросов...я выше писал что:
скорее всего проблема в самой базе данных, а в ней я дуб!.
Раньше при заливке и установки какого-либо скрипта была такая же проблема... решал эту проблему путем добавления что-то вроде :
mysql_query ("set character_set_client='cp1251'"); mysql_query ("set character_set_results='cp1251'"); mysql_query ("set collation_connection='cp1251_general_ci'");

Добавлял я в скрипт, который конектит к базе данных...

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 10.12.2007 21:11

Я перекодировала все языковые файлы из соответвующей папки в 1251, после чего выставляла в настройках default. Срабатывало.

Вот тут еще можно глянуть:
http://coppermine-gallery.net/forum/ind ... ic=31872.0
А где приказ, о чем нам нужно думать?!

Аватара пользователя
TheHawk
phpBB 1.4.4
Сообщения: 130
Зарегистрирован: 21.02.2007 18:04
Откуда: Беларусь, Гомель

Сообщение TheHawk » 16.12.2007 17:57

Хотелось бы узнать немного о возможностях этой галереи, похоже в ней много чего нужного делать нельзя.

Как например можно сделать так, чтобы можно было вылаживать фотографии с реалок сети, при этом чтобы они не относились ни к 1 пользователю ?
Пусть предположим так сделать нельзя, но есть человек который будет их вылаживать на свой логин. Дабы это лучше всего выглядело, нужно создать отдельную категорию. Как в этой категории дать права на вылаживание фотографий только ему?

Проколупался 2 часа и в самой галерее и в phpmyadmin с базой, но так ничего и не получилось.
Версия галереи 1.4.12 и она интегрирована в форум.
Изображение

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 17.12.2007 7:07

TheHawk
А "галерея пользователя" не подойдет? Обязательно общественная?
Если подойдет - то ее можно в настройках включить
А где приказ, о чем нам нужно думать?!

Аватара пользователя
TheHawk
phpBB 1.4.4
Сообщения: 130
Зарегистрирован: 21.02.2007 18:04
Откуда: Беларусь, Гомель

Сообщение TheHawk » 18.12.2007 1:40

Lela-la писал(а):Если подойдет
Не подойдёт, нужно чтобы все эти фотографии видели.
Изображение

Аватара пользователя
Lela-la
phpBB 1.4.2
Сообщения: 50
Зарегистрирован: 17.05.2007 15:45
Откуда: Москва
Контактная информация:

Сообщение Lela-la » 18.12.2007 7:17

Запрети приват. Или, в настройках конкретного альбома не делай его приватным.
По умолчанию фотки из этих альбомов высвечиваются в "последних добавлениях".

Или еще вариант: создать общий альбом, дать права для загрузки в этот альбом посетителям (идет в соответствии с правами групп). Единственное, после интеграции с phpbb у меня не получается работать с группами пользователей. ЛИбо я не разобралась, либо все посетители смогут загружать в него.
А где приказ, о чем нам нужно думать?!

Kassper
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 19.12.2007 10:55
Контактная информация:

Сообщение Kassper » 19.12.2007 10:57

Ребята!!! У меня такой вопрос!!!! Все было прекрасно, галерея работала нормально, но тут я захожу, вчера, и вижу надпись: Fatal Error:, я просто в шоке! Думал, мало ли, пройдет, но не тут то было! Я даже не могу понять в чем причина, и что вообще могло произойти!?

Может кто в курсе?!

Вот адрес галереи: www.avril-gallery.ru

:? :cry:

Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 19.12.2007 12:14

Kassper писал(а):Может кто в курсе?!
Наверное, вы. (потому что кроме вас никто ошибки не видел, а телепат у нас недавно уволился)
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

Kassper
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 19.12.2007 10:55
Контактная информация:

Сообщение Kassper » 19.12.2007 12:19

ДА?! А причем тут телепат?! Если бы я видел ошибку, тогда бы возможно было бы куда легче, а то вдруг откуда не возьмись, пишет: Fatal error!!! Странно! :cry:

Закрыто

Вернуться в «Поддержка модов для phpBB 2.0.x»