Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

Белые (пустые) страницы

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »


rightmiha
phpBB 1.2.1
Сообщения: 27
Зарегистрирован: 23.01.2010 14:36
Благодарил (а): 5 раз

Re: Белые (пустые) страницы

Сообщение rightmiha »

Вставляю строку -

Код: Выделить всё

$redirect_url = submit_post($mode, $post_data['post_subject'], $post_author_name, $post_data['topic_type'], $poll, $data, $update_message, ($update_message || $update_subject) ? true : false);
die("POST OK");

Белий, совсем белий.... но пост отправляется... :(

Добавлено спустя 1 час 43 минуты 37 секунд:
Перенес все на денвер, включил вообще все ошибки - вот что он мне показывает вместо белой страницы:

Код: Выделить всё

[phpBB Debug] PHP Warning: in file [ROOT]/posting.php on line 758: Invalid argument supplied for foreach()
[phpBB Debug] PHP Warning: in file [ROOT]/posting.php on line 758: Invalid argument supplied for foreach()
[phpBB Debug] PHP Warning: in file [ROOT]/posting.php on line 758: Invalid argument supplied for foreach()
[phpBB Debug] PHP Warning: in file [ROOT]/posting.php on line 758: Invalid argument supplied for foreach()
[phpBB Debug] PHP Warning: in file [ROOT]/posting.php on line 758: Invalid argument supplied for foreach()
Вот строка кода 758: foreach($array2 as $number => $array3)

Опа, а пот и кусок кода:

Код: Выделить всё

	// Parse Attachments - before checksum is calculated
	// BEGIN custom mod [url=http://www.phpbbguru.net/community/topic36446.html]Простой мульти аплоад для phpbb3 (массовая загрузка файлов)[/url]
	$_FILES_NEW = array();
	
	foreach ($_FILES as $form_name => $array1)
	{
		foreach($array1 as $key_name => $array2)
		{
			foreach($array2 as $number => $array3)
			{
				$_FILES_NEW[$form_name.$number][$key_name] = $_FILES[$form_name][$key_name][$number];
			}
		}
	}
	
	foreach ($_FILES_NEW as $form_name => $value)
	{
		$_FILES = array($form_name=>$value);
		$message_parser->parse_attachments($form_name, $mode, $forum_id, $submit, $preview, $refresh);
	}
	// END custom mod
Теперь уже сложно сказать, это ли привело к белой странице, так как я умудрился обновить версию форума, но проблему это не решило,..и возможностал глючить сам мод. Я запутался окончательно...

Удалил эти строки - вывело POST OK
Белые (пустые) страницы
но почему-то только пару раз, отправляю сообщения еще - опять белая страница.

Код: Выделить всё

$redirect_url = submit_post($mode, $post_data['post_subject'], $post_author_name, $post_data['topic_type'], $poll, $data, $update_message, ($update_message || $update_subject) ? true : false);
die("POST OK");
не срабатывает.....
Последний раз редактировалось Татьяна5 16.02.2014 11:18, всего редактировалось 1 раз.
Причина: [code]

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Если заменить posting.php на чистый - ошибка пропадает?

rightmiha
phpBB 1.2.1
Сообщения: 27
Зарегистрирован: 23.01.2010 14:36
Благодарил (а): 5 раз

Re: Белые (пустые) страницы

Сообщение rightmiha »

Проблема решена, помог решить Pazh. Была проблема с формированием очереди уведомлений, как раз поэтому и был белый экран при всех действиях при которых отсылалось уведомление: (спасибо за пост, лс, ответы в теме) УРА :)

Еще раз спасибо Pazh.

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

Друзья, прошу помощи, после сбоя на сервере хостера при отправке ЛС после отправки выбрасывает на белую страницу.
Проделал операцию как указано в первом сообщении результат ниже:
На белой странице выдало сообщение:
ini_set('display_errors', 'on');
В адресной строке следующий текст:
http://мой домен/ucp.php?i=pm&mode=compose&action=post&sid=e9f5df1ce8fab32be95800a8f3084014
Пожалуйста подскажите как исправить.
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Востриков писал(а):На белой странице выдало сообщение:
ini_set('display_errors', 'on');
Добавили строку не по инструкции

config.php
Найти Добавить до

Код: Выделить всё

ini_set('display_errors', 'on');

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

Вставил так: ini_set('display_errors', 'on');?>
Результат та же чистая страница. Что то опять наверное сделал не верно.
Ход моих действий:
1. в файле config.php добавил перед надписью ?> в той же строке символы ini_set('display_errors', 'on');
2. прошел на форум в отправку личного сообщения на форуме после отправки выпадает чистая страница (так же было до изменения файла config.php)
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

Такая же ситуация при отправке ответа в теме форума через полную форму ответа. Сообщение на форуме появляется но после нажатия клавиши ответить вываливается чистое белое окно.
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Востриков писал(а):в той же строке
Не в той же, а до строки

Код: Выделить всё

ini_set('display_errors', 'on');
?>
В error_logs есть ошибки?

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

ini_set('display_errors', 'on');
?>

Так тоже белая страница.
Где найти error_logs ? Извините за неопытность :)
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Дебаг включён?
http://www.phpbbguru.net/useful/general ... g-php/#dbg
Востриков писал(а):Где найти error_logs ?
Где-то на сервере, выше папки с форумом (на разных хостингах по-разному)

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

Вот мой конфиг:

Код: Выделить всё

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli';
$dbhost = 'localhost';
$dbport = '';
$dbname = '***';
$dbuser = '***';
$dbpasswd = '***';
$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>
Добавлено спустя 2 минуты 41 секунду:
Мои последние ошибки:

Код: Выделить всё

178.154.204.250 - - [01/Mar/2014:01:23:14 +0400] "GET /viewtopic.php?f=40&t=870&p=48443&sid=0879e98fcf3977b0e51cce71aed33729 HTTP/1.0" 200 38614
95.64.238.40 - - [01/Mar/2014:01:23:45 +0400] "GET /viewtopic.php?f=26&t=339&start=390 HTTP/1.0" 200 68810
81.7.10.146 - - [01/Mar/2014:01:23:51 +0400] "GET /thankslist.php?mode=givens&author_id=1890&give=true HTTP/1.0" 200 7079
81.7.10.146 - - [01/Mar/2014:01:23:53 +0400] "GET /thankslist.php?mode=givens&author_id=474&give=false HTTP/1.0" 200 7079
81.7.10.146 - - [01/Mar/2014:01:23:56 +0400] "GET /thankslist.php?mode=givens&author_id=538&give=true HTTP/1.0" 200 7079
81.7.10.146 - - [01/Mar/2014:01:24:00 +0400] "GET /thankslist.php?mode=givens&author_id=932&give=false HTTP/1.0" 200 7079
81.7.10.146 - - [01/Mar/2014:01:24:02 +0400] "GET /thankslist.php?mode=givens&author_id=932&give=true HTTP/1.0" 200 7079
81.7.10.146 - - [01/Mar/2014:01:24:03 +0400] "GET /viewtopic.php?f=17&t=379 HTTP/1.0" 200 45410
81.7.10.146 - - [01/Mar/2014:01:24:05 +0400] "GET /viewtopic.php?f=17&t=379&view=next HTTP/1.0" 200 45808
81.7.10.146 - - [01/Mar/2014:01:24:07 +0400] "GET /viewtopic.php?f=17&t=379&view=previous HTTP/1.0" 200 40204
81.7.10.146 - - [01/Mar/2014:01:24:08 +0400] "GET /viewtopic.php?f=17&t=508&start=50 HTTP/1.0" 200 22968
81.7.10.146 - - [01/Mar/2014:01:24:10 +0400] "GET /viewtopic.php?f=22&t=162&start=220 HTTP/1.0" 200 39970
81.7.10.146 - - [01/Mar/2014:01:24:11 +0400] "GET /viewtopic.php?f=22&t=224&start=140 HTTP/1.0" 200 31202
81.7.10.146 - - [01/Mar/2014:01:24:13 +0400] "GET /viewtopic.php?f=36&t=174&start=430 HTTP/1.0" 200 47156
81.7.10.146 - - [01/Mar/2014:01:24:15 +0400] "GET /viewtopic.php?f=6&t=203 HTTP/1.0" 200 44603
81.7.10.146 - - [01/Mar/2014:01:24:16 +0400] "GET /viewtopic.php?f=6&t=203&start=130 HTTP/1.0" 200 43851
81.7.10.146 - - [01/Mar/2014:01:24:18 +0400] "GET /viewtopic.php?f=6&t=203&start=140 HTTP/1.0" 200 47340
81.7.10.146 - - [01/Mar/2014:01:24:20 +0400] "GET /viewtopic.php?f=6&t=557 HTTP/1.0" 200 43695
81.7.10.146 - - [01/Mar/2014:01:24:22 +0400] "GET /viewtopic.php?f=6&t=557&start=40 HTTP/1.0" 200 55269
81.7.10.146 - - [01/Mar/2014:01:24:23 +0400] "GET /viewtopic.php?f=7&t=241&start=150 HTTP/1.0" 200 29481
81.7.10.146 - - [01/Mar/2014:01:24:25 +0400] "GET /viewtopic.php?f=7&t=994&start=30 HTTP/1.0" 200 50584
81.7.10.146 - - [01/Mar/2014:01:24:27 +0400] "GET /viewtopic.php?f=7&t=994&start=40 HTTP/1.0" 200 19714
81.7.10.146 - - [01/Mar/2014:01:24:29 +0400] "GET /viewtopic.php?f=9&t=448 HTTP/1.0" 200 38311
91.211.104.25 - - [01/Mar/2014:01:24:42 +0400] "GET /search.php?search_id=active_topics HTTP/1.0" 200 68177
178.154.204.250 - - [01/Mar/2014:01:24:43 +0400] "GET /viewtopic.php?f=22&t=576&p=47870&sid=df061443c9fda57ac8387282f93e6a1c HTTP/1.0" 200 47807
95.64.238.40 - - [01/Mar/2014:01:25:03 +0400] "GET /search.php?search_id=active_topics HTTP/1.0" 200 69155
178.154.204.250 - - [01/Mar/2014:01:28:14 +0400] "GET /index.php?sid=ffae08c44f9179b8d5ea7d9167d0872c HTTP/1.0" 200 41894
178.154.204.250 - - [01/Mar/2014:01:28:43 +0400] "GET /search.php?st=7&sk=t&sd=d&sr=topics&sid=a38f4338f335b460fd2ba31b3cd70d55&search_id=active_topics HTTP/1.0" 200 72005
178.154.204.250 - - [01/Mar/2014:01:29:30 +0400] "GET /search.php?st=7&sk=t&sd=d&sr=topics&sid=fbfe8c391639d4b58cbd53d9c9867d1e&search_id=active_topics&start=75 HTTP/1.0" 200 15585
195.38.23.97 - - [01/Mar/2014:01:29:51 +0400] "GET /download/file.php?id=1121&t=1 HTTP/1.0" 304 -
178.154.204.250 - - [01/Mar/2014:01:31:21 +0400] "GET /viewtopic.php?f=23&p=48278&sid=06ab468acfbe004f5a28e1198019d02e HTTP/1.0" 200 41450
178.154.204.250 - - [01/Mar/2014:01:31:26 +0400] "GET /viewtopic.php?f=7&t=732&p=48344&sid=995ec01fe6889f6e6f8350f0930e0bbb HTTP/1.0" 200 34405
82.145.208.130 - - [01/Mar/2014:01:32:45 +0400] "GET /viewforum.php?f=9 HTTP/1.0" 200 70866
82.145.208.130 - - [01/Mar/2014:01:32:55 +0400] "GET /viewforum.php?f=9 HTTP/1.0" 200 70866
82.145.208.130 - - [01/Mar/2014:01:33:18 +0400] "GET /viewtopic.php?f=9&t=1320 HTTP/1.0" 200 26709
Судя по всему у хостера еще и дата сбита.
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Никогда не выкладывайте пароль для подключения к базе в открытый доступ ($dbname, $dbuser и $dbpasswd заменила звёздочками)


Код

Код: Выделить всё

// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
Замените на

Код: Выделить всё

@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
ini_set('display_errors', 'on');
и перейдите на страницу с ошибкой

Добавлено спустя 2 минуты 52 секунды:
Востриков писал(а):Мои последние ошибки
Там нет ошибок. Это больше похоже на access_log (лог доступа)

Аватара пользователя
Востриков
phpBB 1.4.0
Сообщения: 30
Зарегистрирован: 06.03.2014 12:34
Откуда: Москва
Благодарил (а): 4 раза

Re: Белые (пустые) страницы

Сообщение Востриков »

Поменял на

Код: Выделить всё

@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
ini_set('display_errors', 'on');
теперь вот так:

Код: Выделить всё

<?php
// phpBB 3.0.x auto-generated configuration file
// Do not change anything in this file!
$dbms = 'mysqli';
$dbhost = 'localhost';
$dbport = '';
$dbname = '****';
$dbuser = '****';
$dbpasswd = '*****';
$table_prefix = 'phpbb_';
$acm_type = 'file';
$load_extensions = '';

@define('PHPBB_INSTALLED', true);
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
ini_set('display_errors', 'on');
?>
Все равно страница чистая.
Последний раз редактировалось Татьяна5 06.03.2014 15:15, всего редактировалось 2 раза.
Причина: не забываем про [code]
Мой форум http://bogorodskoe.msk.ru

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10027
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 176 раз
Поблагодарили: 2781 раз

Re: Белые (пустые) страницы

Сообщение Татьяна5 »

Значит ищите лог ошибок (error_log), ошибка может отобразиться там

Вернуться в «Поддержка phpBB 3.0.х»