Белые страницы через некоторое время.

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14537
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 348 раз
Поблагодарили: 1556 раз

Re: Белые страницы через некоторое время.

Сообщение rxu » 28.06.2009 15:43

Dnepr писал(а):Версия phpBB: 3.0.3
Dnepr писал(а):Но не понял, с чего начать искать проблему.
Обновитесь до актуальной версии 3.0.5, иные не поддерживаются.
Изображение

Dnepr
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 28.06.2009 12:24

Re: Белые страницы через некоторое время.

Сообщение Dnepr » 28.06.2009 16:07

Тогда по порядку:
1. Все сделал как в рекомендации RawMind 19.05.2009 15:41
В папке кеша файлы начали создаваться с правами 666. Правильно?
Проверил, поганял форум - пока все работает. Надолго ли, если все так оставить.
Понял, что надо подождать день, чтобы убедиться, что проблема не в хостинге. Правильно?

rxu
Вы советуете обновиться до версии 3.0.5
Тогда подскажите, там также необходимо будет переписывать эти файлы(которые я сейчас менял), либо там уже этой проблемы нет?

Никита
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 07.05.2009 14:46

Re: Белые страницы через некоторое время.

Сообщение Никита » 29.12.2009 15:48

Товарищи, после прочтения этой и соседних тем я так и не понял, проблема была окончательно решена или нет? И какое решение?
Столкнулся с схожей проблемой на хостинге timeweb. Стоит phpbb 3.0.4 и куча модов (обязательно обновлюсь, как только решится эта проблема). До этого три месяца работало всё отлично, проблема возникла в последние 2 дня только. Причем может работать по полдня стабильно, а может неожиданно заглючить.
У хостера
Операционная система Linux 2.6
Версия Apache 1.3.43
Версия MySQL 5.0
Версия PHP 5.2.6 (подробнее)
Версия Perl 5.8.8
Заметил, что через некоторое время работы форума, когда в кэше оказывается побольше файлов, начинают отображаться или пустые страницы или с такой ошибкой
[Tue Dec 29 15:27:26 2009] [error] PHP Parse error: syntax error, unexpected $end in /home/o/ondrev/public_html/forum/cache/tpl_prosilver_posting_buttons.html.php on line 74
Зашёл поглядеть в кэше и заметил, что скомпилированные файлы шаблонов записаны не полностью, имеют неожиданные обрывы (тот самый unexpected end), в результате чего ничего и не работает.
В какую сторону копать? Суппорт хостинга предложил откатиться на версию форума до возникновения ошибки. Я изменения в форум последний раз вносил месяца два назад, а ошибка возникла вчера. Предполагаю, что какие-то косяки в технической части сервера имеются. Возможно, ошибки при записи на диск - или чудит сам жесткий или линух дурака валяет с доступом к файлам. И да, права слетали на файлы, пришлось всё переставлять по новой. На папку /cache стоит 777. В скриптах где идёт chmod заменил "родной" системной функцией из поста http://www.phpbbguru.net/community/post ... ml#p246278. Права на файлы кэша выставляются 666.
Результата - нет.

Аватара пользователя
DK7
Former team member
Сообщения: 1008
Зарегистрирован: 17.07.2006 15:52
Откуда: Кишинёв
Благодарил (а): 3 раза
Поблагодарили: 25 раз

Re: Белые страницы через некоторое время.

Сообщение DK7 » 29.12.2009 16:03

[Tue Dec 29 15:27:26 2009] [error] PHP Parse error: syntax error, unexpected $end in /home/o/ondrev/public_html/forum/cache/tpl_prosilver_posting_buttons.html.php on line 74
копайте в сторону ошибки. что там у вас?
а если слетели все права на директории и файлы, то похоже хостер что то химичит.

Никита
phpBB 1.0.0
Сообщения: 4
Зарегистрирован: 07.05.2009 14:46

Re: Белые страницы через некоторое время.

Сообщение Никита » 29.12.2009 16:28

копайте в сторону ошибки. что там у вас?
У нас там повреждённый файл. Причем повреждаются разные файлы рандомно.

Добавлено спустя 1 час 25 минут 48 секунд:
UPD. Проблема разрешилась (по крайней мере на текущий момент). И вправду закончилось место на жестком диске на сервере (при том, что мой запас не был исчерпан даже на треть). Суппорт отрапортовал, что место почищено, теперь должно работать нормально. Вот так.

Delta
phpBB 1.2.0
Сообщения: 16
Зарегистрирован: 18.03.2010 0:07
Благодарил (а): 1 раз

Re: Белые страницы через некоторое время.

Сообщение Delta » 02.01.2011 1:07

О! у меня похожая проблема!
Всех с Новым Годом!
Суть: После обновления 3.0.7-PL1 до 3.0.8 форума http://truck4x4.ru/forum/
Почти всё отключилось - пустые старницы. После восстановления с резервной копии панель администрирования не загружается...
Кэш я удалил через ftp - результат нулевой.
При переключении на английский администрирование доступно...
Как я понял, обновление касается только тем и языков...
Узкий специалист не в области программирования http://truck4x4.ru/forum/

Аватара пользователя
владимир1983
phpBB 3.1.9
Сообщения: 5954
Зарегистрирован: 27.04.2010 2:17
Откуда: Сергиев Посад
Благодарил (а): 391 раз
Поблагодарили: 730 раз

Re: Белые страницы через некоторое время.

Сообщение владимир1983 » 02.01.2011 3:04

Delta
Я пол часа назад видел что вы мод благодарностей ставите.
Так доступна админка, или нет?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)

Delta
phpBB 1.2.0
Сообщения: 16
Зарегистрирован: 18.03.2010 0:07
Благодарил (а): 1 раз

Re: Белые страницы через некоторое время.

Сообщение Delta » 02.01.2011 14:21

Вообще-то этот мод уже давно стоит... Во всяком случае, сейчас я его не трогал... Занимался откатом до 3.0.7 Админка пока недоступна, сейчас пытаюсь обновиться автоматически до 3.0.8.
Оказывается, PHPnuke не переваривает UTF хотя опция в настройках есть...
Ещё вопрос (чтоб не оффтопить)
Как задавать картинку, которая отображается во вкладке браузера? Значок страницы или как его? Интересует формат тега и куда его вписывать
Последний раз редактировалось Delta 02.01.2011 14:26, всего редактировалось 1 раз.
Узкий специалист не в области программирования http://truck4x4.ru/forum/

Аватара пользователя
владимир1983
phpBB 3.1.9
Сообщения: 5954
Зарегистрирован: 27.04.2010 2:17
Откуда: Сергиев Посад
Благодарил (а): 391 раз
Поблагодарили: 730 раз

Re: Белые страницы через некоторое время.

Сообщение владимир1983 » 02.01.2011 14:25

Тога смените текстовое сообщение: "Ставлю мод спасибок, работы на час" при включённой опции "Отключить конференцию". :)

Добавлено спустя 4 минуты 42 секунды:
favicon.ico в phpbb3
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)

Delta
phpBB 1.2.0
Сообщения: 16
Зарегистрирован: 18.03.2010 0:07
Благодарил (а): 1 раз

Re: Белые страницы через некоторое время.

Сообщение Delta » 02.01.2011 22:34

Очень интересно...
Там стоит "Отключить конференцию: нет" жалко прилепить к сообщению скриншот нельзя
После автоматического обновлениия и небольшого редактирования админка ожила. Там в обновлении значилось что-то из "includes", которе в Codechanges не значилось. А автоматическое обновление почему-то ставиться не хотело...
За favicon спасибо!
Узкий специалист не в области программирования http://truck4x4.ru/forum/

Delta
phpBB 1.2.0
Сообщения: 16
Зарегистрирован: 18.03.2010 0:07
Благодарил (а): 1 раз

Re: Белые страницы через некоторое время.

Сообщение Delta » 19.01.2011 0:04

Вообщем опять то же. Причем пустая страница только в "пользователи и группы" администраторского раздела и только на русском языке. Старые методы не помогают :(
Узкий специалист не в области программирования http://truck4x4.ru/forum/

Аватара пользователя
Alek$
Former team member
Сообщения: 2616
Зарегистрирован: 03.08.2005 13:46
Откуда: Новосибирск
Поблагодарили: 37 раз

Re: Белые страницы через некоторое время.

Сообщение Alek$ » 19.01.2011 15:58

Delta
Моды есть? Если нет, то перезалейте русификацию.
А вообще - Белые (пустые) страницы
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.

Rou
phpBB 1.0.0
Сообщения: 1
Зарегистрирован: 17.02.2011 12:14
Поблагодарили: 1 раз

Re: Белые страницы через некоторое время.

Сообщение Rou » 17.02.2011 12:39

Непонятно почему форум перестал работать, при запросе показывал пустую страницу.
Хостер : мастерхост, тариф : Доцент. Выставил разрешения на файл config.php в 644 и все заработало.

До этого в лог ошибок писалось :

Код: Выделить всё

[Thu Feb 17 11:13:08 2011] [error] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required './config.php' (include_path='.:/usr/local/share/pear') in /home/ццц/common.php on line 128
[Thu Feb 17 11:13:08 2011] [error] PHP Warning: require(./config.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /home/ццц/common.php on line 128
[Thu Feb 17 11:13:08 2011] [error] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required './config.php' (include_path='.:/usr/local/share/pear') in /home/ццц/common.php on line 128
[Thu Feb 17 11:13:09 2011] [error] PHP Warning: require(./config.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /home/ццц/common.php on line 128
[Thu Feb 17 11:13:09 2011] [error] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required './config.php' (include_path='.:/usr/local/share/pear') in /home/ццц/pc3000flash/common.php on line 128
[Thu Feb 17 11:13:14 2011] [error] PHP Warning: require(./config.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /home/ццц/common.php on line 128
[Thu Feb 17 11:13:14 2011] [error] PHP Fatal error: require() [<a href='function.require'>function.require</a>]: Failed opening required './config.php' (include_path='.:/usr/local/share/pear') in /home/ццц/common.php on line 128

Аватара пользователя
Пчелкин
phpBB 3.1.9
Сообщения: 10102
Зарегистрирован: 15.01.2010 13:57
Откуда: От Москвы 9 часов на Боинге
Благодарил (а): 1337 раз
Поблагодарили: 1297 раз

Re: Белые страницы через некоторое время.

Сообщение Пчелкин » 17.02.2011 13:29

Было пару раз подобное, когда файлы по ФТПи копировал командером и возвращал им же...Где этот командер сейчас....File Zilla рулит.Ни разу еще разрешения не меняла при сливе-заливе.

shvager
phpBB 1.4.4
Сообщения: 158
Зарегистрирован: 12.04.2008 9:20
Благодарил (а): 103 раза
Поблагодарили: 8 раз

Re: Белые страницы через некоторое время.

Сообщение shvager » 19.02.2011 12:53

Прошу поделится советом. Не так давно перестал грузится портал. Бела страница и больше ничего. Я не стал разбиратся - просто заменил файл portal.php. Заработало. Вчера перестала грузится админка.

Нашел причину:
В файле forum/adm/index.php на 306 строке -
Было:

Код: Выделить всё

$tpl = ($tpl_type_cond[0] == 'yes' || $tpl_type_con`[0] == 'enabled') ? $tpl_yes . $tpl_no : $tpl_no . $tpl_yes;
А должно быть:

Код: Выделить всё

$tpl = ($tpl_type_cond[0] == 'yes' || $tpl_type_cond[0] =='enabled') ? $tpl_yes . $tpl_no : $tpl_no . $tpl_yes;
Хостер молчит. Как такое в принцыпе могло случится?
Версия форума 3.0.8
Спасибо

Вернуться в «Поддержка phpBB 3.0.х»