Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

Вышел phpBB 3.3.0 бета/RC [обсуждаем]

Вопросы без привязки к версии. Установлена авточистка (2 года).
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Вышел phpBB 3.3.0 бета/RC [обсуждаем]

Сообщение rxu »

Изображение

Аватара пользователя
hd321kbps
phpBB 2.0.2
Сообщения: 301
Стаж: 8 лет 3 месяца
Откуда: Россия, Крым, Армянск
Благодарил (а): 135 раз
Поблагодарили: 336 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение hd321kbps »

Жаль, что каких-то визуальных изменений тут нет, кроме новой таблицы статистики в админке.
adm.jpg
По факту это та же версия 3.2.x, но с обновленными системными компонентами и удаленным устаревшим кодом.
Или все есть вероятность, что добавят что из визуальных новшеств в финальной версии?
Также заметил, что на странице регистрации добавили новый блок "Регистрация с использованием внешних служб аутентификации(Auth)".
Но проблема в том что он отображается пустым если аутентификация Auth выключена. Логичнее бы при этом скрывать этот блок. думаю разработчики просто проглядели этот момент.
reg.jpg
И интересно зачем ввели DateTime RFC3339? чем-то лучше прошлого? Зачем он вообще нужен?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение rxu »

hd321kbps писал(а):
24.10.2019 15:18
По факту это та же версия 3.2.x, но с обновленными системными компонентами и удаленным устаревшим кодом.
Именно.
hd321kbps писал(а):
24.10.2019 15:18
Или все есть вероятность, что добавят что из визуальных новшеств в финальной версии?
Нет, стиль прежний - prosilver.

Отправлено спустя 7 минут 55 секунд:
hd321kbps писал(а):
24.10.2019 15:18
на странице регистрации добавили новый блок "Регистрация с использованием внешних служб аутентификации(Auth)".
Но проблема в том что он отображается пустым если аутентификация Auth выключена.
https://github.com/phpbb/phpbb/pull/5717/files
Изображение

Аватара пользователя
hd321kbps
phpBB 2.0.2
Сообщения: 301
Стаж: 8 лет 3 месяца
Откуда: Россия, Крым, Армянск
Благодарил (а): 135 раз
Поблагодарили: 336 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение hd321kbps »

rxu писал(а):
24.10.2019 15:34
Нет, стиль прежний - prosilver.
Имеется в виду изменения такого рода: новый статут онлайна пользователя, замена значков форума на svg и тд.
Или всего этого ждать в 4.0?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение rxu »

hd321kbps писал(а):
24.10.2019 15:39
Или всего этого ждать в 4.0?
Да.
Изображение

Аватара пользователя
Sheer
phpBB Guru
phpBB Guru
Сообщения: 11568
Стаж: 13 лет 4 месяца
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2611 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение Sheer »

В 4.0 даже внешний вид админки принципиально иной. Ждите...
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.

Аватара пользователя
TaLLeR43
phpBB 1.4.4
Сообщения: 191
Стаж: 3 года 2 месяца
Откуда: Кикнур
Благодарил (а): 29 раз
Поблагодарили: 13 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение TaLLeR43 »

Не знаете, цветовую палитру улучшать будут? Или такая же останется

Аватара пользователя
hd321kbps
phpBB 2.0.2
Сообщения: 301
Стаж: 8 лет 3 месяца
Откуда: Россия, Крым, Армянск
Благодарил (а): 135 раз
Поблагодарили: 336 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение hd321kbps »

TaLLeR43 писал(а):
24.10.2019 23:30
Не знаете, цветовую палитру улучшать будут? Или такая же останется
Стиль полностью переделают
https://codepen.io/collection/Drjrjx/

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение rxu »

Тут тема про 3.3.
Про 4.0 тут
phpBB 4.0 Proteus
phpBB 4.0 Proteus: стиль
Изображение

Аватара пользователя
ronim
phpBB 2.0.4
Сообщения: 433
Стаж: 2 года 5 месяцев
Откуда: Таллин ,Эстония
Благодарил (а): 109 раз
Поблагодарили: 68 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение ronim »

Обновление с 3.28 до 3.3.0 бета1 не вызывает каких то проблем , но только при всех выключенных расширениях
обновлял на локалке
По скольку обновление на 3.3 неизбежно, предлагаю создать список расширение которые работают хотя бы без видимых ошибок.
поскольку у меня установленных расширений много, на данный момент я не могу составить вызывающих ошибку расширений . но претенденты уже нарисовываются .
Тут еще другой вопрос корректно ли все это обсуждать в этой теме или же следует создать отдельную ?
Если ты не видишь проблем на форуме , но это не значить что их там нет

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение rxu »

ronim писал(а):
26.10.2019 20:44
корректно ли все это обсуждать в этой теме или же следует создать отдельную ?
Пока корректно.
ronim писал(а):
26.10.2019 20:44
создать список расширение которые работают хотя бы без видимых ошибок.
С ошибками будут работать те расширения, у которых в config.yml и других конфигурационных файлах сервисы и параметры прописаны без кавычек.
Например: - @template, должно быть: - '@template'

Код: Выделить всё

        calls:
            - [set_config, [@config]]
            - [set_user_loader, [@user_loader]]
Должно быть:

Код: Выделить всё

        calls:
            - [set_config, ['@config']]
            - [set_user_loader, ['@user_loader']]
И т.д.
Либо ждать, когда авторы исправят, либо исправить самим.
Изображение

Аватара пользователя
TaLLeR43
phpBB 1.4.4
Сообщения: 191
Стаж: 3 года 2 месяца
Откуда: Кикнур
Благодарил (а): 29 раз
Поблагодарили: 13 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение TaLLeR43 »

rxu, а расширение быстрого ответа от Татьяны будет на бэтке работать?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15127
Стаж: 14 лет 1 месяц
Откуда: Красноярск
Благодарил (а): 388 раз
Поблагодарили: 1737 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение rxu »

Будет.
Изображение

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10114
Стаж: 8 лет 10 месяцев
Благодарил (а): 178 раз
Поблагодарили: 2816 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение Татьяна5 »

Работать будет, но оно не полностью совместимо

Аватара пользователя
ronim
phpBB 2.0.4
Сообщения: 433
Стаж: 2 года 5 месяцев
Откуда: Таллин ,Эстония
Благодарил (а): 109 раз
Поблагодарили: 68 раз

Re: Вышел phpBB 3.3.0 бета 1 [обсуждаем]

Сообщение ronim »

:rtfm: rxu,

Код: Выделить всё


Произошла ошибка phpBB при компиляции контейнера, связанная с одним из установленных расширений. По этой причине, все установленные расширения были временно отключены. Попробуйте очистить кэш конференции. Все расширения будут автоматически включены, если ошибка контейнера будет устранена. В противном случае, обратитесь на сайт официальной русской поддержки phpBB Guru для получения помощи.

Исключение: The file "E:\OSPanel\domains\forum\ext\alg\adminnotifications\config\services.yml" does not contain valid YAML: The reserved indicator "@" cannot start a plain scalar; you need to quote the scalar at line 7 (near "- @config").

#0 E:\OSPanel\domains\forum\vendor\symfony\dependency-injection\Loader\YamlFileLoader.php(117): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->loadFile('E:\\OSPanel\\doma...')
#1 E:\OSPanel\domains\forum\phpbb\extension\di\extension_base.php(99): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('services.yml')
#2 E:\OSPanel\domains\forum\phpbb\extension\di\extension_base.php(63): phpbb\extension\di\extension_base->load_services(Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#3 E:\OSPanel\domains\forum\vendor\symfony\dependency-injection\Compiler\MergeExtensionConfigurationPass.php(71): phpbb\extension\di\extension_base->load(Array, Object(Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationContainerBuilder))
#4 E:\OSPanel\domains\forum\vendor\symfony\http-kernel\DependencyInjection\MergeExtensionConfigurationPass.php(39): Symfony\Component\DependencyInjection\Compiler\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#5 E:\OSPanel\domains\forum\vendor\symfony\dependency-injection\Compiler\Compiler.php(140): Symfony\Component\HttpKernel\DependencyInjection\MergeExtensionConfigurationPass->process(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#6 E:\OSPanel\domains\forum\vendor\symfony\dependency-injection\ContainerBuilder.php(790): Symfony\Component\DependencyInjection\Compiler\Compiler->compile(Object(Symfony\Component\DependencyInjection\ContainerBuilder))
#7 E:\OSPanel\domains\forum\phpbb\di\container_builder.php(203): Symfony\Component\DependencyInjection\ContainerBuilder->compile()
#8 E:\OSPanel\domains\forum\common.php(115): phpbb\di\container_builder->get_container()
#9 E:\OSPanel\domains\forum\adm\index.php(23): require('E:\\OSPanel\\doma...')
#10 {main}

как я понимаю это подтверждение что вы написали выше ? получается надо лишь исправить то что выше опубликовано ?
Если ты не видишь проблем на форуме , но это не значить что их там нет

Вернуться в «phpBB-пространство»