Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

phpBB 3.3.x - системные требования

Темы по наиболее часто задаваемым вопросам без привязки к версии phpBB. Читать в первую очередь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15183
Стаж: 14 лет 2 месяца
Откуда: Красноярск
Благодарил (а): 390 раз
Поблагодарили: 1772 раза

phpBB 3.3.x - системные требования

Сообщение rxu »

Обязательные системные требования для установки phpBB 3.3.x:
  • Вебсервер под управлением любой операционной системы с поддержкой PHP
  • Сервер SQL, список поддерживаемых:
    • MySQL 4.1.3 и выше (только расширение MySQLi, расширение mysql не поддерживается!)
    • MariaDB 5.1 и выше
    • PostgreSQL 8.3+
    • SQLite 3.6.15+
    • MS SQL Server 2000 и выше (прямое подключение, либо через ODBC или нативный драйвер)
    • Oracle
  • PHP 7.1.3 - 7.4.х включительно.
  • Обязательные модули PHP:
    • json
    • XML
    • Соответствующий PHP-модуль для СУБД, которую вы собираетесь использовать
  • Доступность функции getimagesize().
  • Наличие следующих модулей PHP позволит получить дополнительные возможности (не обязательны):
    • Поддержка сжатия zlib
    • Поддержка удаленного доступа к FTP
    • Модуль GD
Изображение

Вернуться в «FAQ»