Это точно... и себя и других...
Мой совет - всё нах... и С нуля.
Браток писал(а):.Почему то редактирование отключено..
В этом форуме - да.
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
База данных залилась насервер, phpbb её видит под root-пользователем. Но я не вижу базу данных нb через панель хостера (directAdmin), ни через phpMyAdmin.
Попытался сделать бекап через phpMyAdmin, нажал на экспорт, у меня подвис браузер, я через 15 минут вышел из браузера.. не дождавшись, а вот теперь такая ошибка
Warning: mysql_connect(): Access denied for user 'login'@'fay.hc.ru' (using password: YES) in /www/rockvide/users/rockvide-forum/www/htdocs/db/mysql4.php on line 48
Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /www/rockvide/users/rockvide-forum/www/htdocs/db/mysql4.php on line 330
Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /www/rockvide/users/rockvide-forum/www/htdocs/db/mysql4.php on line 331
phpBB : Critical Error
Could not connect to the database
Подскажите, господа, такую вещь.
Вот вчера восстанавливал БД на другом хостинге через Супер дампер.
Значит, залил упакованную базу в папку /dumper/backup, создал нахостинге пустую базу MySQL и запустил восстановление. Процесс в виде шкал стоял на месте и браузер молчал ("Готово"), но при наблюдении базы через PhpMyAdmin выяснилось, что база восстанавливается, хоть прогресса через интерфейс СуперДамера и не видно.
Вопрос: из 46 таблиц восстановилось только 40. Если я запущу восстановление заново, она "довосстановится сама"? Или будет все делать сначала?
Добавлено спустя 1 минуту 56 секунд:
Забыл сказать: размер базы в неупакованном виде 210 Мб в упакованном около 50 Мб.
AlexMen писал(а): прогресса через интерфейс СуперДамера и не видно.
страница браузера не обновлялась
AlexMen писал(а):она "довосстановится сама"? Или будет все делать сначала?
В зависимости от дампа. Если стояло условие: сброс таблиц перед созданием, то сначала.
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
AlexMen писал(а):Вопрос: из 46 таблиц восстановилось только 40. Если я запущу восстановление заново, она "довосстановится сама"? Или будет все делать сначала?
Выкусите из дампа вручную 6 оставшихся таблиц и запустите процессна обкромссаном дампе. Если не восстановились поисковые таблицы, то проще и правильнее оставить в дампе только то, что касается их структуры и потом выполнить реиндекс.
Добавлено спустя 44 секунды:
AlexMen писал(а):А где ставится это условие?
В дампе. слова "DROP TABLE..."
Добавлено спустя 1 минуту 7 секунд:
AlexMen писал(а):А обновлять страницу браузера вручную надо, что ли???
А вы там авторефреш видели?
И если я неправ, пусть старшие товарищи поправят меня
Добрый день!
Ответьте пожалуйста по какой причине при переносе сайта с www на локальный диск, сохраняются название форумов, а темы в самих форумах отсутствуют, хотя в заголовке отображается количество тем,
пробовала Восстановлением базы насамом форуме, а также Импорт базы через PHPMyAdmin?
Выдает след. сообщение: При восстановлении форума ошибки - 1062 Duplicate entry Объекты For key 1.
Line 980 file admin_db_utilities.php, какие изменения нужно выполнить на данной строке в файле admin_db_utilities.php?