Наименование модификации: Thanks for post Описание::
Открыть
Мод добавляет возможность поблагодарить автора сообщения (отменить благодарность).
Опции реализованы включением добавленного права доступа к форумам. При установке право добавлено в роли Стандартный доступ, Ограниченный доступ, Стандартный доступ с опросами, Ограниченный доступ с опросами и Полный доступ. (Если вы хотите установить другие настройки: перейдите в Администраторский раздел - Права доступа - Локальные права - Права доступа к форумам и выберите форумы, где вы хотите иметь функцию благодарностей за сообщения. Разрешите право "Может благодарить за сообщения" на вкладке Разное).
Переключатели выбора опций получения уведомлений о благодарностях (в ЛС и по email) в Личном разделе - Личные настройки.
Настройки опций, в том числе обновление счётчиков после массового удаления сообщений/тем/пользователей, слияния учетных записей, смены автора сообщения, разделения/слияния тем и т.п. - в Администраторском разделе - Модули - Благодарности - Обновление счётчиков.
Для просмотра списка благодарностей нужно разрешить глобальное пользовательское право - "Может просматривать лист благодарностей" на вкладке Разное. При установке право добавлено в роли Стандартные возможности, Ограниченные возможности, Все возможности, Без личных сообщений, Без аватары и членам группы Зарегистрированные пользователи.
Для просмотра топлиста нужно разрешить глобальное пользовательское право - "Может просматривать топлист" на вкладке Разное. При установке право добавлено в роли Стандартные возможности, Ограниченные возможности, Все возможности, Без личных сообщений, Без аватары и членам группы Зарегистрированные пользователи.
Для возможности очистки списков благодарностей нужно разрешить глобальное модераторское право - "Может очищать список благодарностей" на вкладке Разное. При установке право добавлено в роль Супермодератор и членам группы Супермодераторы.
В папке contrib вы можете найти файлы reput_star_.psd и thanks.psd для разработки собственных изображений под используемый вами стиль.
Система рейтинга для сообщений, тем и форумов, основанная на системе СПАСИБО.
Каждый объект (сообщение, тема или форум), набравший максимальное число СПАСИБО, принимается за 100% рейтинга (лидер). Остальные - как % от рейтинга лидера.
Например: Сообщение получило 10 СПАСИБО (100% or 10/10), другое сообщение 4 СПАСИБО (40% or 4 / 10), третье сообщение 1 СПАСИБО (10% or 1 / 10). Если первое сообщение получит ещё одно СПАСИБО (10 +1 = 11), рейтинг второго сообщения будет 36.36% или 4 / 11, у третьего сообщения - 9,09% или 1 / 11 и т.д.
Позиция рейтинга определяется числом СПАСИБО.
Рейтинг тем - суммой количества СПАСИБО у сообщений в теме.
Рейтинг форума - суммой количества СПАСИБО у сообщений в форуме.
Включение\выключение рейтинга для сообщений, тем и форумов - через административный раздел.
Возможно только цифровое или цифровое + графическое отображение рейтинга.
Есть топлист рейтинга. Число отображаемых позиций в топлисте устанавливается в административном разделе.
Важно! Для корректной работы системы рейтинга в базе данных не должно быть записей о благодарностях по отношению к удалённым, перемещённым сообщениям, или сообщениям от гостей (если ранее они были зарегистрированными пользователями). Вам необходимо использовать средство обновления счетчиков благодарностей после массового удаления постов, тем, пользователей или иных действий модераторов или администраторов (например, замена автора сообщения или объединение аккаунтов). Для корректной работы функции обновления счётчиков требуется MySQL версии 4.1 или выше.
Внимание для версии 1.3.2! В связи с обнаружением некорректной работы функции пересчета счетчиков МОДа в административном разделе следует использовать файл includes/acp/acp_thanks_refresh.php от версии 1.3.1
Убедитесь, что вы скопировали файлы-изображения в папку используемого вами стиля
Убедитесь, что вы отредактировали файлы используемого вами стиля
Обновите набор изображений вашего стиля (на вкладке Стили в админке)
Обновите тему вашего стиля (на вкладке Стили в админке)
Обновите кеш
Установите опции мода (вкладка Модули - Спасибо за сообщение)
Убедитесь, что правильно выставлены права доступа
Установите права доступа к форумув котором вы хотите иметь опцию благодарностей
При установке право добавлено в роль Стандартный доступ. (Если вы хотите установить другие настройки: перейдите в Администраторский раздел - Права доступа - Локальные права - Права доступа к форумам и выберите форумы, где вы хотите иметь функцию благодарностей за сообщения. Разрешите право "Может благодарить за сообщения" на вкладке Разное).
Установите права доступа к просмотру листа благодарностей
Для просмотра списка благодарностей нужно разрешить глобальное пользовательское право - "Может просматривать лист благодарностей" на вкладке Разное. При установке право добавлено в роль Стандартные возможности и членам группы Зарегистрированные пользователи.
Если вы хотите иметь другие настройки (у вас другая роль у зарегистрированных пользователей): Админка -> Права доступа -> Прав групп -> Выбор группы:Зарегистрированные пользователи -> Расширенные права -> Разное -> Может просматривать список благодарностей (Может видеть топлист) -> Применить все права Пошаговая инструкция в картинках (на английском)
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось Татьяна5 11.07.2014 8:16, всего редактировалось 12 раз.
Причина:Вынесла ссылки из-под спойлера
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
leshkakrash писал(а):После установки появляется такая ошибка:
Parse error: syntax error, unexpected '}' in ......./cache/tpl_art-deluxe_forumlist_body.html.php on line 92
Если поставить оригинальный файл forumlist_body.html, то этой ошибки нет, но и мод тогда не работает.
Кэш чистил...
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Учусь только работать с форумом и модами. Подскажите где ошибка и как лечить? (Если можно совсем для чайника)
Перенесла файлы, внесла исправления. При установке выдается
SQL ERROR [ mysql4 ]
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT forum_id FROM phpbb31_posts WHERE post_id = phpbb [1064]
SQL
UPDATE phpbb31_thanks SET forum_id = (SELECT forum_id FROM phpbb31_posts WHERE post_id = phpbb31_thanks.post_id)
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
При попытке загрзить зайти на форум вместо гланой станицы выдает
Fatal error: Call to undefined function: get_thanks_forum_reput() in /home/3353/s3737/public_html/phpBB3/includes/functions_display.php on line 507
Alena71 писал(а): При установке выдается SQL ERROR [ mysql4 ]
Здесь возможно срабатывает старая версия mysql (ниже чем 4.1)
Если вы ставите МОД с нуля, то это не страшно. Это не сработала функция обновления таблицы спасибок от старой версии МОДа (если бы вы делали обновление версии)
Alena71 писал(а):Fatal error: Call to undefined function: get_thanks_forum_reput() in /home/3353/s3737/public_html/phpBB3/includes/functions_display.php on line 507
Похоже вы ошиблись при редактировании кода файла includes/functions_display.php
Во всяком случае, если у вас phpbb 3.0.11, то вызов функции get_thanks_forum_reput() осуществляется в районе строки 520 (а не 507). Проверьте установку.
Добавлено спустя 14 минут 58 секунд:
Вышла версия 1.3.5
Исправлена ошибка при постинге с неопределенными параметрами
Исправлена ошибка в коде файла ucp_prefs.php
Исправлена ошибка настроки только первого сообщения в теме
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
обновился с 1.3.4 до 1.3.5 практически без проблем (за исключением пары мест, где по какой-то причине уже были правки от 1.3.5 - вероятно из-за мониторинга данной темы и внесения изменений еще до выхода финалрелиза).
пока полет нормальный :)
спасибо
HAMMER663 писал(а):danilas скажите версию мода спасибок
Прошу прощения, не получил уведомления об ответе в теме. Версия мода: 1.2.5. Текущая 1.3.5, но судя по спискам изменений там не было чего-то кардинально снижающего нагрузку.
danilas
Более чем. С версии 125 весь алгоритм переписывался дважды. Эта версия делалсь под phpbb 306, прошло уже три года, и запросы sql там весьма не оптимальны.
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Палыч у меня создалось впечатление, что при массовом удалении пользователей мод создает большую нагрузку на сервер, что у меня вместо 50 пользователей, удаляется около 10, потом выходит ошибка таймаута. Кто-то может подтвердить опровергнуть?
Alex1204 писал(а):Палыч у меня создалось впечатление, что при массовом удалении пользователей мод создает большую нагрузку на сервер, что у меня вместо 50 пользователей, удаляется около 10, потом выходит ошибка таймаута. Кто-то может подтвердить опровергнуть?
Такая же ерунда. Выбираю на удаление человек 50 - таймаут. Но с модом не задумывался связать. Может, действительно, он.
Здравствуйте! Сегодня установил данный мод себе на форум! Версия форума 3.0.11! Все установилось нормально!
Вот только есть одна проблема: в админпанели не появилась вкладка для данного мода! Что это может быть?!
Alex1204 писал(а):у меня создалось впечатление, что при массовом удалении пользователей мод создает большую нагрузку на сервер
Интересно, на основании чего?
danilas писал(а):Может, действительно, он.
Не может.
Инструмент очистки пользователей из ACP НИКАК не связан с МОДом.
Более того, после совершения массового администрирования или модерирования для правильного функционирования МОДа следует выполнить Обновление счетчиков благодарностей (специальная процедура в ACP), о чем прямо указано в описании.
Добавлено спустя 2 минуты 53 секунды:
IgorOkCJ писал(а):в админпанели не появилась вкладка для данного мода! Что это может быть?!
Что МОД не правильно или не до конца установлен
Как вариант - вы пропустили сообщения об ошибках при установке, например в случае, если ранее вы удаляли встроенный модуль .MODS
Не все то WINDOWS, что висит... phpBB только учусь. ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.