Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

[OLD] Quick reply for phpBB3 - Быстрый ответ

Все моды, созданные нашим сообществом для phpBB 3.0.x, будут анонсированы тут. Вся техническая поддержка по этим модам оказывается в этом форуме.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

[OLD] Quick reply for phpBB3 - Быстрый ответ

Сообщение rxu »

Мод быстрого ответа для phpBB3.

Возможности: быстрый ответ, быстрые темы. Управляется при помощи отдельного модуля в администраторском разделе (закладка Общие).

После установки обязателен запуск установочного скрипта qr_db_install.php, которым, в том числе, будет включено отображение формы быстрого ответа для всех зарегистрированных пользователей.
Внимание: Не рекомендуется использовать установочный скрипт из пакета поставки мода версии 1.6.7. Вместо этого используйте исправленные версии install.php и uninstall.php.

Внимание: при обновлении с предыдущей версии не нужно запускать установочный скрипт install.php, если это не оговорено специально.

О проблеме прокрутки страницы темы вниз к форме быстрого ответа.
Проявляется в Internet Explorer.
Фикс от прокрутки страницы вниз к форме быстрого ответа здесь, новая версия - здесь.
Вариант фикса от пользователя VEG - здесь.
Ещё один фикс от наших иностранных товарищей тут.

Код добавления кнопки быстрого ответа для prosilver здесь. Дополнение к указанному коду, необходимое для появления кнопки в стиле subsilver2 здесь.
Вложения
Olympus_QR_button_1.0.0.zip
(41.32 КБ) 2486 скачиваний
Olympus_QR_1.6.7.zip
(55.08 КБ) 19717 скачиваний
Последний раз редактировалось rxu 11.05.2008 6:04, всего редактировалось 15 раз.
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

Никаких конфликтов не замечено.
Быстрый ответ разрешен зарегистрированным пользователям (быстрые темы отключены).
Если он включен, значит по умолчанию у нового пользователя БО должен сразу же включаться? У меня почему-то такое не происходит.
Жду ответа разработчика мода...

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

Stern
По идее, БО должен включаться у всех после отработки установочного скрипта (апдейта базы данных).
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

А вы можете намекнуть, в чем может быть дело? В каком файле поискать ошибку? Или проще его переустановить?

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

Трудно вот так сказать, где может быть ошибка.
Нужно по крайней мере перепроверить установку на предмет того, внесены ли все изменения, указанные в инструкции, и повторно запустить скрипт апдейта БД.
Изображение

Heldar
phpBB 2.0.0
Сообщения: 231
Зарегистрирован: 13.08.2007 10:13
Благодарил (а): 38 раз
Поблагодарили: 20 раз

Сообщение Heldar »

Вопрос по БО у меня на форуме поле для ввода становится активным сразу после входа на страницу. Из за этого происходит перемещение вниз страницы мимо всех постов .. Это неудобно. можно как нибудь поправить??
А ТЫ очистил кэш??!!

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

Heldar
Попробуйте так

Код: Выделить всё

OPEN
styles/prosilver/template/overall_header.html

FIND
         eval(onload_functions[i]);

AFTER, ADD
         return false;

OPEN
styles/subsilver2/template/editor.js

FIND
window.onload = initInsertions;

REPLACE WITH
window.onload = function()
{
   initInsertions;
   return false;
}
Последний раз редактировалось rxu 21.09.2007 7:11, всего редактировалось 1 раз.
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

rxu писал(а):Трудно вот так сказать, где может быть ошибка.
Нужно по крайней мере перепроверить установку на предмет того, внесены ли все изменения, указанные в инструкции
Попробовал переустновить мод в автом.режиме - скрипт никаких изменений в файлы не внес, сказал что все нормально.
Запускал qr_db_install.php - никаких изменений.

После проверил каждый файл на предмет изменений по инструкции - все присутствует!

Если ничего больше не подскажете, то придется удалять скрипт (затем, как я понял, надо запускать qr_db_uninstall.php) и заниматься установкой по новой. :(
Но очень надеюсь, что вы все-таки подскажете решение данной проблемы.
Последний раз редактировалось Stern 18.09.2007 10:26, всего редактировалось 1 раз.

Аватара пользователя
***Blaze***
phpBB 2.0.7
Сообщения: 579
Зарегистрирован: 12.01.2007 10:57
Откуда: Данков
Благодарил (а): 57 раз
Поблагодарили: 25 раз

Сообщение ***Blaze*** »

Тоже самое, как у Stern и у меня. В чем причина?
Мой сайт http://ublaze.ru/

Vadim

Сообщение Vadim »

rxu писал(а):Stern
По идее, БО должен включаться у всех после отработки установочного скрипта (апдейта базы данных).
У меня БО включен по умолчанию для тех, кто был зареган ДО установки мода (а это были только админ да модератор). А у юзеров, которые регаются ПОСЛЕ установки, БО по умолчанию выключен.

То ли дело в том, кто был ДО, а кто ПОСЛЕ, то ли дело в группах (у модеров включено, а у юзеров выключено).

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

Вопрос к тем, у кого проблема с автовключением отображения БО:
чему равно значение по умолчанию для поля user_options в таблице users (желательно указать и до и после установки мода)?
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

В данный момент (после установки мода) стоит значение 2943.
До установки не знаю, но если надо могу попробовать вернуть все назад...

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

Назад возвращать не нужно. Видимо, было 895.

Добавлено спустя 1 минуту 35 секунд:

Какие значения стоЯт у пользователей (не ботов)?
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

А что это за параметр? В таблице usres? Укажите, плиз, точнее...

Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14779
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 356 раз
Поблагодарили: 1631 раз

Сообщение rxu »

rxu писал(а):для поля user_options в таблице users
Изображение

Stern
phpBB 2.0.3
Сообщения: 368
Зарегистрирован: 22.04.2005 7:24

Сообщение Stern »

:) Ничего не понимаю. Я же написал: 2943.
А где искать значения у пользователей (не ботов)?
(смотрю в таблицу phpbb_users и вижу фигу :) )

Вернуться в «Анонсы и поддержка модов для phpBB 3.0.x»