[OLD] Quick reply for phpBB3 - Быстрый ответ
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
rxu
- phpBB Guru

- Сообщения: 17273
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2413 раз
[OLD] Quick reply for phpBB3 - Быстрый ответ
Мод быстрого ответа для phpBB3.
Возможности: быстрый ответ, быстрые темы. Управляется при помощи отдельного модуля в администраторском разделе (закладка Общие).
После установки обязателен запуск установочного скрипта qr_db_install.php, которым, в том числе, будет включено отображение формы быстрого ответа для всех зарегистрированных пользователей.
Внимание: Не рекомендуется использовать установочный скрипт из пакета поставки мода версии 1.6.7. Вместо этого используйте исправленные версии install.php и uninstall.php.
Внимание: при обновлении с предыдущей версии не нужно запускать установочный скрипт install.php, если это не оговорено специально.
О проблеме прокрутки страницы темы вниз к форме быстрого ответа.
Проявляется в Internet Explorer.
Фикс от прокрутки страницы вниз к форме быстрого ответа здесь, новая версия - здесь.
Вариант фикса от пользователя VEG - здесь.
Ещё один фикс от наших иностранных товарищей тут.
Код добавления кнопки быстрого ответа для prosilver здесь. Дополнение к указанному коду, необходимое для появления кнопки в стиле subsilver2 здесь.
Возможности: быстрый ответ, быстрые темы. Управляется при помощи отдельного модуля в администраторском разделе (закладка Общие).
После установки обязателен запуск установочного скрипта qr_db_install.php, которым, в том числе, будет включено отображение формы быстрого ответа для всех зарегистрированных пользователей.
Внимание: Не рекомендуется использовать установочный скрипт из пакета поставки мода версии 1.6.7. Вместо этого используйте исправленные версии install.php и uninstall.php.
Внимание: при обновлении с предыдущей версии не нужно запускать установочный скрипт install.php, если это не оговорено специально.
О проблеме прокрутки страницы темы вниз к форме быстрого ответа.
Проявляется в Internet Explorer.
Фикс от прокрутки страницы вниз к форме быстрого ответа здесь, новая версия - здесь.
Вариант фикса от пользователя VEG - здесь.
Ещё один фикс от наших иностранных товарищей тут.
Код добавления кнопки быстрого ответа для prosilver здесь. Дополнение к указанному коду, необходимое для появления кнопки в стиле subsilver2 здесь.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось rxu 11.05.2008 2:04, всего редактировалось 15 раз.
-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
QR_phpbb3.xml открываем в браузере, дальше обычные действия руками и головой.
Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
BioReactor
При SQL запросе этим путём:
http://forum.aeroion.ru/db_generator.php выводит ошибку:
Код: Выделить всё
Warning: main(./extension.inc): failed to open stream: No such file or directory in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 23
Warning: main(./extension.inc): failed to open stream: No such file or directory in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 23
Warning: main(): Failed opening './extension.inc' for inclusion (include_path='.;D:/Apache_Swissknife/вебсервер/php/includes/') in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 23
Notice: Undefined variable: phpEx in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 24
Warning: main(./common.): failed to open stream: No such file or directory in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 24
Warning: main(./common.): failed to open stream: No such file or directory in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 24
Warning: main(): Failed opening './common.' for inclusion (include_path='.;D:/Apache_Swissknife/вебсервер/php/includes/') in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 24
Fatal error: Call to undefined function: session_pagestart() in d:\apache_swissknife\www\localhost01\html\1\db_update.php on line 29-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
Генератор ведь рассчитан на выполнение скрипта в среде phpBB2, а вы его в Олимпус впихиваете.
Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
Поправил, да заодно и в скрипте изменения сделал.
Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
Палыч
- Former team member
- Сообщения: 9683
- Стаж: 20 лет 4 месяца
- Откуда: Питер
- Благодарил (а): 3 раза
- Поблагодарили: 454 раза
off: наткнулся на генератор для трешки (там же и для двушки)
http://www.phpbbsmith.com/generate-db.html#avdlink
http://www.phpbbsmith.com/generate-db.html#avdlink
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
-
DOMINATOR
- phpBB 1.4.4
- Сообщения: 153
- Стаж: 19 лет
- Откуда: Новосибирск
- Поблагодарили: 13 раз
Поставил эту форму (из первого поста), но не отображаются смайлики. Текст "Смайлы" есть, но самих смайлов нету... Как прикрутить смайлы? И есть ли возможность убрать из формы быстрого ответа (и только от туда) цвет шрифта и размер?
Важное дополнение к FAQ по установке модов:
Моды ночью/на пьяную голову/с похмелья не ставь, движок сломаешь! Все равно с утра переделывать прийдется...
Моды ночью/на пьяную голову/с похмелья не ставь, движок сломаешь! Все равно с утра переделывать прийдется...
-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
Возможность есть. Только для этого надо сделать свою страницу типа qr_posting_buttons.html на базе posting_buttons.html, в которой и оставить нужные кнопки.
В этом случае в quick_reply.html строку
заменить на
В этом случае в quick_reply.html строку
Код: Выделить всё
<!-- INCLUDE posting_buttons.html -->Код: Выделить всё
<!-- INCLUDE qr_posting_buttons.html -->Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
Stern
- phpBB 2.0.3
- Сообщения: 368
- Стаж: 21 год 5 месяцев
Прочитал данную тему от корки до корки.
Раньше стоял мод v.1.6.2. Обновиться почему-то не получилось, форма ответа не появилась. Решил установить заново. Теперь при заходе в любую тему выбрасывает на пустой белый экран. Все остальное вроде работает - в админке разрешен "Быстрый ответ", в личных настройках то же разрешено. Ув. гуру, подскажите, где я мог накосячить так? (кэш очищал..).
Раньше стоял мод v.1.6.2. Обновиться почему-то не получилось, форма ответа не появилась. Решил установить заново. Теперь при заходе в любую тему выбрасывает на пустой белый экран. Все остальное вроде работает - в админке разрешен "Быстрый ответ", в личных настройках то же разрешено. Ув. гуру, подскажите, где я мог накосячить так? (кэш очищал..).
Последний раз редактировалось Stern 14.02.2008 15:49, всего редактировалось 1 раз.
-
DOMINATOR
- phpBB 1.4.4
- Сообщения: 153
- Стаж: 19 лет
- Откуда: Новосибирск
- Поблагодарили: 13 раз
Поручик, спасибо, все понял! Со смайлами разобрался, просто не сразу нашел в админке настройки... Приболел, туплю 
Добавлено спустя 21 минуту 22 секунды:
Еще вопрос.: а как задать условие чтобы выбор размера и цвета шрифта выводился только определенным группам?
Добавлено спустя 21 минуту 22 секунды:
Еще вопрос.: а как задать условие чтобы выбор размера и цвета шрифта выводился только определенным группам?
Важное дополнение к FAQ по установке модов:
Моды ночью/на пьяную голову/с похмелья не ставь, движок сломаешь! Все равно с утра переделывать прийдется...
Моды ночью/на пьяную голову/с похмелья не ставь, движок сломаешь! Все равно с утра переделывать прийдется...
-
Stern
- phpBB 2.0.3
- Сообщения: 368
- Стаж: 21 год 5 месяцев
-
Stern
- phpBB 2.0.3
- Сообщения: 368
- Стаж: 21 год 5 месяцев
-
Stern
- phpBB 2.0.3
- Сообщения: 368
- Стаж: 21 год 5 месяцев
Как устанавливал? Все по инструкции.
Сначала выполнил SQL запрос, потом закачал новые файлы.
Затем внес изменения в файлы и залил их на сервер.
Также залил туда qr_db_install.php и запустил его.
На что сервер выдал мне ошибку:
SQL ERROR [ mysql4 ]
Duplicate entry 'allow_quick_reply' for key 1 [1062]
ну и так далее.
Вылечил эту ошибку очисткой кэша и снова запустил qr_db_install.php
После чего увидел радостную строчку-поздравление, что мод установлен.
Оказалось, что рано радовался...
(Есть доступ к CPanel. Но не нашел где сбросить эти ошибки... Хотя сомнения берут, что дело тут в ошибках...)
Сначала выполнил SQL запрос, потом закачал новые файлы.
Затем внес изменения в файлы и залил их на сервер.
Также залил туда qr_db_install.php и запустил его.
На что сервер выдал мне ошибку:
SQL ERROR [ mysql4 ]
Duplicate entry 'allow_quick_reply' for key 1 [1062]
ну и так далее.
Вылечил эту ошибку очисткой кэша и снова запустил qr_db_install.php
После чего увидел радостную строчку-поздравление, что мод установлен.
Оказалось, что рано радовался...
(Есть доступ к CPanel. Но не нашел где сбросить эти ошибки... Хотя сомнения берут, что дело тут в ошибках...)

