Мост DLE & форум phpBB

Здесь авторы могут постить бета-версии своих модификаций для phpBB 3.0.x. Внимание! Не устанавливайте бета-версии модов на работающие форумы!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

к тому же у меня последняя версия стоит. Где ты исправил это?
Исправлено в локальной тестовой версии у меня.
Сейчас сильно занят работой :(
Надеюсь в ближайшие дни возьмусь за исправление багов в мосте.
Klaf
phpBB 1.0.0
Сообщения: 3
Стаж: 16 лет 10 месяцев

Re: Мост DLE & форум phpBB

Сообщение Klaf »

IgorA100
когда же нам ждать этого важного исправления? :oops:
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

Буду стараться выкроить время в течении пары ближайших недель....
OwnedByWMZ
phpBB 1.0.0
Сообщения: 1
Стаж: 16 лет 9 месяцев

Re: Мост DLE & форум phpBB

Сообщение OwnedByWMZ »

Добрый День.

После установки модуля - Регистрация на форуме и на Сайте(ДЛЕ) проходит отлично

Но после захода на форуме за "тест аккаунт" выдает ошибку -

Код: Выделить всё

[phpBB Debug] PHP Notice: in file Z:/home/aion-bars.ru/www/bridge/bridge.php on line 42: require(Z:/home/aion-bars.ru/www/news/engine/data/config.php) [function.require]: failed to open stream: No such file or directory

Fatal error: require() [function.require]: Failed opening required 'Z:/home/aion-bars.ru/www/news/engine/data/config.php' (include_path='.;/usr/local/php5/PEAR') in Z:\home\aion-bars.ru\www\bridge\bridge.php on line 42
RuBAN
phpBB 1.2.1
Сообщения: 21
Стаж: 17 лет 7 месяцев

Re: Мост DLE & форум phpBB

Сообщение RuBAN »

А интеграция возможна для DLE 8.3 и phpBB 3.0.7???
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

DLE 8.3 и phpBB 3.0.6 работают. С 3.0.7 форумом не пробовал.
Готово очередное обновление, но все руки не доходят выложить его. Там исправлены мелкие баги и добавлена синхронная регистрация в случае активации аккаунта через мыло.
housecry
phpBB 1.0.0
Сообщения: 1
Стаж: 16 лет 4 месяца

Re: Мост DLE & форум phpBB

Сообщение housecry »

У меня проблема!

При регистрации пользователя в dle, профиль создается и в dle и в phpbb, но потом после выхода когда пытаешься зайти на форум пишет что пароль неверен.

и при выходе пользователя в dle выдает ошибку:

Fatal error: Cannot redeclare set_config() (previously declared in /var/www/vhosts/progresskolomna.ru/httpdocs/bridge/module/functions/functions_phpbb.php:26) in /var/www/vhosts/progresskolomna.ru/httpdocs/forum/includes/functions.php on line 166

у меня dle 8.5 и phpbb 3.0.7-PL1
Buhgalter
phpBB 1.2.0
Сообщения: 10
Стаж: 16 лет 3 месяца

Re: Мост DLE & форум phpBB

Сообщение Buhgalter »

IgorA100, у меня выдает ошибку при входе c DLE:

Код: Выделить всё

Warning: include_once(): open_basedir restriction in effect. File(/usr/local/apache/htdocs/bridge/bridge.php) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/a7571174/public_html/engine/modules/sitelogin.php on line 49
Warning: include_once(/usr/local/apache/htdocs/bridge/bridge.php): failed to open stream: пРЕТБГЙС ОЕ РПЪЧПМСЕФУС in /home/a7571174/public_html/engine/modules/sitelogin.php on line 49
Warning: include_once(): Failed opening '/usr/local/apache/htdocs/bridge/bridge.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a7571174/public_html/engine/modules/sitelogin.php on line 49
и при входе с форума:

Код: Выделить всё

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 2878: include() [function.include]: open_basedir restriction in effect. File(/usr/local/apache/htdocs/bridge/bridge.php) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 2878: include(/usr/local/apache/htdocs/bridge/bridge.php) [function.include]: failed to open stream: Operation not permitted
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 2878: include() [function.include]: Failed opening '/usr/local/apache/htdocs/bridge/bridge.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php')
PHP Error Message


Warning: Cannot modify header information - headers already sent by (output started at /home/a7571174/public_html/forum/includes/functions.php:3479) in /home/a7571174/public_html/forum/includes/functions.php on line 4285
При этом мост не работает - авторизация происходит только с одной стороны... тоже самое с выходом :(

Использую DLE 8.5 и phpbb 3.0.7
В cfg.php прописал следуещее:

Код: Выделить всё

//ЭТО ЗАПОЛНЯЕТСЯ РУКАМИ!!!!!!!!!!!!!!!!!!!!!!!
define ( 'BR_DLE_DIR', '/' ); //Каталог куда установлен DLE
define ( 'BR_PHPBB_DIR', '/forum' ); //Каталог куда установлен форум PhpBB
Портал установлен на 000webhost.com

P.S. на localhost (Denwer) все работало... как я понимаю, не верно определяется путь /usr/local/apache/htdocs/bridge/bridge.php т.к. должно было бы быть /home/a7571174/public_html/bridge/bridge.php?
Buhgalter
phpBB 1.2.0
Сообщения: 10
Стаж: 16 лет 3 месяца

Re: Мост DLE & форум phpBB

Сообщение Buhgalter »

Разобрался с проблемой! Все работает теперь! Решение для тех, у кого подобные проблемы:

1. Создаем файл get_path.php

Код: Выделить всё

<?php

echo dirname(__FILE__);
2. Заливаем его в корень сайта.
3. Идем по адерсу: вашсайт.ру/get_path.php и получаем путь к своей корневой директории на сервере.
4. Дальше все по инструкции от автора моста, но везде вместо $_SERVER['DOCUMENT_ROOT'] . '/bridge/bridge.php' ставим 'полученный путь к своей корневой директории на сервере/bridge/bridge.php'
5. В /bridge/cfg.php прописываем следуещее:

Код: Выделить всё

//ЭТО ЗАПОЛНЯЕТСЯ РУКАМИ!!!!!!!!!!!!!!!!!!!!!!!
define ( 'BR_DLE_DIR', '/' ); //Каталог куда установлен DLE
define ( 'BR_PHPBB_DIR', '/forum' ); //Каталог куда установлен форум PhpBB
и внизу (строка 93):

Код: Выделить всё

//ЭТО ВОООБЩЕ НЕ ТРОГАТЬ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
define ( 'BR_BASE_DIR', 'полученный путь к своей корневой директории на сервере'); //Адрес хоста
6.Наслаждаемся :D

P.S. Большое спасибо автору за проделанную работу!
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

Не успел я подумать о проблеме, как она решилась :)
Все никак не выложу доработанную версию, занят сильно :(
Если кому не трудно, "пните" меня завтра после обеда, попробую выложить.....
Аватара пользователя
crazyicf
phpBB 1.0.0
Сообщения: 8
Стаж: 16 лет 3 месяца
Откуда: Sebastopol

Re: Мост DLE & форум phpBB

Сообщение crazyicf »

Установил по инструкции. Все вроде работает. Сменил пароль 1 пользователю. При вводе пароля выдает хрень что нет функции:
Fatal error: Call to undefined function request_var() in /home/user/vhosts/site.ru/forum/includes/captcha/plugins/captcha_abstract.php on line 41
dle 8.5 установлен в "/"
forum 3.0.7-PL1 установлен в "/forum"
Что делать?
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

Обновил мост до версии 1.15
http://www.kentavr.com.ru/forum/viewtopic.php?f=28&t=43

Добавлено спустя 1 минуту 51 секунду:
crazyicf писал(а):Fatal error: Call to undefined function request_var() in /home/user/vhosts/site.ru/forum/includes/captcha/plugins/captcha_abstract.php on line 41
Что делать?
Это вообще похоже на ошибку НЕ моста, а на дополнительно установленный мод капчи. ИМХО в ней надо искать ошибки...
Аватара пользователя
crazyicf
phpBB 1.0.0
Сообщения: 8
Стаж: 16 лет 3 месяца
Откуда: Sebastopol

Re: Мост DLE & форум phpBB

Сообщение crazyicf »

форум нулячий ,слил с офсайта и поставил, сразу ставил мост прикручивать

Добавлено спустя 5 минут 43 секунды:
при смене/восстановлении пароля на форуме или на dle пароли не будут совпадать?

Добавлено спустя 5 минут 28 секунд:
извиняюся, прочитал по поводу синхронизацию и планы в help.html =)
IgorA100
phpBB 1.4.0
Сообщения: 30
Стаж: 16 лет 11 месяцев
Поблагодарили: 3 раза

Re: Мост DLE & форум phpBB

Сообщение IgorA100 »

crazyicf писал(а):форум нулячий ,слил с офсайта и поставил, сразу ставил мост прикручивать
Надо тогда смотреть 41 строку captcha_abstract.php
Или где-то не так добавили в форум интеграцию моста....
Buhgalter
phpBB 1.2.0
Сообщения: 10
Стаж: 16 лет 3 месяца

Re: Мост DLE & форум phpBB

Сообщение Buhgalter »

Ver. 1.15 Date:16-02-2010
~ Ошибка при добавлении пользователя в DLE имеющего в НИКе русские буквы и уже существующего на форуме.
Регистрация пользователя с русским логином с стороны DLE происходит только на DLE, тоесть на форуме надо повторно регистрироваться. Как это можно поправить?

Если же регистрироваться со стороны форума,то регистрация проходит нормально и на сайте и на форуме:
Спасибо за регистрацию, ваш аккаунт создан. Теперь вы можете войти, воспользовавшись вашим именем и паролем
Авторизация пользователя "Оля", зарегистрированного "2 июня 2010 03:59" успешно прошла на сайте.
Добавлено спустя 37 минут 24 секунды:
Снова разобрался сам :)
Двухсторонняя регистрация со стороны DLE вообще не работала...
В новом варианте инструкции упущен один момент, без которого мост не работает как надо:
Для регистраци на форуме, при регистрации в ДЛЕ стандартным способом.
Надо в файле /engine/modules/register.php найти:
if( intval( $config['reg_group'] ) < 3 ) $config['reg_group'] = 4;
И ПОСЛЕ этой строчки вставить:
include($_SERVER['DOCUMENT_ROOT'] . '/bridge/bridge.php');
P.S. Просто сверил мануалы... добавил вышеприведенный пункт и все заработало!

Вернуться в «Бета-версии модов для phpBB 3.0.x»