User Blog Mod
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: User Blog Mod
В css прописан нужный цвет, а на деле - другой. Полтергейст? Или Вы просто не можете разобраться?
Проанализируйте код, смотрите откуда что берется
Проанализируйте код, смотрите откуда что берется
-
arty777
- phpBB 1.4.2
- Сообщения: 65
- Стаж: 17 лет 5 месяцев
- Откуда: arty.in.ua country :)
- Благодарил (а): 2 раза
Re: User Blog Mod
Нарисовал себе кнопку :) Под сабсильвер2 , делюсь с Вами
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
Лейтенант
- phpBB 1.4.2
- Сообщения: 59
- Стаж: 17 лет 2 месяца
- Благодарил (а): 2 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
Помогите, пожалуйста.
Мод работал нормально. С момента установки прошло дней десять.
Но сегодня при попытке зайти в любую тему форума появляется ошибка:
Данная строчка выглядит так:
А тут:
Версия - User Blog Mod 1.0.12
Также от хостера сегодня получили такое сообщение:
Мод работал нормально. С момента установки прошло дней десять.
Но сегодня при попытке зайти в любую тему форума появляется ошибка:
Код: Выделить всё
Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/interne6/public_html/forum/blog/plugins/plugins.php on line 21При попытке зайти в настройки блога в административной панели другая ошибка:public static $plugins = false();
Код: Выделить всё
Parse error: parse error, unexpected T_AS, expecting '(' in /home/interne6/public_html/forum/includes/acp/acp_blogs.php on line 689Чтобы это могло быть? :( :( :(foreach (blog_plugins::$available_plugins as $name => $data)
Версия - User Blog Mod 1.0.12
Также от хостера сегодня получили такое сообщение:
Уважаемый клиент! 28.04.2010 и 29.04.2010 с 9:00 до 16:00 будут проводиться работы по модернизации канального оборудования. В связи с этим для оказываемой Вам услуги имя_сайта .ru возможны перерывы связи и/или ухудшения по отдельным направлениям общей продолжительностью не более 30 минут.
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: User Blog Mod
Давайте указанную строку +/- 10 строчек
Вы сами ничего не делали перед появлением ошибки?
Вы сами ничего не делали перед появлением ошибки?
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
Лейтенант
- phpBB 1.4.2
- Сообщения: 59
- Стаж: 17 лет 2 месяца
- Благодарил (а): 2 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
Вот. Ничего не меняли. В полдень еще все работало:
1. forum/blog/plugins/plugins.php on line 21:
i
--------------------------------------------------------------------
1. forum/blog/plugins/plugins.php on line 21:
i
2. forum/includes/acp/acp_blogs.php on line 689f (!defined('IN_PHPBB'))
{
exit;
}
/**
* Blog Plugins Class
*/
class blog_plugins
{
public static $plugins = array();
public static $available_plugins = array();
private static $to_do = array();
/**
* Constructor
*
* Load all installed and enabled plugins
*/
public function __construct()
{
global $cache, $config, $db, $phpbb_root_path, $phpEx, $blog_plugins_path, $table_prefix, $user;
Может, из-за базы данных? Точнее из-за того, что хостер собирается отключить некоторые функции?// We need to do a redirect here because the plugins list is not shown correctly after one is moved...and I see no easy way to resync the list
redirect($this->u_action);
break;
}
$i = 0;
$installed_plugins = array();
foreach (blog_plugins::$available_plugins as $name => $data)
{
$i++;
$installed = (array_key_exists($name, blog_plugins::$plugins)) ? true : false;
$active = ($installed && blog_plugins::$plugins[$name]['plugin_enabled']) ? true : false;
$s_actions = array();
if ($installed)
{
if ($active)
{
$s_actions[] = '<a href="' . $this->u_action . "&action=deactivate&name=" . $name . '">' . $user->lang['PLUGIN_DEACTIVATE'] . '</a>';
$s_actions[] = '<a href="' . $this->u_action . "&action=uninstall&name=" . $name . '">' . $user->lang['PLUGIN_UNINSTALL'] . '</a>';
}
else
{
$s_actions[] = '<a href="' . $this->u_action . "&action=activate&name=" . $name . '">' . $user->lang['PLUGIN_ACTIVATE'] . '</a>';
$s_actions[] = '<a href="' . $this->u_action . "&action=uninstall&name=" . $name . '">' . $user->lang['PLUGIN_UNINSTALL'] . '</a>';
}
--------------------------------------------------------------------
В шаблонах тем?Rayden писал(а):Возможно проблема в шаблонах
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: User Blog Mod
Явно видны непарные скобки. По какой-то причине они пропали. Если в эти файлы не вносились изменения, не ставились моды, то залейте эти файлы из дистрибутива по новой
-
Лейтенант
- phpBB 1.4.2
- Сообщения: 59
- Стаж: 17 лет 2 месяца
- Благодарил (а): 2 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
Нет, это к сожалению не помогает. Кэш форума и кэш стилей (обновление) не помогает
-
Лейтенант
- phpBB 1.4.2
- Сообщения: 59
- Стаж: 17 лет 2 месяца
- Благодарил (а): 2 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
Да, замена файлов не помогает. Помогло удаление мода. Но я чуть напорталчил потом, сейчас восстанавливаю базу данных и файловую структуру форума. Снова он будет с модом блогов. Буду его снова удалять.
-
мотоциклист
- phpBB 1.4.2
- Сообщения: 52
- Стаж: 17 лет 7 месяцев
Как снести User Blog Mod?
Какие SQL-запросы необходимо сделать для полного возврата всех изменений в базе, связанных с User Blog Mod?
Дело в том, что я столкнулся с такой проблемой - давным давно установил одну из старых версий User Blog Mod (как следует из нижеизложенного, версия ранее 0.9.0).
Потом не понравилось что-то - снёс. Но, разбираясь в phpBB на уровне среднего пользователя, снёс поверхностно - проделал изменения в файлах в обратном порядке и удалил те таблицы из базы, которые были при установке мода созданы с нуля и которые в своих названиях содержали слово "_blog_".
Однако, как я понял, при установке User Blog Mod были созданы не только новые таблицы, но и внесены некоторые изменения в стандарные форумные таблицы.
Неудивительно, что после такого поверхностного сноса в "ACP / пользователи и группы / права групп / выбор группы / расширенные права / разное " я увидел:
В принципе, это не мешало работать с конференцией без блога, но через время я решил вновь установить блог на своём сайте, скачал User Blog Mod, которого к недавнему времени уже вышла версия 1.0.12, произвёл требуемые изменения в файлах и открываю, находясь под логином и паролем администратора, путь
однако вижу:
Зайдя по ссылке "here", ведущую на "mysite/blog/update.php", я вижу в броузере белое поле.
При попытке использовать вместо mysite/blog/database.php скрипт по адресу blog.php?page=update выдаёт:
Что делать? Я намерен полностью вычистить MySQL-базу от остатков старой версии мода и, запустив скрипт, установить заново.
Дело в том, что я столкнулся с такой проблемой - давным давно установил одну из старых версий User Blog Mod (как следует из нижеизложенного, версия ранее 0.9.0).
Потом не понравилось что-то - снёс. Но, разбираясь в phpBB на уровне среднего пользователя, снёс поверхностно - проделал изменения в файлах в обратном порядке и удалил те таблицы из базы, которые были при установке мода созданы с нуля и которые в своих названиях содержали слово "_blog_".
Однако, как я понял, при установке User Blog Mod были созданы не только новые таблицы, но и внесены некоторые изменения в стандарные форумные таблицы.
Неудивительно, что после такого поверхностного сноса в "ACP / пользователи и группы / права групп / выбор группы / расширенные права / разное " я увидел:
Код: Выделить всё
{ acl_u_blog_create_poll }
{ acl_u_blog_css }
{ acl_u_blog_style }
{ acl_u_blog_vote }
{ acl_u_blog_vote_change }
{ acl_u_blogattach }
{ acl_u_blogbbcode }
{ acl_u_blogdelete }
{ acl_u_blogedit }
{ acl_u_blogflash }
{ acl_u_blogimg }
{ acl_u_blogmoderate }
{ acl_u_blognoapprove }
{ acl_u_blognolimitattach }
{ acl_u_blogpost }
{ acl_u_blogreply }
{ acl_u_blogreplydelete }
{ acl_u_blogreplyedit }
{ acl_u_blogreplynoapprove }
{ acl_u_blogreport }
{ acl_u_blogsmilies }
{ acl_u_blogurl }
{ acl_u_blogview }Код: Выделить всё
mysite/blog/database.phpКод: Выделить всё
Versions prior to 0.9.0 can not be updated using this method, you must use the old update script first, then come back to this to do any further updates.
The old update script is located here.При попытке использовать вместо mysite/blog/database.php скрипт по адресу blog.php?page=update выдаёт:
Код: Выделить всё
General Error
SQL ERROR [ mysql4 ]
Table 'data_base_name.phpbb3_blogs_users' doesn't exist [1146]
SQL
SELECT * FROM phpbb3_blogs_users WHERE user_id = 2
BACKTRACE
FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()
FILE: blog/includes/functions.php
LINE: 328
CALL: dbal_mysql->sql_query()
FILE: blog.php
LINE: 221
CALL: get_user_settings()
FILE: blog/blog.php
LINE: 53
CALL: include('blog.php')-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
не получается установить User Blog Mod 1.0.12
Не получается установить User Blog Mod - когда я ввёл адрес
http://моя конференция/blog/database.php
мне написало, что устарела версия umil, я скачал и установил новую и хотел продолжать инсталляцию, нажав "продолжить", однако далее в окне браузера появилось пустое белое поле и на этом процесс закончился.
Версия блога, который пытался установить, 1.0.12
Версия phpBB 3.0.7-PL1
Установлены моды:
Advertisement Management
board3_Portal
NV_advanced_last_topic_titles
phpbb_gallery_nickvergessen
recent (rxu)
Медали
а также support_toolkit_phpBB_3.0.7-pl1
http://моя конференция/blog/database.php
мне написало, что устарела версия umil, я скачал и установил новую и хотел продолжать инсталляцию, нажав "продолжить", однако далее в окне браузера появилось пустое белое поле и на этом процесс закончился.
Версия блога, который пытался установить, 1.0.12
Версия phpBB 3.0.7-PL1
Установлены моды:
Advertisement Management
board3_Portal
NV_advanced_last_topic_titles
phpbb_gallery_nickvergessen
recent (rxu)
Медали
а также support_toolkit_phpBB_3.0.7-pl1


