User Blog Mod
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
mEx
- phpBB 1.4.4
- Сообщения: 197
- Стаж: 19 лет 5 месяцев
- Благодарил (а): 4 раза
User Blog Mod
В моде User Blog Mod ссылки преобразовывает кириллицей, например:
/blog/Разное/index_c-1.html - категории
/blog/Разное/путевка_c-1_u-2_b-3.html
Зайти по этим ссылкам можно заменив киррилицу латиницей, разное - raznoe, путевка - putevka.
Как сделать, чтобы изначально ссылки выглядили латиицей?
/blog/Разное/index_c-1.html - категории
/blog/Разное/путевка_c-1_u-2_b-3.html
Зайти по этим ссылкам можно заменив киррилицу латиницей, разное - raznoe, путевка - putevka.
Как сделать, чтобы изначально ссылки выглядили латиицей?
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
Re: User Blog Mod
Выводить все сведения - точно выбирал.
В папку language/ru закинул соответствующие файлы из папки root/language/en
В папку language/ru закинул соответствующие файлы из папки root/language/en
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
Re: User Blog Mod
тогда включай в config.php дебаг
Не поможет - тогда надо смотреть error.log вебсервера
Не поможет - тогда надо смотреть error.log вебсервера
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
Re: User Blog Mod
Имеется в виду вот это:Rayden писал(а):тогда включай в config.php дебаг
@define('PHPBB_INSTALLED', true);
// @define('DEBUG', true);
// @define('DEBUG_EXTRA', true);
?>
так у меня выставлено "true".
Имеется в виду в администраторском разделе вкладка "обслуживание" и далее "лог ошибок"? Или запросить лог у хостинг-провайдера?Rayden писал(а):Не поможет - тогда надо смотреть error.log вебсервера
Последний раз редактировалось editorial 20.05.2010 19:00, всего редактировалось 1 раз.
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
Re: User Blog Mod
Раскомментировал:
залил на сервер и с этим config.php попробовал опять запустить установщик - то-же самое белое окно.
При заходе на мой форум/blog.php и мой форум/blog/blog.php перекидывает на мой форум/blog/database.php
На самом форуме появилась строка Time : 0.154s | 61 Queries | GZIP : On | Memory Usage: 2.66 Мб | Explain, при заходе по ссылке "Explain" виден SQL Report, в нем много чего, только не знаю, что там искать.
Посмотреть error.log вебсервера - это нужно к хостинг-провайдеру обращаться, или смотреть в админке форума?
Код: Выделить всё
@define('PHPBB_INSTALLED', true);
@define('DEBUG', true);
@define('DEBUG_EXTRA', true);
?>При заходе на мой форум/blog.php и мой форум/blog/blog.php перекидывает на мой форум/blog/database.php
На самом форуме появилась строка Time : 0.154s | 61 Queries | GZIP : On | Memory Usage: 2.66 Мб | Explain, при заходе по ссылке "Explain" виден SQL Report, в нем много чего, только не знаю, что там искать.
Посмотреть error.log вебсервера - это нужно к хостинг-провайдеру обращаться, или смотреть в админке форума?
-
Nekstati
- Поддержка

- Сообщения: 3365
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 37 раз
- Поблагодарили: 1454 раза
Re: User Blog Mod
Кошмар какой… Это на портале? Если такое на index.php или viewtopic.php, то что-то там у вас с форумом неладно. Хотя и для портала многовато.editorial писал(а):61 Queries
Error.log ищите по FTP в папках вашего сайта.
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
Re: User Blog Mod
Да, это на Портале.
А что делать с дебагом - обратно закомментировать соответствующие строки в config.php?
Что искать в error.log?
А что делать с дебагом - обратно закомментировать соответствующие строки в config.php?
Что искать в error.log?
-
editorial
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 4 месяца
Re: User Blog Mod
Проблема решена - сегодня успешно установил блог версии 1.0.13
Очевидно, в версии 1.0.12 была техническая несовместимость с phpBB3.0.7-PL1
Однако уже выявлен баг - список вариантов голосования выводится в обратном порядке.
Т.е. при составлении сообщения пишется несколько вариантов голосования:
первый вариант
второй вариант
третий вариант
другое
А после постинга фактически получается:
другое
третий вариант
второй вариант
первый вариант
Очевидно, в версии 1.0.12 была техническая несовместимость с phpBB3.0.7-PL1
Однако уже выявлен баг - список вариантов голосования выводится в обратном порядке.
Т.е. при составлении сообщения пишется несколько вариантов голосования:
первый вариант
второй вариант
третий вариант
другое
А после постинга фактически получается:
другое
третий вариант
второй вариант
первый вариант
-
Berk
- phpBB 2.0.2
- Сообщения: 301
- Стаж: 18 лет
- Откуда: Украина, Киев
- Благодарил (а): 3 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
проверил сегодня индексируется ли блог гуглом
оказывается нет
в инструментах вебмастера сделал проверку адреса
пишет: Не в домене
что это значит? как в домен включить?
спасибо!
оказывается нет
в инструментах вебмастера сделал проверку адреса
пишет: Не в домене
что это значит? как в домен включить?
спасибо!
-
Papastratos
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 16 лет 3 месяца
- Откуда: Питер
Re: User Blog Mod
Такая фигня. Поставил этот мод на форум с кучей уже установленных модов, в том числе немного изменен и стандартный стиль просильвер. Короче все работает, но почемуто при использовании стилей из пакета мода, вместо картинок в блогах отображаются цифры, вида #12 #156 и другие варианты, при чем меняются при обновлении страницы. Если поставить тот стиль что у меня на форуме или стандартный просильвер всё отображается отлично. Не подскажите где копать?
-
Nekstati
- Поддержка

- Сообщения: 3365
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 37 раз
- Поблагодарили: 1454 раза
Re: User Blog Mod
Обнаружился небольшой сюрприз от автора мода. Если пользователь запрещает гостям доступ к своему дневнику и разрешает только зарегистрированным, то на ботов этот запрет не распространяется. Таким образом, господа администраторы, если у вас включена система пользовательских прав доступа, то необходимо глобально запретить ботам чтение дневников (в общих правах групп). Иначе от этих пользовательских прав никакого толку нет. Закрытые дневники будут индексироваться, плюс любой неглупый юзер может изменить юзерагент своего браузера и читать закрытые дневники.
Если кому-то не лень регистрироваться, напишите автору.
http://www.lithiumstudios.org/forum/tracker.php?p=1
Если кому-то не лень регистрироваться, напишите автору.
http://www.lithiumstudios.org/forum/tracker.php?p=1
-
Berk
- phpBB 2.0.2
- Сообщения: 301
- Стаж: 18 лет
- Откуда: Украина, Киев
- Благодарил (а): 3 раза
- Поблагодарили: 2 раза
Re: User Blog Mod
о, так может у меня не индексируется, потому, что в правах ботов, Can view blog entries - установлена точечка в NO ? :)
-
Nekstati
- Поддержка

- Сообщения: 3365
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 37 раз
- Поблагодарили: 1454 раза
Re: User Blog Mod
О чём я и говорю. Индексируется либо всё, либо ничего, в зависимости от этой точечки. Права, выставленные самими пользователями, на это не влияют.

