User Blog Mod

Поддержка старых модов или модов, созданных авторами не из нашего сообщества, а также любые вопросы, связанные с модами для phpBB 3.0.x, кроме относящихся к форуму Для авторов (phpBB 3.0.x).
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
mEx
phpBB 1.4.4
Сообщения: 197
Стаж: 19 лет 5 месяцев
Благодарил (а): 4 раза

Re: User Blog Mod

Сообщение mEx »

Nekstati
Если бы обвинял поставил бы восклицательный знак!)))
Мы просто не поняли друг друга, я имел в виду как заставить преобразовывать кириллицу в транслит, раздел = razdel. Например, в моде галереи, все преобразовывается как надо.
mEx
phpBB 1.4.4
Сообщения: 197
Стаж: 19 лет 5 месяцев
Благодарил (а): 4 раза

Re: User Blog Mod

Сообщение mEx »

Подскажите, как увеличить время тайм-аута, если долго писать запись, то при размещении вас выкинет на форму входа и текст будет утрачен.
Аватара пользователя
Nekstati
Поддержка
Поддержка
Сообщения: 3365
Стаж: 17 лет 6 месяцев
Благодарил (а): 37 раз
Поблагодарили: 1454 раза

Re: User Blog Mod

Сообщение Nekstati »

В админке увеличить время сессии.

Существует также мод In-line login: http://www.phpbb.com/community/viewtopic.php?t=1059225, но не думаю, что он будет работать с блогом.
mEx
phpBB 1.4.4
Сообщения: 197
Стаж: 19 лет 5 месяцев
Благодарил (а): 4 раза

Re: User Blog Mod

Сообщение mEx »

В том-то и дело, что у меня в админке стоит 0(неограниченно).
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: User Blog Mod

Сообщение Egoz »

Приветствую гуру.
Только что установил мод Блога. При выполнении команды

Код: Выделить всё

Go to yoursite/blog/database.php in your web browser to install the database section.
жму далее и вот что выдает:
Обновление шаблонов prosilver
Ошибка: Файл ../styles/prosilverattachment.html не доступен для чтения.

Обновление шаблонов subsilver2
Ошибка: Файл ../styles/subsilver2attachment.html не доступен для чтения.
но ставится нормально. Подскажите что это за файлы и где их брать?
После установки, в админке, в разделе Общие при попытке Очистить кеш по нажатию кнопки Выполнить при нажатии подтверждения, выскакивает вот такое сообщение:
Общая ошибка
SQL ERROR [ mysql4 ]

The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay [1104]

SQL

SELECT a.forum_id, ug.user_id, g.group_id FROM (phpbb_acl_options o, phpbb_user_group ug, phpbb_groups g, phpbb_acl_groups a) LEFT JOIN phpbb_acl_roles_data r ON (a.auth_role_id = r.role_id) WHERE (o.auth_option_id = a.auth_option_id OR o.auth_option_id = r.auth_option_id) AND ((a.auth_setting = 0 AND r.auth_setting IS NULL) OR r.auth_setting = 0) AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ug.user_id IN (2, 261, 67, 53, 267, 289, 69, 60) AND ug.user_pending = 0 AND o.auth_option LIKE 'm\\_%'

BACKTRACE

FILE: includes/db/mysql.php
LINE: 174
CALL: dbal->sql_error()

FILE: includes/functions_admin.php
LINE: 2387
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_main.php
LINE: 344
CALL: cache_moderators()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_main->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
В тоже время очистка кеша и обновление шаблона из раздела Стили проходит нормально.
Подскажите пожалуйста как с этой ошибкой бороться.
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: User Blog Mod

Сообщение MAzZY »

Ошибка: Файл ../styles/prosilverattachment.html не доступен для чтения.

Потерян слэш.
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: User Blog Mod

Сообщение Egoz »

MAzZY
всмысле должно быть вот так:

Код: Выделить всё

Файл ../styles/prosilver/attachment.html
но он есть по адресу

Код: Выделить всё

Файл ../styles/prosilver/template/attachment.html
как быть?
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: User Blog Mod

Сообщение MAzZY »

А, точно. Не слэш, а целая папка. Значит, какая-то проблема в установщике
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: User Blog Mod

Сообщение Egoz »

MAzZY
от этого может и эта ошибка вылезает?
Egoz писал(а):подтверждения, выскакивает вот такое сообщение:

Общая ошибка
SQL ERROR [ mysql4 ]

The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay [1104]
Может не все скопировалось или с ошибками или может я, когда вносил изменения в файлы при установке мода, допустил ошибки?

Еще вот в инструкции по установке мода есть такое:

Код: Выделить всё

Additional MODX files
Template:  subsilver2 
Template:  Acid Tech Tiger 
Template:  Black Pearl 
Contrib:  Extended Install
так вот надо ли, после установки самого мода, делать еще и

Код: Выделить всё

Contrib:  Extended Install
деинсталлировал мод, удалил все закопированное и вернул оригинальные файлы на место, но вот ошибка при Очистки кеша из вкладки Общие не ушла. Сам форум вроде функционирует нормально.
Помогите пожалуйста с этой проблемой
+ еще заметил глюк удаления мода Блоги - в админке Общие - Конфигурация - Модули - не работает.
Пишет

Код: Выделить всё

Общая ошибка
Module not accessible
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: User Blog Mod

Сообщение Egoz »

Нашел единственный пока выход - восстановил БД из бекапа и все вернулось на свои места, ошибка исчезла.
Только вот как же теперь быть с установкой и этой проблемой, возникающей при установке мода:
Egoz писал(а):Обновление шаблонов prosilver
Ошибка: Файл ../styles/prosilverattachment.html не доступен для чтения.
мало того что пропущен слеш, так еще и файл лежит по адресу
Egoz писал(а):../styles/prosilver/template/attachment.html
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
Jet
phpBB 1.4.4
Сообщения: 100
Стаж: 18 лет 4 месяца
Благодарил (а): 7 раз

Re: User Blog Mod

Сообщение Jet »

Помогите разобраться с проблемой установки данного мода. Некоторое время назад установил его но были некоторые проблемы и пришлось удалить. Удалил не правильно. Не знал что в установщике есть функция uninstall и просто удалил таблицы из базы. Теперь при запуске установщика получаю вот такое сообщение:
Снимок.JPG
Я так понимаю, некоторые записи о моде все-же в базе остались и их нужно удалить. Только вот где искать? Все перерыл, не нашел.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: User Blog Mod

Сообщение Shredder »

Тебе мод не нужен? Тогда оставь всё в покое, эти записи в БД (если они есть) никому не помешают, т.к. вызовов в php для них больше нет. Или используй Support Toolkit
Аватара пользователя
Jet
phpBB 1.4.4
Сообщения: 100
Стаж: 18 лет 4 месяца
Благодарил (а): 7 раз

Re: User Blog Mod

Сообщение Jet »

Shredder
Спасибо за ответ, но мод как раз нужен. Пытаюсь установить.
velo
phpBB 2.0.1
Сообщения: 252
Стаж: 19 лет
Благодарил (а): 10 раз
Поблагодарили: 26 раз

Re: User Blog Mod

Сообщение velo »

Подскажите, в чём может быть проблема:

Пр использовании данного МОДа, favicon отображается на главной странице Блогов, частично на странице Блога пользователя (появилось после добавления иконки также и в корень папки, где расположены файлы мода) и практически никогда не отображается при просмотре какого-нибудь материала.

SEO Url включен, может быть эта проблема связана с этим?
WORK: phpBB3 3.0.8 + Portal XL 5.0 + MODs + Custom,
PHP Version 5.3.3-7+squeeze25, Apache/2.2.9 (Debian), MySQL(i) 5.1.73-1+deb6u1-log
Аватара пользователя
Nekstati
Поддержка
Поддержка
Сообщения: 3365
Стаж: 17 лет 6 месяцев
Благодарил (а): 37 раз
Поблагодарили: 1454 раза

Re: User Blog Mod

Сообщение Nekstati »

Вернуться в «Поддержка модов для phpBB 3.0.x»