Ошибка container_builder.php on line 146: require

Темы из форумов поддержки phpBB 3.2.x (доступны только для чтения)
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

После обновления до последней версии обнаружил (через несколько дней), что форум не работает. http://www.бахаи.kz/forum/
Очистка кэша не помогает. Права на паку выставлены корректно.

Код: Выделить всё

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php): failed to open stream: No such file or directory

Fatal error: require(): Failed opening required './cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/bahaiwiki/data/www/xn--80aab4a4d.kz/forum/phpbb/di/container_builder.php on line 146
Просьба помочь советом.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка container_builder.php on line 146: require

Сообщение nissin »

А если вручную почистить(удалить папку cache/production)?
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 13160
Стаж: 15 лет 1 месяц
Благодарил (а): 236 раз
Поблагодарили: 3750 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Татьяна5 »

Всё сейчас работает

Отправлено спустя 59 секунд:
Ошибка плавающая. Пару раз нажать f5 и сама пропадает
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

Это я принудительно кэш почистил. Сейчас наблюдаю. Создались файлы, которые не удалялись по FTP. Пользователи корректные. Кэш новый создался также корректно... в чем причина не понятно.
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка container_builder.php on line 146: require

Сообщение nissin »

Prometheus писал(а): 31.05.2018 16:11 Создались файлы, которые не удалялись по FTP
От какого пользователя работает PHP?
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

www-data
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка container_builder.php on line 146: require

Сообщение nissin »

А права на файлы, которые создаёт phpBB в каталоге cache какие?
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

777 на папку cache
папки внутри 755
файлы 666 и 644
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка container_builder.php on line 146: require

Сообщение nissin »

Понятно, phpBB не может определить, что PHP работает от другого пользователя.
Глянул код в 3.2.2, похоже на опечатку.
OPEN FILE
phpbb/filesystem/filesystem.php
FIND

Код: Выделить всё

				$php_uid	= (function_exists('posic_getuid')) ? @posix_getuid() : false;
REPLACE WITH

Код: Выделить всё

				$php_uid	= (function_exists('posix_getuid')) ? @posix_getuid() : false;
После этого почистить кэш, новые файлы должны быть 666, папки 777.
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

Спасибо!

Отправлено спустя 2 минуты 27 секунд:
Кэш вручную не чистить после изменения?
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Ошибка container_builder.php on line 146: require

Сообщение nissin »

Как раз для этого изменение, что бы права стояли нужные и вручную кэш очищался нормально.
А сама проблема вероятно из-за того, что хостер меняет владельца файлов в папке cache, уже сталкивались на hoster.kz.
Аватара пользователя
southklad
phpBB 3.1.0 RC4
Сообщения: 3468
Стаж: 14 лет 8 месяцев
Благодарил (а): 871 раз
Поблагодарили: 200 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение southklad »

Сейчас устанавливал расширение и столкнулся с такой же проблемой. Помогло ручное удаление файлов кеша. Это что баг 3.2.2?
Изображение
Prometheus
phpBB 1.4.4
Сообщения: 183
Стаж: 20 лет 4 месяца
Благодарил (а): 1 раз

Re: Ошибка container_builder.php on line 146: require

Сообщение Prometheus »

Опечатка в коде. Смотрите выше.

Вернуться в «phpBB 3.2.x (архив)»