Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекратила выпуск обновлений для phpBB версии 3.2.
С учетом этого, рекомендуется обновить конференции до версии 3.3.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до отдельного объявления.

Не работает функция обновления с 3.2.3 до 3.2.4

Проблемы с установкой или работой phpBB 3.2.x? Получите помощь здесь!
Внимание: с 7 ноября 2020 года phpBB Group завершает дальнейшее развитие phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до отдельного объявления.

Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Обновление с phpBB 3.2.2 до 3.2.3 проходило успешно, а вот с 3.2.3 до 3.2.4 что-то не захотело. Не сработал пакет автоматического обновления, поэтому заменил файлы в соответствии с инструкцией здесь. Теперь меня просят обновить СУБД, но я не могу! При переходе по ссылке /install/app.php/update я вижу сообщение "Пожалуйста, удалите, переместите или переименуйте папку install, прежде чем начнёте пользоваться конференцией. В противном случае будет доступен только администраторский раздел." При этом ссылка /install/app.php открывается нормально. Опять доставать STK?
Описание проблемы в форме STK 
Генератор запросов в службу поддержки

Какую версию phpBB вы используете?: phpBB 3.2.3
Какой тип/версию базы данных вы используете?: MySQL(i) 5.5.60-MariaDB
Какую версию PHP вы используете?: 5.6.25
Кто предоставляет услуги хостинга?: Собственный сервер.
Как вы установили вашу конференцию?: Я использовал установочный пакет с phpbbguru.net
Вы используете чистую установку или конвертацию?: Обновление с более ранней версии phpBB3
Какие расширения у вас установлены?: anavaro/autoban (active)
bb3mobi/seodesc (active)
boardtools/quickreply (active)
javiexin/chgposttime (active)
paybas/quickstyle (active)
phpbb/boardannouncements (active)
phpbb/boardrules (active)
phpbb/googleanalytics (active)
rubencm/customregistrationagreement (active)
tas2580/sitemap (active)
vse/dbtool (active)
Какие стили у вас установлены в данный момент?: prosilver (not active)
Digi
Digi Red
AllanStyle-SUBSILVER
Какие языковые пакеты установлены на вашей конференции?: Русский
Каков ваш уровень опыта?: Новичок в PHP, но не в phpBB
Какое имя пользователя можно использовать, чтобы увидеть проблему?: Ответ не предоставлен
Какой пароль можно использовать, чтобы увидеть проблему?: Ответ не предоставлен
Когда возникла ваша проблема?: В момент выхода обновления phpBB 3.2.4.
Опишите вашу проблему: Скачал пакет автоматического обновления с сайта phpbb.com для перехода с 3.2.3 на 3.2.4. Не работает /install/app.php/update, просит убрать с конференции папку install.
Затем удалил все папки кроме files, ext, images, store и styles, а также файла config.php. Залил новые файлы phpBB 3.2.4, конференция успешно вернулась к работе, но в ACP вижу уведомление, что "не удалось завершить обновление". Версии СУБД и файлов отличаются и нужно перейти в /install/app.php/update, выбрав только обновление базы. Получаю ту же ошибку конференции с просьбой убрать папку install. Обновление завершить не удаётся.

Создано при помощи генератора запросов в службу поддержки
Hello, Moto! :D
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 15 лет 9 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 41 раз
Поблагодарили: 1712 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Sheer »

SigmaTel71 писал(а): 02.12.2018 12:37 Не сработал пакет автоматического обновления
Сколько раз нужно говорить, что обновлять нужно по инструкции [FAQ] Обновление phpBB 3.2.x to phpBB 3.2.x
SigmaTel71 писал(а): 02.12.2018 12:37 Опять доставать STK?
Доставай и проверь какую версию phpBB определил STK.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Sheer писал(а): 02.12.2018 13:01 Сколько раз нужно говорить, что обновлять нужно по инструкции [FAQ] Обновление phpBB 3.2.x to phpBB 3.2.x
..."поэтому заменил файлы в соответствии с инструкцией здесь".
Sheer писал(а): 02.12.2018 13:01 Доставай и проверь какую версию phpBB определил STK.
STK говорит, что всё ещё 3.2.3. Видимо, из-за СУБД.
Hello, Moto! :D
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 11450
Стаж: 11 лет 3 месяца
Благодарил (а): 137 раз
Поблагодарили: 2131 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Татьяна5 »

SigmaTel71 писал(а): 02.12.2018 12:37 /install/app.php
Что происходит там? Вкладка "обновление" есть?
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Татьяна5 писал(а): 02.12.2018 13:08 Вкладка "обновление" есть?
Да, вкладка есть, но при переходе на неё получаю ошибку, где просят убрать папку install, чтобы получить доступ к конференции.
Hello, Moto! :D
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 11450
Стаж: 11 лет 3 месяца
Благодарил (а): 137 раз
Поблагодарили: 2131 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Татьяна5 »

Очистить кеш, физически, весь
Из store удалить логи от установки/обновления
Проверить не затёрся ли config.php, если что - вернуть из бекапа
И после этого попробовать перейти ещё раз
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Стартовая страница 
app_php.png
Обновление 
[app_php_update.png
Отправлено спустя 2 минуты 47 секунд:
Татьяна5 писал(а): 02.12.2018 13:14 Из store удалить логи от установки/обновления
Помимо файлов "migrations.log" есть ещё два файла: файл блокировки с расширением .lock и некий install_config. Их тоже убирать? Файлы бэкапа БД тоже есть, само собой.
Татьяна5 писал(а): 02.12.2018 13:14 Очистить кеш, физически, весь
Тупо сделать папку cache пустой?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Hello, Moto! :D
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 11450
Стаж: 11 лет 3 месяца
Благодарил (а): 137 раз
Поблагодарили: 2131 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Татьяна5 »

SigmaTel71 писал(а): 02.12.2018 13:19 Их тоже убирать?
Убирайте
SigmaTel71 писал(а): 02.12.2018 13:19 Тупо сделать папку cache пустой?
Почти
index.htm и .htaccess оставить (их оставляют всегда)
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Татьяна5 писал(а): 02.12.2018 13:22Убирайте
Удалил.
Татьяна5 писал(а): 02.12.2018 13:22 index.htm и .htaccess оставить (их оставляют всегда)
И всё равно не сработало. :?
Hello, Moto! :D
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Татьяна5, а может ли сработать вариант, где я "поднимаю" резервный сервер, на нём обновляю базу до phpBB 3.2.4, делаю её резервную копию, после чего восстанавливаю её на основном сервере?
Hello, Moto! :D
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 15 лет 9 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 41 раз
Поблагодарили: 1712 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Sheer »

Проще сделать это на своем домашнем компьютере.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
SigmaTel71
phpBB 1.4.0
Сообщения: 32
Стаж: 4 года 2 месяца
Откуда: Тула, Россия
Благодарил (а): 7 раз
Поблагодарили: 1 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение SigmaTel71 »

Sheer писал(а): 04.12.2018 22:25Проще сделать это на своем домашнем компьютере.
Таки да. Я свой второй комп так "в шутку" называю. :lol:
Получается, предложенный мною вариант обновления БД сработает?
Hello, Moto! :D
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 11450
Стаж: 11 лет 3 месяца
Благодарил (а): 137 раз
Поблагодарили: 2131 раз

Re: Не работает функция обновления с 3.2.3 до 3.2.4

Сообщение Татьяна5 »

Непонятно откуда идёт ошибка
Может сработать, может нет, но попробовать стоит

Вернуться в «Поддержка phpBB 3.2.x»