Сначала обновляется версия PHP сервера или версия форума?

Проблемы с установкой или работой phpBB 3.2.x? Получите помощь здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 29.12.2018 10:20

Здравствуйте!
Перед обновлением форума мне нужно сначала на хостинге установить требуемую версию PHP или сначала обновить форум до версии, поддерживаемой имеющейся версией PHP, и затем уже повышать версию PHP до 7-ой? Если я хочу обновить до самой последней - до 3.2.5.
Каков правильный порядок действий?

У меня сейчас форум 3.0.14 и на сервере PHP 5.4
в панели хостинга можно самостоятельно без проблем повысить версию PHP до 7.1
но если я сейчас сразу подниму PHP до 7.1 - смогу ли я форум 3.014 обновить до 3.1 и далее?
читал долго тут все справочные страницы - что форум 3.2.2 уже требует PHP 7 - но каков порядок повышения версии PHP, до обновления версии форума или после?
между обновлением форума до 3.2.1 и перед обновлением до 3.2.2 повышать PHP ?

Аватара пользователя
nissin
phpBB 3.0.3
Сообщения: 2168
Зарегистрирован: 16.12.2007 14:01
Откуда: Павлодар
Благодарил (а): 7 раз
Поблагодарили: 335 раз
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение nissin » 29.12.2018 10:26

Минимальные требования для phpBB 3.2 - PHP 5.4.7+
Т.е. можно обновить форум с текущей версией PHP.
Всё повторяется. nurlan.info

Перенесено из форума Рекрутинг в форум Поддержка phpBB 3.2.x 29.12.2018 10:29 модератором nissin

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 29.12.2018 10:36

Да, я видимо не вникнув прочел фразу (в новости о phpbb3.2.5): *PHP 5.4.7 и выше. Начиная с версии 3.2.2 совместимо с PHP 7.2 и выше.
т.е. что совместимо с PHP 7.2 и выше - вовсе не означает что это непременное требование для этой версии форума, а лишь допускает совместимость, корректную работу, и при этом может работать на версиях от 5.4.7 и выше.
Спасибо!

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 30.12.2018 12:00

Еще спрошу, только не ругайте... уж заодно в этой ветке, чтобы уж в одном месте все вопросы от одного автора.

Если у меня сейчас версия форума 3.0.14 - возможно ли ее сразу обновить до 3.2.5 ?
ну то есть без промежуточных этапов 3.1.х...
Или существует конкретный алгоритм (только так и никак иначе), когда 3.0.14 -> 3.1.12 -> 3.2.5 ?
Пожалуйста, подскажите, какие этапы мне нужно пройти, чтобы обновить 3.0.14 до 3.2.5

Заранее извиняюсь...

Аватара пользователя
nissin
phpBB 3.0.3
Сообщения: 2168
Зарегистрирован: 16.12.2007 14:01
Откуда: Павлодар
Благодарил (а): 7 раз
Поблагодарили: 335 раз
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение nissin » 30.12.2018 12:05

tomskafo, можно обновить сразу на 3.2.5
Всё повторяется. nurlan.info

LCFSCS
phpBB 1.2.1
Сообщения: 23
Зарегистрирован: 11.12.2018 19:51
Благодарил (а): 3 раза
Поблагодарили: 1 раз

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение LCFSCS » 05.01.2019 17:03

Включите PHP 5.6 (работают хорошо и старая, и новая версия форума), обновите форум и переключите PHP на нужную Вам версию (например 7.1).
Точно работает - пару недель назад мною проверено.

А в идеале сначала нужно "тренироваться на кошках" - на локалке установить копию сайта, на локалке же обновиться и только потом на хостинге обновляться, т.к. на локалке можно эксперементы проводить, а на работающем форуме крайне не желательно.

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 22.01.2019 17:55

Здравствуйте!
Обновил форум успешно с 3.0.14 до 3.2.5.

но... в архиве нового форума не было папки /ext
и в моей версии 3.0.14 такой папки не было.

и в результате я вижу тексты:

The "../ext/" directory does not exist.

а в админке форума вижу:



Произошла ошибка phpBB при компиляции контейнера, связанная с одним из установленных расширений. По этой причине, все установленные расширения были временно отключены. Попробуйте очистить кэш конференции. Все расширения будут автоматически включены, если ошибка контейнера будет устранена. В противном случае, обратитесь на сайт официальной русской поддержки phpBB Guru для получения помощи.

Исключение: The "./../ext" directory does not exist.

#0 /forum/phpbb/di/container_builder.php(655): Symfony\Component\Finder\Finder->in('./../ext')
#1 /forum/phpbb/di/container_builder.php(187): phpbb\di\container_builder->register_ext_compiler_pass()
#2 /forum/common.php(115): phpbb\di\container_builder->get_container()
#3 /forum/adm/index.php(23): require('/home/fr5243/pu...')
#4 {main}

------------------------
как быть? обращаюсь к вам как тут написано.
архив с новой русской версией скачал тут.
Последний раз редактировалось tomskafo 22.01.2019 18:22, всего редактировалось 1 раз.

apograph
phpBB 1.4.3
Сообщения: 80
Зарегистрирован: 03.04.2017 15:29
Благодарил (а): 4 раза
Поблагодарили: 18 раз

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение apograph » 22.01.2019 18:02

В архиве 3.2.5 есть папка ext.

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 22.01.2019 18:06

уф.... нашел... я ее удалил из архива вместе с теми папками. которые заменять было не нужно.

что мне теперь делать? заново запускать обновление базы данных?

Отправлено спустя 4 минуты 56 секунд:
я уже удалил с фтп папку install

мне ее нужно заново залить и повторить обновление БД?
т.к. в админке в последнем разделе"Настройка расширений" я вижу такой текст:

Общая ошибка
Не найден модуль ./../includes/acp/acp_altt.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 9421
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 167 раз
Поблагодарили: 2629 раз
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение Татьяна5 » 22.01.2019 18:35

tomskafo писал(а):
22.01.2019 18:10
что мне теперь делать?
Залить папку ext на сервер
Повторять обновление БД, если оно прошло до конца, не надо
tomskafo писал(а):
22.01.2019 18:10
Не найден модуль ./../includes/acp/acp_altt.php
Не удалили остатки модов
Удаляйте теперь через STK ("проверка изменений в базе данных")

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 22.01.2019 18:37

Где находится это STK ("проверка изменений в базе данных") ? где мне его найти?


tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 22.01.2019 19:02

запустил stk

нужно удалять все записи со значением altt ?

вспомнил, это был установлен мод вывода последних затронутых тем на список форума.
сам мод перед обновлением был деактивирован, а записи от его установки видимо остались.
вот эти все записи нужно удалять или нет?
Вложения
555543332.jpg

Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 9421
Зарегистрирован: 08.08.2011 2:02
Благодарил (а): 167 раз
Поблагодарили: 2629 раз
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение Татьяна5 » 22.01.2019 19:25

Удаляйте всё нестандартное, оно будет мешать (разве что ботов и прочие мелочи можно оставить)

tomskafo
phpBB 1.4.2
Сообщения: 54
Зарегистрирован: 29.12.2018 10:05
Откуда: Tomsk
Благодарил (а): 14 раз
Поблагодарили: 3 раза
Контактная информация:

Re: Сначала обновляется версия PHP сервера или версия форума?

Сообщение tomskafo » 22.01.2019 19:28

Всё что выше - всё поудалял...
запускал STK ("проверка изменений в базе данных")

однако в админке форума по прежнему на последней кнопке "Настройка расширений" написано:
Общая ошибка
Не найден модуль ./../includes/acp/acp_altt.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

вот скрин что у меня только последнего осталось, что я не удалял при помощи STK - это у меня текстовое подтверждение, модуль против спам-ботов.

Что делать теперь? ведь по прежнему пишет что Не найден модуль ./../includes/acp/acp_altt.php
кэш многократно обновил уже... не помогает.
Вложения
1112222334.jpg

Ответить

Вернуться в «Поддержка phpBB 3.2.x»