Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекращает поддержку phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2020 года.
С учетом этого, а также того, что версия 3.2.x больше не будет получать обновлений, за исключением связанных с проблемами безопасности
(только при их наличии и только до 7 ноября 2020 года), рекомендуется обновить конференции до версии 3.3.x.

Ошибка после смены версии php

Проблемы с установкой или работой phpBB 3.2.x? Получите помощь здесь!
Внимание: с 7 ноября 2020 года phpBB Group завершает дальнейшее развитие phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до отдельного объявления.

Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Triniti
phpBB 2.0.1
Сообщения: 297
Стаж: 8 лет 1 месяц
Благодарил (а): 57 раз

Ошибка после смены версии php

Сообщение Triniti »

Повысила версию php, чтобы потом повысить версию форума.
Несколько часов всё было нормально.
Сейчас вверху вижу ошибку (см. файл)
Что это такое и как исправить?

Версия форума сейчас 3.2.5
Версия php была 5.6.
Сейчас 7.1.33
Вложения
er.JPG
Последний раз редактировалось Triniti 29.01.2021 9:20, всего редактировалось 1 раз.
Аватара пользователя
Pazh
Former team member
Сообщения: 2294
Стаж: 11 лет 8 месяцев
Благодарил (а): 42 раза
Поблагодарили: 498 раз

Re: Ошибка после смены версии php

Сообщение Pazh »

Triniti, это ошибка sql при попытке получить какие-то данные, которых нет. Скорее всего ошибка в каком-то расширении и со сменой версии php мало вероятно что связано. Просто поймали его после смены - совпадение.
Помощь в ЛС/email только за WM или ЮMoney
Triniti
phpBB 2.0.1
Сообщения: 297
Стаж: 8 лет 1 месяц
Благодарил (а): 57 раз

Re: Ошибка после смены версии php

Сообщение Triniti »

Вообще вчера после смены в админке видела сообщение насчет расширения Livesearch (быстрый поиск), какая-то ошибка.
Наверное, надо его отключить, тогда. Попробую. Всё равно для смены версии отключать.
---------------------

Через 10 минут.
Теперь вообще не вижу форум (см. файл er2)

Вчера было такое, еще при попытке хостинга сменить версию php. Обращалась к ним, они что-то делали. Потом сменилась версия php, форум заработал. И вот, сегодня снова такое. Опять к ним обращаться или что это?

Отправлено спустя 19 минут 31 секунду:
После того как удалила папку alg, где находится это расширение, появилось другое сообщение, вместо форума (см. файл er)
И оно остается, после того как снова скопировала эту папку в файлы расширений.
Что мне делать?
Вложения
er.JPG
er2.JPG
Аватара пользователя
Татьяна5
Поддержка
Поддержка
Сообщения: 10633
Стаж: 9 лет 11 месяцев
Благодарил (а): 185 раз
Поблагодарили: 3008 раз

Re: Ошибка после смены версии php

Сообщение Татьяна5 »

Triniti писал(а): 29.01.2021 9:42 После того как удалила папку alg
Расширение в админке перед этим отключали? Удалять файлы без отключения расширений нельзя

Для начала попробуйте очистить кеш, физически
Triniti
phpBB 2.0.1
Сообщения: 297
Стаж: 8 лет 1 месяц
Благодарил (а): 57 раз

Re: Ошибка после смены версии php

Сообщение Triniti »

Форум уже заработал. На новой версии php.
Это как-то сделали специалисты хостинга, когда обратилась к ним.
Возможно, повторным копированием файлов.
Или проблема была не столько в расширении.
Потом вошла в админку и его отключила.
Triniti
phpBB 2.0.1
Сообщения: 297
Стаж: 8 лет 1 месяц
Благодарил (а): 57 раз

Re: Ошибка после смены версии php

Сообщение Triniti »

Заметила существенную ошибку, после смены версии php.
Снова не отображаются видео в тэгах media
Как-то здесь уже решала эту проблему, в теме "Новый смартфон" , видимо, это было как-то связано.
Re: Новый смартфон

Как это исправить? Хотелось бы видеть ранее опубликованные в постах видео, на форуме.

Вижу, там в теме мне рекомендовали скрипт
Sheer писал(а): 15.03.2019 19:34 Первое, что вам нужно сделать это скачать скрипт http://phpbbex.com/api/bbmedia.js и записать его на свой сервер, например в корневую папку своего форума, после чего изменить в ACP--СООБЩЕНИЯ--BBCodes для bb-кода [video] (или как он там у вас)
Возможно, он теперь с чем-то конфликтует?..

Файл bbmedia.js у меня точно есть, в корневой папке, наверное, тогда его туда записала.
Как и что мне исправить, чтобы видео были видны на форуме?
Аватара пользователя
ronim
phpBB 2.0.7
Сообщения: 594
Стаж: 3 года 6 месяцев
Откуда: Таллин ,Эстония
Благодарил (а): 125 раз
Поблагодарили: 93 раза

Re: Ошибка после смены версии php

Сообщение ronim »

Triniti, зачем такие проблемы ,если есть такое расширение phpBB Media Embed PlugIn.Которое работает на 3.3.3 и PHP8
Если ты не видишь проблем на форуме , но это не значить что их там нет
Triniti
phpBB 2.0.1
Сообщения: 297
Стаж: 8 лет 1 месяц
Благодарил (а): 57 раз

Re: Ошибка после смены версии php

Сообщение Triniti »

Только начала менять версию форума, еще пока не получилось.
И у меня php 7.1.33, восьмерки нет.

Вернуться в «Поддержка phpBB 3.2.x»