500 Internal Server Error

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Скажите, пожалуйста.
в журнале ошибок вижу такую запись:
[error] [client 37.19.145.117] File does not exist: /home/..../public_html/.../500.shtml, referer: http://.../index.php

Как может отсутствующий файл вызывать ошибку 500?

У меня таких файлов миллион. Как вообще запретить индексировать такие файлы.
Форум перестраивался, страницы удалялись и т.д. Где я их сейчас возьму...
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

Как-как? Ды вот так. Отсутствующий файл — критическая ошибка. Вот ты и получаешь о ней уведомление.
Где я их сейчас возьму...
Ну так и не фига было перестраивать форум без резервной копии всех файлов. Кто тебе сейчас эти файлы искать будет?
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

МайскийЖук писал(а):Отсутствующий файл — критическая ошибка. Вот ты и получаешь о ней уведомление.
Так я не понял. Может ли эта критическая ошибка вызывать ошибку 500 Internal Server Error?
Аватара пользователя
Pazh
Former team member
Сообщения: 2317
Стаж: 16 лет 10 месяцев
Благодарил (а): 42 раза
Поблагодарили: 506 раз

Re: 500 Internal Server Error

Сообщение Pazh »

Эта запись говорит только о том что отсутствует файл 500.shtml который лежал по указанному пути и судя по названию это файл, который должен показываться юзеру при 500-ой ошибке. Это не критично и никак не является причиной появления 500 ошибки
Помощь в ЛС/email только за WM или ЮMoney
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

Подскажите, как мне выяснить что это за процесс такой привел к нагрузке:

Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/lstoursc/public_html/jesus-forum.com/viewtopic.php
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

Вообще-то в этой строке все написано: /suphp. Что еще надо-то?
не является причиной появления 500 ошибки
Sheer, вообще-то человек и не говорил, что у него выскакивает ошибка 500, он говорил лишь о записи в логе, свидетельствующей об отсутствующем файле.
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

МайскийЖук писал(а):него выскакивает ошибка 500
Выскакивает такая ошибка. Просто тема про это. Поэтому я и не акцентировал внимание.
Ищу причину этого.
Поэтому и спросил, может ли отсутствующий файл это вызвать. Понял, что нет.

Запись:
/suphp
мне не понятна. Если можно разъяснить или направить где это можно прочитать, буду благодарен!
И можно ли мне как то решить эту проблему? Что бы не грузила память. Я так понимаю, что из-за перегрузки выскакивает ошибка 500...
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

может ли отсутствующий файл это вызвать. Понял, что нет.
Я не знаю, с чего вдруг ты это понял, если я выше написал, что это вполне может быть критичной ошибкой и вызывать Internal Server Error.
направить где это можно прочитать
На официальном сайте suPHP, например.
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

МайскийЖук писал(а):На официальном сайте suPHP, например.
Спасибо.
Ответь на еще вопрос: Можно ли мне как то решить эту проблему? И как?
Что бы не грузила память.
Я так понимаю, что из-за перегрузки выскакивает ошибка 500...
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

Да как-как? Попроси хостера увеличить объем облачной памяти. Или сайт свой оптимизируй.
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

МайскийЖук писал(а):Попроси хостера увеличить объем облачной памяти
Скажите, такие данные нового хостинга помогут избавиться от проблемы?

Unlimited Websites∞, Space+ & Bandwidth
1000 Email Accounts2
Unlimited MySQL Databases (1 GB ea.)
FREE†† Premium DNS, Malware Scanner, SSL Certificate with Fixed IP address
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

Тут, считай, вообще ничего не сказано, из чего можно сделать вывод о том, поможет ли тебе это избавиться от проблемы с перегрузкой.
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
Shimon197628
phpBB 1.4.1
Сообщения: 42
Стаж: 13 лет 10 месяцев
Благодарил (а): 3 раза

Re: 500 Internal Server Error

Сообщение Shimon197628 »

МайскийЖук писал(а):поможет ли тебе это избавиться от проблемы с перегрузкой.
Не хочу выкладывать все полотенце здесь. Вот адрес: http://www.godaddy.com/hosting/web-host ... 75&ci=8971 План - Ultimate
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

500 Internal Server Error

Сообщение МайскийЖук »

Ну, судя по описанию тарифа, тебе дадут доступ к php.ini, а это уже неплохо, сможешь сам регулировать, например, время, отведенное для загрузки файлов, или объем памяти, выделяемый под те или иные операции.

Решит ли это твою проблему с ошибкой 500? Да хрен его знает. Мы ж так и не поняли, из-за чего конкретно у тебя возникает перегрузка. Может у тебя там какой-нибудь циклический запрос или вообще хрен знает что, для чего никакой облачной памяти не хватит. Я еще раз говорю: оптимизируй сайт.
Любовь и боль, покой и бой я как любой несу с собой…
Аватара пользователя
miba
phpBB 2.0.4
Сообщения: 432
Стаж: 19 лет 8 месяцев
Благодарил (а): 86 раз
Поблагодарили: 7 раз

Re: 500 Internal Server Error

Сообщение miba »

у меня 500 и 503 вылазили, когда не хватало ресурсов сервера, слава Богу, забыл про них.

Вернуться в «Поддержка phpBB 3.0.х»