Проблемы с аватарами

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
sana1
phpBB 1.2.0
Сообщения: 15
Стаж: 18 лет 4 месяца

Re: Проблемы с аватарами

Сообщение sana1 »

rxu писал(а):Загадкой остается, почему phpBB2. Ну да ладно.
Сайту 7 лет. И переписывать адрес на всех страницах 2000 .... проблематично. Вот и осталась та же директория.

Аватары, наконец то встали. Всем, кто делился своими знаниями большое спасибо.
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: Проблемы с аватарами

Сообщение MAzZY »

Подскажите такую вещь.
В сообщениях аватары не отображаются, а в профиле пользователя они есть. Подозреваю, что где-то надо что-то включить, но никак не найду где именно
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Re: Проблемы с аватарами

Сообщение Палыч »

MAzZY
Возможно в собственном личном разделе (личные настройки - настройки отображения - показывать аватары)
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
MAzZY
Бывший член :)
Сообщения: 2925
Стаж: 21 год 4 месяца
Благодарил (а): 79 раз
Поблагодарили: 69 раз
Забанен: Бессрочно

Re: Проблемы с аватарами

Сообщение MAzZY »

Большое спасибо за точное указание места ошибки. Действительно, сказалась неверная установка одного мода в файле viewtopic.php. Теперь все как надо работает
Аватара пользователя
RDJ
phpBB 1.4.3
Сообщения: 80
Стаж: 19 лет 6 месяцев
Откуда: -=ТАТАРСТАН=-
Благодарил (а): 1 раз

Re: Проблемы с аватарами

Сообщение RDJ »

Перестали отображаться аватары.

1. Сконвертировал форум из phpBB 2, аватары отображались нормально.
2. Спустя два дня сайт кто то поломал, дописали в индексных и некоторых других файлах по всему сайту скрипт, в результате пришлось переписать все файлы. Базы остались те же.
3. Скрипта нового форума не было, залил его заново с локалки. Изменил config.php. Переместил вложения, аватарки, смайлы из папок форума phpBB 2 в соответствующие папки на phpBB 3. Выставил нужные права.
4. Форум нормально встал. Только аватары перестали отображаться. Вложения показываются нормально, а вот аватарки не отображаются. Ново залитые показываются, а старые нет.

В чём может быть проблема?
вот форум lastxaoc.net/forum/
Аватара пользователя
RDJ
phpBB 1.4.3
Сообщения: 80
Стаж: 19 лет 6 месяцев
Откуда: -=ТАТАРСТАН=-
Благодарил (а): 1 раз

Re: Проблемы с аватарами

Сообщение RDJ »

Подскажите, пожалуйста, в каком направление копать?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Проблемы с аватарами

Сообщение Rayden »

В строну названия файлов с аватарами и в сторону прав на эти файлы.
А вообще правило 3.5 никто не отменял. :evil:
phpBB2 FAQ
phpBB3 FAQ
Аватара пользователя
RDJ
phpBB 1.4.3
Сообщения: 80
Стаж: 19 лет 6 месяцев
Откуда: -=ТАТАРСТАН=-
Благодарил (а): 1 раз

Re: Проблемы с аватарами

Сообщение RDJ »

Rayden спасибо теперь понял в чем проблема, не думал что при конвертации названия аватарок изменяются :(
Аватара пользователя
RDJ
phpBB 1.4.3
Сообщения: 80
Стаж: 19 лет 6 месяцев
Откуда: -=ТАТАРСТАН=-
Благодарил (а): 1 раз

Re: Проблемы с аватарами

Сообщение RDJ »

понял как прописываются аватары, название аватарки имеет название: префикс_id пользователя.расширение
Это префикс можно посмотреть в БД phpbb_config -> avatar_salt

Решил проблему следующим образом:
1. Установил phpbb 3 в новую папку.
2. Заново сконвертировал phpbb 2 в phpbb 3.
3. Таким образом получил аватарки с префиксом, переместил эти аватарки в папку с images/avatars/upload нужного нам форума.
4. Скопировал префикс, отредактировал БД нужного мне форума -> вставил полученный префикс.
5. Очистил кеш в админке.
6. Удалил ненужную папку с форумом и базу.

Проделал это на двух форумах, сначала на локалке, а потом и на сервере, оба раз успешно.

Не спорю что есть способ проще, просто до чего додумался.
Koyot
phpBB 1.4.0
Сообщения: 32
Стаж: 18 лет 7 месяцев

Re: Проблемы с аватарами

Сообщение Koyot »

Суть проблемы такова, грузятся аватары, но не все, тоесть: .gif грузить, а такой же тока с празрачным фоном уже нет, что делать. И проблема не только с гифами. Грузить как-то странно и не все. Все соответствуют требованиям.
Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 648
Стаж: 19 лет 4 месяца
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз

Re: Проблемы с аватарами

Сообщение DeathMan »

Столкнулся с такой проблемой:
- не могу через админку увеличить не объём аватара, не размер, при попытке сделать это, выкидывает на чистый лист и всё....


phpbb3.0.2
база перекидывалась с бесплатного хоста на платный

P.S. Блин. после переезда на новый хостинг, перестали работать любые изменения производимые в админке !
phpbb3 - сила!
Аватара пользователя
Master of Tragedy
phpBB 1.4.2
Сообщения: 68
Стаж: 19 лет 1 месяц
Откуда: Санкт-Петербург

Re: Проблемы с аватарами

Сообщение Master of Tragedy »

DeathMan
А причем тут форум? Смотрите логи сервера, разговаривайте с хостером.
Ce grand malheur de ne pouvoir etre seul...
Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 648
Стаж: 19 лет 4 месяца
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз

Re: Проблемы с аватарами

Сообщение DeathMan »

Master of Tragedy писал(а):DeathMan
А причем тут форум? Смотрите логи сервера, разговаривайте с хостером.
а они тут причём, это по любому форум... до переезда всё работало!
phpbb3 - сила!
Аватара пользователя
Master of Tragedy
phpBB 1.4.2
Сообщения: 68
Стаж: 19 лет 1 месяц
Откуда: Санкт-Петербург

Re: Проблемы с аватарами

Сообщение Master of Tragedy »

DeathMan
Откуда такая уверенность в своей правоте? Вы сюда зачем пришли? Чтобы вам помогли или зачем еще? Еще раз говорю, смотрите логи сервера и делайте выводы, почему и откуда берется "белая страница".
П.С Если вы не хотите, чтобы вам тут помогали, делайте все самостоятельно, раз умнее нас...
Ce grand malheur de ne pouvoir etre seul...
Аватара пользователя
DeathMan
phpBB 2.0.7a
Сообщения: 648
Стаж: 19 лет 4 месяца
Откуда: Курская обл.
Благодарил (а): 73 раза
Поблагодарили: 8 раз

Re: Проблемы с аватарами

Сообщение DeathMan »

Вот лог, посмотрите пожалуйста, что можно с этим сделать:

Код: Выделить всё

[Sun Sep 28 21:09:14 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:09:21 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:11:28 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:12:03 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:14:19 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:14:24 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=board&mode=avatar
[Sun Sep 28 21:35:52 2008] [error] [client 80.240.242.129] PHP Fatal error: Not able to open ./../cache/data_global.php in /var/www/vhosts/xxx.ru/subdomains/forum/httpdocs/includes/acm/acm_file.php on line 106, referer: http://forum.xxx.ru/adm/index.php?sid=c8d8b6b96485f01e0372d771708f267c&i=attachments&icat=9&mode=attach
phpbb3 - сила!

Вернуться в «Поддержка phpBB 3.0.х»