Вышел phpBB 3.0.6 [обсуждаем]
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Что в errorlog?
Это не совсем те ошибки.
У меня складывается смутное подозрение, что Вы фактически обновляли 3.0.4 файлами автоматического обновления для 3.0.5.
Т.е. при обновлении до 3.0.5 обновили только базу данных, но не файлы.
Это не совсем те ошибки.
У меня складывается смутное подозрение, что Вы фактически обновляли 3.0.4 файлами автоматического обновления для 3.0.5.
Т.е. при обновлении до 3.0.5 обновили только базу данных, но не файлы.
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Вышел phpBB 3.0.6 [обсуждаем]
500 - Internal Server Error - в процессе обработки запроса произошёл внутренний сбой на сервереfanatic писал(а):выскакивает с завидной регулярностью ошибка
500 Internal Server Error
Здесь что-то серьезней, чем простая картинка
-
fanatic
- phpBB 2.0.0
- Сообщения: 244
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 2 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Так я же давно обновлялся. Как только выходит новая версия, я сразу ее обновляю До этого пользовался автоматическими обновлениями и все всегда проходило четко и работало исправно.
Это и было из файла error_log
Добавлено спустя 1 минуту 12 секунд:
Это и было из файла error_log
Добавлено спустя 1 минуту 12 секунд:
Но ссылается именно на эти ошибки :roll:MAzZY писал(а): Здесь что-то серьезней, чем простая картинка
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Ещё раз, "500 Internal Server Error" не имеет отношения к приведённым Вами ошибкам.
Кстати, то что при загрузке главной страницы, браузеры пользователей пытаются загрузить данные изображения, говорит о том что вы их не вычистили из используемого шаблона и темы.
У меня нет другого объяснения предыдущей ошибки с отсутствием настроек капчи в constants.php
Кстати, то что при загрузке главной страницы, браузеры пользователей пытаются загрузить данные изображения, говорит о том что вы их не вычистили из используемого шаблона и темы.
У меня нет другого объяснения предыдущей ошибки с отсутствием настроек капчи в constants.php
-
fanatic
- phpBB 2.0.0
- Сообщения: 244
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 2 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Скажите nissin, а в каком файле следует покопаться, что бы найти обращение к этим файлам?
Если это мне адресовано, то я уже все отремонтировал.
Код: Выделить всё
[b]У меня нет другого объяснения предыдущей ошибки с отсутствием настроек капчи в constants.php[/b]-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Это уже Вам должно быть виднее, где Вы ссылки на них оставили.
Ну это понятно, что файл Вы заменили, просто мне думается, что это не последний файл с ошибками.
Ну это понятно, что файл Вы заменили, просто мне думается, что это не последний файл с ошибками.
-
fanatic
- phpBB 2.0.0
- Сообщения: 244
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 2 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Только что я обновлял вашу страницу с форумом и было тоже самое. Несколько раз происходило - 500 Internal Server Error
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Вышел phpBB 3.0.6 [обсуждаем]
Я и не заметил, что это опять fanatic
Говорящий ник.
У Вас снова проблема с обновлением. Но теперь неявная. Что-то Вы нафигачили снова.
Модов много? Я предлагаю Вам установить чистый движок и накатить на него _актуальные_ версии всех нужных модов. Иначе ошибки будут преследовать Вас еще долго.
Говорящий ник.
У Вас снова проблема с обновлением. Но теперь неявная. Что-то Вы нафигачили снова.
Модов много? Я предлагаю Вам установить чистый движок и накатить на него _актуальные_ версии всех нужных модов. Иначе ошибки будут преследовать Вас еще долго.
-
fanatic
- phpBB 2.0.0
- Сообщения: 244
- Стаж: 17 лет 6 месяцев
- Благодарил (а): 2 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
В общем проблемы нужно решать по мере их возникновения. Взять все заново поставить - это не очень хорошая идея. Щас мне, не без вашей помощи конечно, удалось добиться удовлетворительной работы форума. Но некоторые моменты, конечно, возникают. Просто нужно в них разобраться. А модов прилично стоит всяких.
-
Fray98rus
- Former team member
- Сообщения: 442
- Стаж: 18 лет 11 месяцев
- Откуда: Санкт-Петербург
- Благодарил (а): 3 раза
- Поблагодарили: 2 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Их можно решать долго..fanatic писал(а):В общем проблемы нужно решать по мере их возникновения.
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Вышел phpBB 3.0.6 [обсуждаем]
Вы понимаете, что при обновлении что-то пошло не так? Причем конкретно. Может быть все эти моды начали конфликтовать, потому что они не могут работать 3.0.6. Может быть из-за этих модов в код были внесены такие правки, что при обновлении произошли ошибки, которые будут всплывать все оставшееся время.fanatic писал(а):А модов прилично стоит всяких.
Посмотрите хотя бы обновления этих модов
-
rewter
- phpBB 1.0.0
- Сообщения: 7
- Стаж: 16 лет 9 месяцев
Re: Вышел phpBB 3.0.6 [обсуждаем]
И все-таки эту проблему так и не могу решить после обновления на 3.0.6.rewter писал(а):Когда я обновил 3.0.5 => 3.0.6, то у меня было четыре ошибки
...
4. Вот эту проблему до сих пор не могу решить. Значек "Перейти к первому непрочитанному сообщению", который помещается у названия топика, стал давать непредсказуемые результаты. У некоторых тем все нормально, а некоторые темы стали как заклятые. Например, в теме 15 страниц, там вот, переходишь по этому значку постоянно в одно и то же место - на 10-ю страницу, посты на которой от сентября месяца. И опять тема остается в Непрочитанных сообщениях, и нажатие на этот же значек приводит опять к этому же результату.
Кеш очищал, базу восстанавливал и делал прочие пляски с бубном. Ничего не помогает.
Скажите пожалуйста, где копать?
При нажатии на
Очистка кеша, отметка всех постов на как прочитанные, сброс сессий - ничего не помогает, значек "Перейти к первому непрочитанному сообщению" опять направляет не туда. А в некоторых темах ведет корректно.
Подскажите пожалуйста, где копать?
И какая таблица базы отвечает за непрочитанные посты? И что бы такого можно было с ней сделать?
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Таблицы phpbb_topics_track и phpbb_forums_track.
Проверьте настройку в "Нагрузке на сервер"
Проверьте настройку в "Нагрузке на сервер"
Код: Выделить всё
Включить маркировку тем на сервере:
Сохранять информацию о статусе «прочитано/не прочитано» в базе данных, а не в cookies.-
rewter
- phpBB 1.0.0
- Сообщения: 7
- Стаж: 16 лет 9 месяцев
Re: Вышел phpBB 3.0.6 [обсуждаем]
Спасибо, в нагрузке так и стояяло, это я смотрел..Таблицы phpbb_topics_track и phpbb_forums_track.
Проверьте настройку в "Нагрузке на сервер"
Может очистить эти таблицы, что скажете?
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Вышел phpBB 3.0.6 [обсуждаем]
Можно в принципе. Плюс ещё нужно изменить поле user_lastmark таблицы phpbb_users
Как всегда желательно сделать backup перед запросом 
Код: Выделить всё
DELETE FROM phpbb_topics_track;
DELETE FROM phpbb_forums_track;
UPDATE phpbb_users SET user_lastmark = UNIX_TIMESTAMP();
