Общая база юзеров в Wordpress и phpBB
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Vityas
- phpBB 1.4.4
- Сообщения: 179
- Стаж: 17 лет 5 месяцев
- Благодарил (а): 59 раз
-
Vityas
- phpBB 1.4.4
- Сообщения: 179
- Стаж: 17 лет 5 месяцев
- Благодарил (а): 59 раз
Re: Общая база юзеров в Wordpress и phpBB
PHPBB Single Sign On на денвере встал нормально, однако при регистрации из под wp, в phpbb не передается значение email. При регистрации на форуме в wp все передавалось нормально. Однако на хостинге, после установки моста, не регистрируются новые пользователи: приходит на email логин-пароль, однако система отвечает, что пароль не подходит. В общем даже и не знаю где там можно накосячить, т.к. плагин совсем простенький.
С WP-United же дело дальше визарда дело не идет. Вроде все оставлял по дефолту, однако в конце выдает либо просто не известную ошибку, либо Internal Server Error
Специально всё проводил на чистых форуме и блоге. Вообще получалось настроить связку между wp 3.0.1 и phpbb 3.0.7 ?
С WP-United же дело дальше визарда дело не идет. Вроде все оставлял по дефолту, однако в конце выдает либо просто не известную ошибку, либо Internal Server Error
Специально всё проводил на чистых форуме и блоге. Вообще получалось настроить связку между wp 3.0.1 и phpbb 3.0.7 ?
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Общая база юзеров в Wordpress и phpBB
Тоже недавно пробовал с wp 3.0.1, при установке - то же самое. Лазанье по иностранным сайтам в поисках ответа и предложенные там фиксы не помогли, у многих такое. Остаётся ждать новой версии.Vityas писал(а): Internal Server Error
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Общая база юзеров в Wordpress и phpBB
Это как у вас обоих получилось?Vityas писал(а):Internal Server Error
-
Vityas
- phpBB 1.4.4
- Сообщения: 179
- Стаж: 17 лет 5 месяцев
- Благодарил (а): 59 раз
Re: Общая база юзеров в Wordpress и phpBB
На денвере выдало просто undef error. Устанавливал через автомод. Потом развернул все у хостера, только на этот раз устанавливал вручную. Результат - Internal Server Error Все параметры в визарде оставлял по умолчанию.
А у тебя получилось привязать?
А у тебя получилось привязать?
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Общая база юзеров в Wordpress и phpBB
В админке, на пятом этапе конфигуратора Wp-united. Пробовал любые настройки, которые там предлагались - бестолку. У форума - обычный .htaccess от версии 3.0.5 (я это не у себя делал):MAzZY писал(а):Это как у вас обоих получилось?
Код: Выделить всё
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>Код: Выделить всё
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPresshttp://сайт.com/forum/-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Общая база юзеров в Wordpress и phpBB
Shredder, так ты говоришь сначала, что у тебя тройка, а потом оказывается, что у тебя включен Wp-united. Ты инструкцию по включению читал вообще?
http://codex.wordpress.org/%D0%A1%D0%BE ... 1%82%D0%B8
http://codex.wordpress.org/%D0%A1%D0%BE ... 1%82%D0%B8
-
Shredder
- Former team member
- Сообщения: 2266
- Стаж: 17 лет 9 месяцев
- Благодарил (а): 283 раза
- Поблагодарили: 584 раза
Re: Общая база юзеров в Wordpress и phpBB
Ничего не понял, что ты этим хотел сказать...
Wp 3.0.1, phpBB 3.0.5, установил на форум мод Wp-united, выполнил все пункты инструкции, и на пятом этапе Setup wizard'а:
Wp 3.0.1, phpBB 3.0.5, установил на форум мод Wp-united, выполнил все пункты инструкции, и на пятом этапе Setup wizard'а:
- лезет этот Internal Server Error.WP-United Setup Wizard – Step 5 of 6.
Applying Settings
Installing WP-United
WP-United is now applying the integration settings.
-
MAzZY
- Бывший член :)
- Сообщения: 2925
- Стаж: 21 год 4 месяца
- Благодарил (а): 79 раз
- Поблагодарили: 69 раз
- Забанен: Бессрочно
Re: Общая база юзеров в Wordpress и phpBB
О, извини. Что-то я с утра ничего не сообразил. Перепутал с MU.
Попробуй логи посмотреть или в теме с поддержкой поискать.
Попробуй логи посмотреть или в теме с поддержкой поискать.
-
Vityas
- phpBB 1.4.4
- Сообщения: 179
- Стаж: 17 лет 5 месяцев
- Благодарил (а): 59 раз
Re: Общая база юзеров в Wordpress и phpBB
Видимо придется ждать версии 0.9 http://www.wp-united.com/2010/08/25/wp- ... neak-peek/
Я так понимаю, чтобетка ее есть rc3, вот только не нашел в открытом доступе :(
Я так понимаю, что
-
stanislav-zz
- phpBB 1.2.1
- Сообщения: 26
- Стаж: 16 лет 10 месяцев
- Откуда: Москва
Re: Общая база юзеров в Wordpress и phpBB
а кто-нибудь настраивал htaccess с форумом где стоит SEO мод и wordpress?
-
kils
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 15 лет 9 месяцев
Re: Общая база юзеров в Wordpress и phpBB
пытаюсь настроить связку wp 3.0.1 и PHPBB Single Sign On 0.7.1. wpunited сразу забросил даже все 5 шагов пройти не удается (( С PHPBB Single Sign On 0.7.1 все работает кроме пары моментов:
1) при регистрации через WP e-mail не переносится на форум (думаю это важно, так как я сам часто ставлю оповещения из топика на email)
2) при выходе через WP выдается 502 ошибка.
На самом деле мне интересно как он работает с 2.9.2, но судя по всему почтовые адреса переноситься не будут, что не есть гуд. Сейчас пытаюсь разобраться в этом баге и с выходом через WP. Через некоторое время напишу что получилось, но если кто-то уже исправил эти проблемы отпишите плиз.
Пока думается мне дать ссылку на выход через форумную ссылку с обратным редиректом на WP, но разбираться еще придется.
После изучения файлов нашел вот такую штуку в файле auth_wpbb.php (который записывается в директория авторизации форума):
четно говоря я думаю проблема где-то здесь в том что не переносится запись e-mail с блога на форум, тогда как обратно переносится, так как я php на начальном уровне, я бы даже скзаал на совсем началоном мне здесь тяделовато разобраться, кто шарит расскажите что и как, а да, в обеих базах колонка с e-mail пользователя называется одинаково - user_email
1) при регистрации через WP e-mail не переносится на форум (думаю это важно, так как я сам часто ставлю оповещения из топика на email)
2) при выходе через WP выдается 502 ошибка.
На самом деле мне интересно как он работает с 2.9.2, но судя по всему почтовые адреса переноситься не будут, что не есть гуд. Сейчас пытаюсь разобраться в этом баге и с выходом через WP. Через некоторое время напишу что получилось, но если кто-то уже исправил эти проблемы отпишите плиз.
Пока думается мне дать ссылку на выход через форумную ссылку с обратным редиректом на WP, но разбираться еще придется.
После изучения файлов нашел вот такую штуку в файле auth_wpbb.php (который записывается в директория авторизации форума):
Код: Выделить всё
//Checking existence of users
if(!function_exists('censor_text')){ //censor_text is a function from phpbb
//WP 1 BB 0 ?
if(!$phpBB_user && $in_wp){ //If he doesn't exists, create the user in phpbb
$email = $wp_user->user_email ? $wp_user->user_email : '';
// since group IDs may change, use a query to make sure it is the right default group.
$sql = 'SELECT group_id FROM ' . GROUPS_TABLE . " WHERE group_name = '" . $db->sql_escape(REGISTERED) . "' AND group_type = " . GROUP_SPECIAL;
$result = $db->sql_query($sql);
$row = $db->sql_fetchrow($result);
$group_id = $row['group_id'];
$user_row = array(
'username' => $username,
'user_password' => phpbb_hash($password),
'group_id' => $group_id,
'user_email' => $email,
'user_type' => 0
);
$id = wpbb_phpBB3::addUser($user_row);
$phpBB_user = wpbb_phpBB3::getUserById($id);
}
} else {
//WP 0 BB 1 ?
if($phpBB_user && !$in_wp){ //if he doesn't exist creates the user in wordpress
$username = $phpBB_user['username'];
$user_row = array(
'username' => $username,
'email' => $phpBB_user['user_email'] ? $phpBB_user['user_email'] : '',
'password' => html_entity_decode($password)
);
$wp_user = wpbb_WordPress::addUser($user_row);
$wp_user = wp_signon(array(
'user_login' => $username,
'user_password' => html_entity_decode($password)
), $secure_cookie);
mysql_select_db($db->db_name); // Select phpBB database
}
}-
dolcom
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 15 лет 9 месяцев
Re: Общая база юзеров в Wordpress и phpBB
У меня та же самая проблема. WP-wizard на 5 шаге стопарится из-за Internal Server Error. Причём в инете всё ништяк работает, а дома в локалке выдаёт такую хренотень( Может дело в настройках серва? Что делать? Может кто-то знает ответ? Ответьте пожалуйста, очень нужно.

