Взял из дистрибутива, теперь в админке заходит в раздел настройки капчи без проблем.
Но капча так и не отображается, кроме сетки искажения.
Теперь ошибка следующего характера
{phpBB Debug} PHP Notice: in file /includes/capcha/plugins/capcha_abstract.php on line 233: mt_rand() Expects parameter 1 to be long, string given
вот line 233
Код: Выделить всё
$this->code = gen_rand_string(mt_rand(CAPTCHA_MIN_CHARS, CAPTCHA_MAX_CHARS));
$this->confirm_id = md5(unique_id($user->ip));
$this->seed = hexdec(substr(unique_id(), 4, 10));
$this->solved = 0;
// compute $seed % 0x7fffffff
$this->seed -= 0x7fffffff * floor($this->seed / 0x7fffffff);
$sql = 'INSERT INTO ' . CONFIRM_TABLE . ' ' . $db->sql_build_array('INSERT', array(
'confirm_id' => (string) $this->confirm_id,
'session_id' => (string) $user->session_id,
'confirm_type' => (int) $this->type,
'code' => (string) $this->code,
'seed' => (int) $this->seed)
Как дальше исправлять?