[FAQ] Проблема с UTF8

Темы по наиболее часто задаваемым вопросам по phpBB 3.0.x. Читать в первую очередь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Закрыто
volset
phpBB 1.0.0
Сообщения: 8
Зарегистрирован: 10.09.2007 17:21
Поблагодарили: 1 раз
Контактная информация:

[FAQ] Проблема с UTF8

Сообщение volset » 10.09.2007 17:28

Иногда вместо текста отображаются ?????
Ключевое слово здесь иногда :D

Вот пациент http://www.astra-club.org.ua
Для того что бы отловить баг надо несколько раз нажимать кнопку обновить до появления бага.
От браузера независит так как знаки "??????" уже приходят с сервера.
Текст который читается з базы отображается всегда нормально.
PHP Version 5.2.1

Если существует проблема, проявляющаяся в "битом тексте" - замене некоторых символов в сообщении на BOM (знак вопроса в ромбе):

Основной метод решения:
Установить значение mbstring.func_overload равным 0.

Возможное решение:
В корневой директории форума создайте файл .htaccess со следующим содержанием:
.htaccess

Код: Выделить всё

CharsetDisable On
CharsetDefault UTF-8 
CharsetSourceEnc UTF-8
Если после этого теряется работоспособность ресурса, попробовать убрать из вышеуказанного кода строку

Код: Выделить всё

CharsetDisable On
Если не помогает, то вместо первого попробовать добавить в .htaccess строку

Код: Выделить всё

AddDefaultCharset UTF-8
Если у хостера Russian Apache попробуйте добавить в .htaccess

Код: Выделить всё

CharsetDisable On
AddHandler default-handler html
CharsetDefault utf-8
И если совсем ничего не помогает:

Код: Выделить всё

OPEN
includes/utf/utf_tools.php

FIND
function utf8_normalize_nfc($strings)
{

AFTER, ADD
return $strings;
уже приходят с сервера.
Текст который читается з базы отображается всегда нормально.
PHP Version 5.2.1

Если существует проблема, проявляющаяся в

Аватара пользователя
crash
Former team member
Сообщения: 6523
Зарегистрирован: 07.07.2004 17:12
Откуда: Бердск
Поблагодарили: 15 раз
Контактная информация:

Сообщение crash » 10.09.2007 18:02

volset писал(а):Для того что бы отловить баг надо несколько раз нажимать кнопку обновить до появления бага.
так может не надо так часто нажимать обновить
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

volset
phpBB 1.0.0
Сообщения: 8
Зарегистрирован: 10.09.2007 17:21
Поблагодарили: 1 раз
Контактная информация:

Сообщение volset » 10.09.2007 21:50

:-) Весело

Но каждый второй пользователь который был на сайте ловил этот баг

Добавлено спустя 1 минуту 40 секунд:

А если много пользователей, то отображать форум только избранным?
:D Где такой мод найти :-)

Добавлено спустя 2 часа 34 минуты 31 секунду:

Ну что есть у кого какие то идея?
Ума не приложу что это может быть.

И еще не всегда отображаются превью картинок и это как то связано со знаками вопроса:
Добавляю пост, отображается страничка со знаками вопроса, редиректится на пост и в посте не отображаются картинки.
Или если в посте несколько картинок, то в случаи если заглючит одна, то все следующие тоже не отображаются.

Аватара пользователя
crash
Former team member
Сообщения: 6523
Зарегистрирован: 07.07.2004 17:12
Откуда: Бердск
Поблагодарили: 15 раз
Контактная информация:

Сообщение crash » 11.09.2007 2:42

вчера обновлял, бага не получил.
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

volset
phpBB 1.0.0
Сообщения: 8
Зарегистрирован: 10.09.2007 17:21
Поблагодарили: 1 раз
Контактная информация:

Сообщение volset » 11.09.2007 12:57

Блин. У меня постоянно получается и пользователи жалуются :(

Добавлено спустя 2 часа 25 минут 44 секунды:

Заглюченая страничка выглядит так:
http://www.astra-club.org.ua/bag.html

Аватара пользователя
Палыч
Former team member
Сообщения: 9688
Зарегистрирован: 24.05.2006 23:20
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 453 раза
Контактная информация:

Сообщение Палыч » 11.09.2007 13:15

volset
Наблюдаю подобный баг (переодический частичный сбой кодировки при отображении или в тексте, или в титлах, или даже в одном посте - если глюк возникает при постинге) на форуме SMF.
При чём, на том же сервере стоит форум phpbb3 и phpbb2, там глюка не было.
ИМХО, дело в хостере.
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.

volset
phpBB 1.0.0
Сообщения: 8
Зарегистрирован: 10.09.2007 17:21
Поблагодарили: 1 раз
Контактная информация:

Сообщение volset » 12.09.2007 1:38

даже гуглу страничка выдалась с ????????

http://www.google.com.ua/search?hl=ru&q ... g.ua&meta=

http://209.85.135.104/search?q=cache:8q ... cd=1&gl=ua

Добавлено спустя 1 минуту 1 секунду:

ХЕЛП :o !!!

Добавлено спустя 10 часов 9 минут 27 секунд:

Вопрос снимается, просто перешел на пхп 4.

puhlov
phpBB 1.0.0
Сообщения: 2
Зарегистрирован: 12.09.2007 1:52

Сообщение puhlov » 12.09.2007 1:59

АУ! Народ!

Два дня уже бьемся с этой проблемой. Все поставили и везде ?????????????????? вместо текстов.

Корифеи помогите плиз! Где лекарство? В чем болезнь?

Ну здесь же есть профи, я знаю!

puhlov
phpBB 1.0.0
Сообщения: 2
Зарегистрирован: 12.09.2007 1:52

Сообщение puhlov » 14.09.2007 0:40

Н-да господа, вы оказались действительно правы!

ЧИТАЙТЕ FAQ чаще и не задавайте глупых вопросов!

Аватара пользователя
Nemo1987
phpBB 2.0.7
Сообщения: 560
Зарегистрирован: 14.02.2006 10:20

[FAQ] Проблема с UTF8

Сообщение Nemo1987 » 18.09.2007 21:44

Млин... ну как сделать, что он, форум, писал по-русски а не на этом непонятном наречии :(
Что занчит поставить русские шрифты?
Как?

Xpert
phpBB Guru
phpBB Guru
Сообщения: 5486
Зарегистрирован: 13.03.2004 21:27
Поблагодарили: 2 раза
Контактная информация:

Сообщение Xpert » 18.09.2007 21:55

Шаблон запроса это раз. Пишем по русски и без слов-паразитов это два. Отучаемся от привычки писать кучу лишних скобок и знаков вопроса.
Эксперт - это человек, который избегает мелких ошибок на пути к грандиозному провалу.
Любая более-менее сложная задача имеет несколько простых, изящных, лёгких для понимания неправильных решений

Аватара пользователя
Nemo1987
phpBB 2.0.7
Сообщения: 560
Зарегистрирован: 14.02.2006 10:20

Сообщение Nemo1987 » 18.09.2007 22:04

Xpert, прости, пожалуйста.. просто дастал уже этот УТФ... невозможно работать :((((

Добавлено спустя 4 минуты 26 секунд:

По поводу шаблона...
Стандартный форум 3 версии... 5 релиз кандидат

Добавлено спустя 17 секунд:

без модов и прочего...

Аватара пользователя
Rayden
Former team member
Сообщения: 3740
Зарегистрирован: 27.06.2005 1:07
Поблагодарили: 44 раза
Контактная информация:

Сообщение Rayden » 18.09.2007 22:53

Ну и дальше что? У всех RC5 и у всех работает.
Ты считаешь, что описал свою проблему?
Какая версия MySQL, обновлял форум или новая установка? Какая кодировка в базе?
phpBB2 FAQ
phpBB3 FAQ

Аватара пользователя
Siava
Поддержка
Поддержка
Сообщения: 4057
Зарегистрирован: 11.01.2005 14:29
Откуда: Питер
Благодарил (а): 100 раз
Поблагодарили: 406 раз
Контактная информация:

Сообщение Siava » 18.09.2007 23:48

Небось в .htaccess какая-нибудь шняга про кодировки..
Еще одно нарушение правил и будете забанены. © Mr. Anderson
https://siava.ru/forum/ (phpbb 2.0.x, 3.1.x 3.2.x)

Аватара пользователя
Nemo1987
phpBB 2.0.7
Сообщения: 560
Зарегистрирован: 14.02.2006 10:20

Сообщение Nemo1987 » 19.09.2007 10:24

Rayden
Nemo1987 писал(а):без модов и прочего...
Новая, конечно :)))

Мускул 4.1.14 В базе УТФ8

Siava, он отсутствует :)

Закрыто

Вернуться в «FAQ (phpBB 3.0.x)»