Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).

phpBB 3.1.x - системные требования

Проблемы с установкой или работой phpBB 3.1.x? Получите помощь здесь!
С 1 июля 2018 года phpBB Group прекращает поддержку phpBB версии 3.1.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.1 до 1 января 2019 года.
Подробнее: Окончание поддержки phpBB 3.1.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB3.1.x | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 14706
Зарегистрирован: 12.05.2006 18:16
Откуда: Красноярск
Благодарил (а): 352 раза
Поблагодарили: 1619 раз

phpBB 3.1.x - системные требования

Сообщение rxu »

Обязательные системные требования для установки phpBB 3.1.x:
  • Вебсервер под управлением любой операционной системы с поддержкой PHP
  • Сервер SQL, список поддерживаемых:
    • MySQL 3.23 и выше (MySQLi поддерживается)
    • MariaDB 5.1 и выше
    • PostgreSQL 8.3+
    • SQLite 2.8.2+
    • SQLite 3.6.15+
    • MS SQL Server 2000 и выше (прямое подключение, либо через ODBC или нативный драйвер)
    • Oracle
  • PHP 5.3.3+ с поддержкой используемой СУБД. Несовместимо с PHP 7.
  • Обязательные модули PHP:
    • json
  • Доступность функции getimagesize().
  • Наличие следующих модулей PHP позволит получить дополнительные возможности (не обязательны):
    • Поддержка сжатия zlib
    • Поддержка удаленного доступа к FTP
    • Поддержка XML
    • Imagemagick
    • Модуль GD
Изображение

Аватара пользователя
владимир1983
phpBB 3.1.9
Сообщения: 5954
Зарегистрирован: 27.04.2010 2:17
Откуда: Сергиев Посад
Благодарил (а): 391 раз
Поблагодарили: 731 раз

Re: phpBB 3.1.x - системные требования

Сообщение владимир1983 »

Q: Как узнать используемую версию php?
R: 1. Посмотреть в администраторском разделе. Админ. раздел > Сведения о php
2. Создать .php файл phpinfo.php с содержимым

Код: Выделить всё

<?php
phpinfo();
?>
и разместить файл в корневой папке форума. Открыть файл в браузере http://domain.ru/forum/phpinfo.php
3. В терминале выполнить команду # php -v
Q: Как узнать наличие модуля php json?
R: См. пункт 1 - 2 выше. Искать в сведениях:
Вложения
2014-11-27_182138.jpg
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)

Перенесено из форума FAQ в форум Поддержка phpBB 3.1.x 01.01.2019 7:18 модератором rxu

Вернуться в «Поддержка phpBB 3.1.x»