Уважаемые пользователи!
Напоминаем, что с 7 ноября 2020 года phpBB Group прекращает поддержку phpBB версии 3.2.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.2 до 31 декабря 2020 года.
С учетом этого, а также того, что версия 3.2.x больше не будет получать обновлений, за исключением связанных с проблемами безопасности
(только при их наличии и только до 7 ноября 2020 года), рекомендуется обновить конференции до версии 3.3.x.

[3.3] Несовместимые расширения

Проблемы с установкой или работой phpBB 3.3.x? Получите помощь здесь!
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Мини [FAQ] по phpBB 3.1.x/3.2.x | FAQ | Как задавать вопросы | Как устанавливать расширения

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

[3.3] Несовместимые расширения

Сообщение rxu »

Каталог несовместимых с phpBB 3.3 на настоящий момент расширений.Тестировалось в связке phpBB 3.3 / PHP 7.4.
Принимаются добавления в список (с описанием того, что не работает).
Изображение
Аватара пользователя
ronim
phpBB 2.0.7a
Сообщения: 612
Стаж: 3 года 8 месяцев
Откуда: Таллин ,Эстония
Благодарил (а): 127 раз
Поблагодарили: 98 раз

Re: [3.3] Несовместимые расширения

Сообщение ronim »

Ajax Chat
Не работают кнопки : ББ коды,Смайлики и Цвет сообщений.
Исправление получено от автора расширения
в файле ext\spaceace\ajaxchat\styles\all\template\js\ajax_chat.js
найти

Код: Выделить всё

	$(window).load(function () {
и заменить на

Код: Выделить всё

	$(window).on('load', function () {
также (кавычки в tables.yml)
Если ты не видишь проблем на форуме , но это не значить что их там нет
Admirals
phpBB 1.4.1
Сообщения: 41
Стаж: 12 лет 6 месяцев
Благодарил (а): 1 раз
Поблагодарили: 8 раз

Re: [3.3] Несовместимые расширения

Сообщение Admirals »

Reputation System (Не уверен
или хостинг или несовместимость выдает ошибку 500 при включении расширения на форуме,доступный только админ раздел если в ручную ввести ссылку на него, при выключении его форум нормально работает).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

Re: [3.3] Несовместимые расширения

Сообщение rxu »

Admirals писал(а): 08.01.2020 9:31 выдает ошибку 500 при включении расширения на форуме
Смотрите лог ошибок вебсервера при этом. Иначе не поймете.
Изображение
Перенесено из форума Анонсы и поддержка расширений для phpBB в форум Поддержка phpBB 3.3.x 12.01.2020 10:47 модератором rxu

Bydlocoder
phpBB 1.2.0
Сообщения: 15
Стаж: 1 год 8 месяцев
Благодарил (а): 1 раз
Поблагодарили: 3 раза

Re: [3.3] Несовместимые расширения

Сообщение Bydlocoder »

В файле ext/pico/reputation/config/routing.yml поменяйте path: на pattern:
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

Re: [3.3] Несовместимые расширения

Сообщение rxu »

Bydlocoder писал(а): 13.01.2020 6:15 поменяйте path: на pattern:
С точностью до наоборот.
Изображение
Аватара пользователя
COB16
phpBB 2.0.15
Сообщения: 1011
Стаж: 6 лет 11 месяцев
Откуда: Беларусь
Благодарил (а): 317 раз
Поблагодарили: 60 раз

Re: [3.3] Несовместимые расширения

Сообщение COB16 »

Fancybox не работает 3.3, картинки открывает просто во вкладке. Правки в yml делались
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

Re: [3.3] Несовместимые расширения

Сообщение rxu »

Думается, что проблема в JS скриптах.
Изображение
Bydlocoder
phpBB 1.2.0
Сообщения: 15
Стаж: 1 год 8 месяцев
Благодарил (а): 1 раз
Поблагодарили: 3 раза

Re: [3.3] Несовместимые расширения

Сообщение Bydlocoder »

rxu писал(а): 13.01.2020 9:38
Bydlocoder писал(а): 13.01.2020 6:15 поменяйте path: на pattern:
С точностью до наоборот.
Угу, задумался, не так написал
Аватара пользователя
COB16
phpBB 2.0.15
Сообщения: 1011
Стаж: 6 лет 11 месяцев
Откуда: Беларусь
Благодарил (а): 317 раз
Поблагодарили: 60 раз

Re: [3.3] Несовместимые расширения

Сообщение COB16 »

rxu, вечером посмотрю в консоли браузера
Аватара пользователя
COB16
phpBB 2.0.15
Сообщения: 1011
Стаж: 6 лет 11 месяцев
Откуда: Беларусь
Благодарил (а): 317 раз
Поблагодарили: 60 раз

Re: [3.3] Несовместимые расширения

Сообщение COB16 »

да так и есть, сыплет ошибки в консоли:

Код: Выделить всё

Uncaught TypeError: Cannot read property 'indexOf' of undefined
    at k.fn.init.k.fn.load (jquery-3.4.1.min.js?assets_version=152:2)
    at HTMLImageElement.<anonymous> (fancy.js?assets_version=152:29)
    at Function.each (jquery-3.4.1.min.js?assets_version=152:2)
    at k.fn.init.each (jquery-3.4.1.min.js?assets_version=152:2)
    at fancy.js?assets_version=152:28
globalnoises
phpBB 1.4.1
Сообщения: 42
Стаж: 2 года
Благодарил (а): 68 раз
Поблагодарили: 2 раза

Re: [3.3] Несовместимые расширения

Сообщение globalnoises »

Внимание!
Не все расширения для phpBB 3.2 совместимы с phpBB 3.3, главным образом из-за неверного синтаксиса в определениях сервисов (отсутствия обрамляющих кавычек - '...').
Перед обновлением необходимо убедиться в совместимости всех расширений.
Рекомендуется предварительно тестировать обновление на копии конференции (локально или на сервере).
Лучше лишний раз переспрошу. Так как не совсем понял. :hat

А наоборот совместимы?
Переделанные под версию 3.3.х расширения с обрамляющими ковычками будут работать на 3.2.х?

Чтобы в случае чего заранее заготовить все возможные расширения под 3.3, но пока что использовать эти переделанные расширения на форуме 3.2.9. :rtfm:

Спасибо :hat
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

Re: [3.3] Несовместимые расширения

Сообщение rxu »

С кавычками в 3.2.9 будет работать.
Изображение
TrekRed
phpBB 2.0.4
Сообщения: 413
Стаж: 3 года 1 месяц
Благодарил (а): 57 раз
Поблагодарили: 15 раз

Re: [3.3] Несовместимые расширения

Сообщение TrekRed »

А 3.2.8?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 15517
Стаж: 15 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 418 раз
Поблагодарили: 1860 раз

Re: [3.3] Несовместимые расширения

Сообщение rxu »

Тоже.
Изображение

Вернуться в «Поддержка phpBB 3.3.x»