Сообщаем об ошибках phpBB 3.0.x разработчикам

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Борис Бердичевский »

Я полагаю, что рассматриваемую проблему вполне можно отнести к ошибкам разработчиков. А именно: замену изменения прав доступа к файлу с

Код: Выделить всё

@chmod($this->cache_dir . 'data_global.' . $phpEx, 0666); 
на

Код: Выделить всё

phpbb_chmod($this->cache_dir . 'data_global.' . $phpEx, CHMOD_WRITE); 
( includes/asm/asm_file.php ). И это создаёт проблемы у некоторых пользователей, пользующихся провайдеровскими хостами.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Борис Бердичевский
Как я уже писАл ранее, и неоднократно, о проблеме известно разработчикам. Спасибо.
Изображение
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Борис Бердичевский »

rxu,
надеюсь, что они учтут это в следующей версии. Моё сообщение тоже полезно, чтобы столкнувшийся с этим мог поправить это дело. Workaround, как мы говорим.
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
Oleg NT
Former team member
Сообщения: 450
Стаж: 20 лет 8 месяцев
Откуда: Нижний Тагил
Поблагодарили: 11 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Oleg NT »

/styles/prosilver/template/posting_editor.html

Код: Выделить всё

id="group_list "multiple="true"
пробел и кавычку между «list» и «multiple» поменять местами
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Это косметический "баг", не влияющий на работоспособность.
Изображение
Semik
phpBB 1.2.0
Сообщения: 16
Стаж: 18 лет 9 месяцев
Откуда: Voronezh
Благодарил (а): 1 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Semik »

PhpBB3 3.0.4 vs PostgreSQL - баг.

Свежеустановленный phpbb 3.0.4
Из админки пытаюсь сделать восстановление базы данных из резевной копии, сделанной на рабочем форуме с базой MySQL. Вылетает ошибка:
Общая ошибка
SQL ERROR [ postgres ]

[]

SQL

-- Table: phpbb_acl_users

BACKTRACE

FILE: includes/db/postgres.php
LINE: 177
CALL: dbal->sql_error()

FILE: includes/acp/acp_database.php
LINE: 366
CALL: dbal_postgres->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_database->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
Делаю свежую резервную копию с "чистой" базы postgres (свежеустановленный phpbb3), пытаюсь сделать восстановление из неё - получаю ту же самую ошибку.

gentoo-linux
apache-2.2.10
php-5.2.6
postgresql-8.0.15
Semik
phpBB 1.2.0
Сообщения: 16
Стаж: 18 лет 9 месяцев
Откуда: Voronezh
Благодарил (а): 1 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Semik »

Поэкспериментировал ещё немного. Оказалось всё не совсем так.
Мускульную базу не восстанавливает в постгрес, но пишет другую немного ошибку (хотя на том же месте):
SQL ERROR [ postgres ]

ERROR: syntax error at or near "#" at character 1 []

SQL

# # phpBB Backup Script # Dump of tables for phpbb_ # DATE : 04-03-2009 14:40:54 GMT # # Table: phpbb_acl_groups DROP TABLE IF EXISTS phpbb_acl_groups

BACKTRACE

FILE: includes/db/postgres.php
LINE: 177
CALL: dbal->sql_error()

FILE: includes/acp/acp_database.php
LINE: 366
CALL: dbal_postgres->sql_query()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_database->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
А вот бэкап сделанный с чистого постгреса не восстанавливает, если он лежит в bzip2. Если в plain text или gzip - восстановление проходит на ура.
Ошибка при восстановлении из архива как раз та, что в прошлом посте описана.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

1) С чего вы решили, что между MySQL и Postgres нет никакой разницы и можно делать кросс-восстановление бэкапов?
2) насчет восстановления из bzip2 ничего пока сказать не могу, возможно, проблемы на стороне сервера (например, отсутствует поддержка в PHP).
Изображение
Semik
phpBB 1.2.0
Сообщения: 16
Стаж: 18 лет 9 месяцев
Откуда: Voronezh
Благодарил (а): 1 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Semik »

rxu писал(а):1) С чего вы решили, что между MySQL и Postgres нет никакой разницы и можно делать кросс-восстановление бэкапов?
Ну я надеялся :)
Кстати проблема - сконвертить базу мускуля в базу постгреса. Найденные в инете решения (типа mysqldump --compatibitity=postresql и mysql2pgsql.perl) не работают. Был бы рад подсказке, жаль здесь это не в тему.
rxu писал(а):2) насчет восстановления из bzip2 ничего пока сказать не могу, возможно, проблемы на стороне сервера (например, отсутствует поддержка в PHP).
База в mysql восстанавливается из bzip2 на ура, неоднократно это делал. На том же свежеустановленном форуме в том числе (как раз для экспериментов его и ставил). Сам был сильно удивлён, перепроверял много раз - в простгресе из .sql и .sql.gz без проблем, а из .sql.bzip2 - болт.
GadskyPapa
phpBB 1.0.0
Сообщения: 2
Стаж: 17 лет 6 месяцев

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение GadskyPapa »

При поиске "Только по названию темы" вываливается ошибка. phpbb 3.0.4. Используется PostgreSQL 8.2.6. Судя по всему не верно формируется запрос к БД, из запроса выпадает табличка phpbb_topics t, но я плохо знаю пхп чтобы самому пофиксить этот баг.

Пример: http://anvil.perm.ru/search.php?keyword ... 1%81%D0%BA

Код: Выделить всё

Текст ошибки:
============================================================================================================================
Общая ошибка
SQL ERROR [ postgres ]

ERROR: отсутствует запись о FROM-выражении для таблицы "t" LINE 1: ...s p ON (m0.post_id = p.post_id) WHERE p.post_id = t.topic_fi... ^ []

SQL

SELECT COUNT(DISTINCT p.post_id) AS total_results FROM phpbb_search_wordmatch m0 LEFT JOIN phpbb_posts p ON (m0.post_id = p.post_id) WHERE p.post_id = t.topic_first_post_id AND m0.word_id = 18460 AND m0.title_match = 1

BACKTRACE

FILE: includes/db/postgres.php
LINE: 177
CALL: dbal->sql_error()

FILE: includes/search/fulltext_native.php
LINE: 663
CALL: dbal_postgres->sql_query()

FILE: search.php
LINE: 418
CALL: fulltext_native->keyword_search()
Последний раз редактировалось GadskyPapa 12.03.2009 11:16, всего редактировалось 3 раза.
Аватара пользователя
DK7
Former team member
Сообщения: 1008
Стаж: 20 лет 2 месяца
Откуда: Кишинёв
Благодарил (а): 3 раза
Поблагодарили: 25 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение DK7 »

для кода есть кнопка "Сode". Используйте на будущее.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

GadskyPapa
Моды какие-либо устанавливались?
Английский вариант ошибки привести имеете возможность?
Изображение
GadskyPapa
phpBB 1.0.0
Сообщения: 2
Стаж: 17 лет 6 месяцев

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение GadskyPapa »

модов никаких, проверил, файлы includes/db/postgres.php, includes/search/fulltext_native.php, search.php полностью соответствуют тем что в дистрибутиве 3.0.4.

На английском ошибка звучит так: missing FROM-clause entry for table "t".

Чтобы получить эту ошибку достаточно выполнить приведенный запрос, видно что есть t.topic_first_post_id и никакого упоминания в запросе про таблицу phpbb_topics t, в которой как раз и есть это поле:

SELECT COUNT(DISTINCT p.post_id) AS total_results FROM phpbb_search_wordmatch m0 LEFT JOIN phpbb_posts p ON (m0.post_id = p.post_id) WHERE p.post_id = t.topic_first_post_id AND m0.word_id = 18460 AND m0.title_match = 1
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2413 раз

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение rxu »

Что-то по ссылке проблемы с кодировкой - текст ошибки побит.

Добавлено спустя 20 минут 9 секунд:
http://www.phpbb.com/bugs/phpbb3/ticket ... t_id=42825

Добавлено спустя 4 минуты 15 секунд:
Оказалось, ошибка была известна ранее http://www.phpbb.com/bugs/phpbb3/40605
Изображение
Алексий
phpBB 1.2.0
Сообщения: 13
Стаж: 17 лет 6 месяцев

Re: Сообщаем об ошибках phpBB 3.0.x разработчикам

Сообщение Алексий »

В файле styleswitcher.js в IE6 (phpbb3.0.4) выдает все время ошибку:
Строка: 115
Ошибка: "style_cookie_settings" - определение отсутствует


В других браузерах все нормально (а может просто не выдает ничего)

спустя несколько дней:
ВСЕ, РАЗОБРАЛСЯ.
В "Стилях" нажал "Удалить" стиль, а затем "Установить" и все заработало нормально.
Последний раз редактировалось Алексий 25.03.2009 15:08, всего редактировалось 1 раз.

Вернуться в «Поддержка phpBB 3.0.х»