Обсуждаем phpBB 3.0 RC6/RC7
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Alek$
- Former team member
- Сообщения: 2616
- Стаж: 21 год 1 месяц
- Откуда: Новосибирск
- Поблагодарили: 37 раз
Ух ты блин!
Резво они версии выпускают.
Пошел качать...
Резво они версии выпускают.
Пошел качать...
Самая страшная ошибка, это ошибка без видимых причин и конкретных последствий.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
phpBB3 [db_update.php generator]
Первая помощь по всем phpBB-вопросам: phpBB2 и phpBB3 FAQ; Правила общения;
Все консультации в icq или личке - на платной основе.
-
Snegovic
- phpBB 1.2.1
- Сообщения: 21
- Стаж: 20 лет 7 месяцев
-
NCom
- phpBB 2.0.11
- Сообщения: 810
- Стаж: 20 лет 8 месяцев
- Откуда: Ставрополь
- Забанен: Бессрочно
-
***Blaze***
- phpBB 2.0.7
- Сообщения: 583
- Стаж: 19 лет 8 месяцев
- Откуда: Данков
- Благодарил (а): 57 раз
- Поблагодарили: 25 раз
Я про ошибку с администраторский разделом не знал и поэтому возникли проблемы, я в тупике. Вообщем стоял я на RC5, поставил RC7. Удалил таблицы форума с помощью phpMyAdmin. Заново установил форум. Затем восстановил резервную копию RC5, обновил БД (RC5>RC7). Теперь самое важное!!! У меня присвоен стиль по умолчанию не prosilver, а holyweb2pointoly. Тоесть этот стиль используется всеми пользователями конференции. И я не могу попасть в администраторский раздел, так как я немогу поменять в личном разделе стиль на prosilver и в админку я попасть немогу:
RC5 to RC6 fix не помогает, так как стиль используется holyweb2pointoly. Помогите это вылечить.
Код: Выделить всё
Общая ошибка
Необходимо ввести пароль для получения доступа в администраторский раздел.Мой сайт http://ublaze.ru/
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Где вы нашли такую инструкцию по обновлению?***Blaze*** писал(а):Удалил таблицы форума с помощью phpMyAdmin. Заново установил форум. Затем восстановил резервную копию RC5, обновил БД (RC5>RC7).
Через пхпмайадмин выставьте себе просильвер как стиль по умолчанию (user_style в таблице пользователей).***Blaze*** писал(а):RC5 to RC6 fix не помогает, так как стиль используется holyweb2pointoly. Помогите это вылечить.
-
Chance
- phpBB 1.4.2
- Сообщения: 70
- Стаж: 20 лет 1 месяц
- Забанен: Бессрочно
-
***Blaze***
- phpBB 2.0.7
- Сообщения: 583
- Стаж: 19 лет 8 месяцев
- Откуда: Данков
- Благодарил (а): 57 раз
- Поблагодарили: 25 раз
Это я сам экскременты ставил. Так давно уже обновляю.Где вы нашли такую инструкцию по обновлению?
Меняю у себя user_style
Код: Выделить всё
Поле Тип Функция Ноль ЗначениеМой сайт http://ublaze.ru/
-
Lokust
- phpBB 1.4.4
- Сообщения: 119
- Стаж: 20 лет 4 месяца
-
playa
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 18 лет 11 месяцев
ошибочный редирект!
Здравствуйте.
Хочу затронуть одну тему связанную с ошибкой при редиректе в админскую панель(АП)..
ошибка проявляет себя в RC5 RC6 и RC7 (и скорее всего в пред. версиях)
где то месяц назад поставил на свой пк HTTP сервер(PHP5.2.4) и форум phpBB3 RC5.
Установка прошла нормально, но через нек. время я заметил что после повторного ввода пароля для входа в АП
форум уходит по неправильной ссылке -
"http://xx.xxx.xx.xx/adm/index.php?sid=8 ... bdff441dc8"
т.е. перед "adm/" не написана папка в которой установлен форум - "phpBB3/"
...
решение подсказали на англ форуме поддержки phpBB3
кому интересно можете почитать
- мой запрос...
http://www.phpbb.com/community/viewtopi ... 0#p3183412
-
http://www.phpbb.com/community/viewtopi ... a#p3162988
решение:
замена в файле "\phpBB3\includes\functions.php"
строки - "if (!function_exists('realpath'))"
, на - "if (!function_exists('realpath') || 1 == 1)"
после этого фикса, все нормально редиректится...
Сегодня на свой тестовый форум я сначала пробовал поставить апдейт
RC5 to RC7, ничего не получилось!!
смог поставить только вариант - "Changed Files Only"
phpBB-3.0.RC7-files.zip
Но ошибка связанная с редиректом осталась и в этой версии!!!!
(пришлось опять файлик исправлять)
Кто знает почему такая серьезная бага остается незамеченной разработчиками phpBB3 ??????????
Хочу затронуть одну тему связанную с ошибкой при редиректе в админскую панель(АП)..
ошибка проявляет себя в RC5 RC6 и RC7 (и скорее всего в пред. версиях)
где то месяц назад поставил на свой пк HTTP сервер(PHP5.2.4) и форум phpBB3 RC5.
Установка прошла нормально, но через нек. время я заметил что после повторного ввода пароля для входа в АП
форум уходит по неправильной ссылке -
"http://xx.xxx.xx.xx/adm/index.php?sid=8 ... bdff441dc8"
т.е. перед "adm/" не написана папка в которой установлен форум - "phpBB3/"
...
решение подсказали на англ форуме поддержки phpBB3
кому интересно можете почитать
- мой запрос...
http://www.phpbb.com/community/viewtopi ... 0#p3183412
-
http://www.phpbb.com/community/viewtopi ... a#p3162988
решение:
замена в файле "\phpBB3\includes\functions.php"
строки - "if (!function_exists('realpath'))"
, на - "if (!function_exists('realpath') || 1 == 1)"
после этого фикса, все нормально редиректится...
Сегодня на свой тестовый форум я сначала пробовал поставить апдейт
RC5 to RC7, ничего не получилось!!
смог поставить только вариант - "Changed Files Only"
phpBB-3.0.RC7-files.zip
Но ошибка связанная с редиректом осталась и в этой версии!!!!
(пришлось опять файлик исправлять)
Кто знает почему такая серьезная бага остается незамеченной разработчиками phpBB3 ??????????
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
playa
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 18 лет 11 месяцев
Возможно что это мой сервак такой неправильный, незнаю, а что вобще эта ф. realpath() делает?А почему вы решили, что это бага форума?
Еси вы сами ставили сервер, то почему у вас неправильно определяется realpath?
Такие же проблеммы возникли при установке форума на платный хостинг сервер Majordomo.
(с пред. версией phpBB 2.0.22 таких граблей нет)
-
***Blaze***
- phpBB 2.0.7
- Сообщения: 583
- Стаж: 19 лет 8 месяцев
- Откуда: Данков
- Благодарил (а): 57 раз
- Поблагодарили: 25 раз
Все сделал так как вы написали, не помогло. В таблице стилей номер просливера 1, я его себе присвоил в phpbb_users в поеле user_style. Может можно что-то в стиле изменить?rxu писал(а):***Blaze***
Просто заходите в редактирование строки в phpbb_users с вашим user_id и меняете там значение поля user_style на номер просильвера, который можете посмотреть в таблице стилей, но обычно это 1.
Мой сайт http://ublaze.ru/
-
o9uH
- phpBB 1.2.1
- Сообщения: 20
- Стаж: 20 лет 9 месяцев
- Откуда: Moscow

