Проблемы с аватарами

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Пока видимо варианты иссякли... Давайте еще раз. Итак.

1. права нужные на папки 777
2. в файл .htaccess добавлен нужный код
3. в php настройках хостера files_uploads стоит on
4. размер аватары в настройках указан достаточен для закачки
5. На хостинге достаточно места

Какие еще быть варианты? Может даже самые невероятные или даже слишком вероятные?

Еще раз факт о том, что возможность закачки юзерами с компа пропала когда стоял еще phpbb2 Plus (там писал ошибку о расширениях) и при конвертации проблема осталась (теперь пишет о невозможности).
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Сообщение rxu »

Другие браузеры, кроме Сафари, пробовали?
Изображение
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Да, и в IE, и в Opere тоже самое.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Сообщение rxu »

Перекопал весь лангпак, но так и не нашел текста наподобие "Невозможно закачать аватару в...". Странненько.
Никакой защиты от хотлинков или правил редиректа в .htaccess не установлено?
Изображение
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Там только вот что:
<IfModule mod_charset.c>
CharsetRecodeMultipartForms off
</IfModule>

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

По поводу лангпака. Я пару дней назад установил, может обновили?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Сообщение rxu »

dzadzen писал(а):может обновили?
Нет.
Изображение
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Тогда откуда?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Сообщение Rayden »

dzadzen писал(а):Пока видимо варианты иссякли... Давайте еще раз. Итак.

1. права нужные на папки 777
2. в файл .htaccess добавлен нужный код
3. в php настройках хостера files_uploads стоит on
4. размер аватары в настройках указан достаточен для закачки
5. На хостинге достаточно места

Какие еще быть варианты? Может даже самые невероятные или даже слишком вероятные?

Еще раз факт о том, что возможность закачки юзерами с компа пропала когда стоял еще phpbb2 Plus (там писал ошибку о расширениях) и при конвертации проблема осталась (теперь пишет о невозможности).
Может темповая дериктория не доступна?
phpBB2 FAQ
phpBB3 FAQ
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Это вы говорите о папке cache и прав к ней?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Сообщение Rayden »

нет. О темповой директории для php, определяется переменной upload_tmp_dir

И вот тебе скрипт, положи его в директорию аватар (или любую нужную) и попробуй с помощью него загрузить файл.

Код: Выделить всё

<?
echo "
<html><head><title>Загрузка файлов на сервер</title></head>
<body>
";
echo "Размер загружаемого файла не должен превышать: ". 
ini_get("upload_max_filesize") . "<br>";
if (!$HTTP_POST_FILES) {
echo "
Введите имя и путь для загружаемого файла:
";
} else {
if(move_uploaded_file($HTTP_POST_FILES["filename"]["tmp_name"],
"files/" . $HTTP_POST_FILES["filename"]["name"])) {
chmod("files/" . $HTTP_POST_FILES["filename"]["name"], 0660);
echo "Файл '" . $HTTP_POST_FILES["filename"]["name"] . "' успешно 
загружен.<br>";
} else {
echo "Ошибка загрузки файла '" . $HTTP_POST_FILES["filename"]["name"] . 
"'.<br>";
}
}

echo "
<form action='index.php' method='post' enctype='multipart/form-data'>
<input type='file' name='filename'><br>
<input type='submit' value='Загрузить'><br>
</form>
";

$dh = opendir("files");
while (($file = readdir($dh)) !== false) {
if (!ereg("^\.+$", $file)) {
echo "
<div>
<a href='files/$file'>$file</a>
</div>
";
}
}
echo "
</body></html>
";
?>
phpBB2 FAQ
phpBB3 FAQ
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Сообщение Палыч »

rxu
ru/ucp.php строка 94

Код: Выделить всё

'AVATAR_GENERAL_UPLOAD_ERROR'	=> 'Невозможно закачать аватару в %s.',
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Rayden

upload_tmp_dir на хостинге прописан путь /var/tmp

при загрузке этого скрипта в корень форума не выдает никаких ошибок выскакивает на заглавную страницу. Файлов не добавляется. при загрузке скрипта в любую другую папку, ошибка 404.
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Сообщение Rayden »

Ну логично...

form action='index.php' - исправь на название свое название, как ты этот скрипт обозвал
phpBB2 FAQ
phpBB3 FAQ
dzadzen
phpBB 1.2.1
Сообщения: 27
Стаж: 19 лет 7 месяцев

Сообщение dzadzen »

Ну вот что выдал:

Warning: move_uploaded_file() [function.move-uploaded-file]: open_basedir restriction in effect. File(/var/tmp/phpqerQi5) is not within the allowed path(s): (/home2/forumfrenchmusi) in /home2/forumfrenchmusi/forumfrenchmusi/www/a.php on line 14

Warning: move_uploaded_file(/var/tmp/phpqerQi5) [function.move-uploaded-file]: failed to open stream: Operation not permitted in /home2/forumfrenchmusi/forumfrenchmusi/www/a.php on line 14

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/var/tmp/phpqerQi5' to 'files/animal000.gif' in /home2/forumfrenchmusi/forumfrenchmusi/www/a.php on line 14
Ошибка загрузки файла 'animal000.gif'.
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Сообщение crash »

dzadzen
нельзя вам использовать
dzadzen писал(а):/var/tmp/
для временного хранения файлов. перепишите скрипт, чтобы он использовал папку внутри ывшей домешней директории
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса

Вернуться в «Поддержка phpBB 3.0.х»