Ошибка почты
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
devilstar
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 18 лет 5 месяцев
У меня появилась следующая проблема - при регистрации пользователей не отправляется мыло с активацией.
В логах следующая ошибка:
Кто-нибудь сталкивался с такой проблемой? Ту ссылку, которую мне предлагает прочитать сам mail.ru я прочитал, но так и не понял где нужно изменить настройки в форуме, что бы все заработало.
Добавлено спустя 19 минут 14 секунд:
Все, разобрался... Поля 'Контактный email-адрес:' и 'Обратный email-адрес:' должны быть одинаковыми... Хотя это странно, ведь функции у них разные. Ну да ладно, хоть заработало.
В логах следующая ошибка:
Код: Выделить всё
Ошибка почты
» EMAIL/SMTP
/ucp.php
Ошибка при отправке email в строке 945. Ответ сервера: 550 Message was not accepted -- it contains invalid headers. More specially, 'From:' header must match user you are sending mail from. See http://www.mail.ru/pages/help/261.html for details.
.
Backtrace
Connecting to smtp.mail.ru:25
LINE: 851 <- 220 mail.ru ESMTP Sun, 06 Apr 2008 07:30:50 +0400
# EHLO ftp-5.ayola.net
LINE: 1104 <- 250-mx48.mail.ru Hello ftp-5.ayola.net [88.214.232.108]
LINE: 1104 <- 250-SIZE 31457280
LINE: 1104 <- 250-8BITMIME
LINE: 1104 <- 250-AUTH PLAIN LOGIN
LINE: 1104 <- 250 PIPELINING
# AUTH LOGIN
LINE: 1233 <- 334 VXNlcm5hbWU6
# Omitting sensitive information
LINE: 1239 <- 334 UGFzc3dvcmQ6
# Omitting sensitive information
LINE: 1245 <- 235 Authentication succeeded
# MAIL FROM:<forums.sk6@mail.ru>
LINE: 867 <- 250 OK
# RCPT TO:<devi.lstar@mail.ru>
LINE: 887 <- 250 Accepted
# DATA
LINE: 918 <- 354 Enter message, ending with "." on a line by itself
# Subject: =?UTF-8?B?0JTQvtCx0YDQviDQv9C+0LbQsNC70L7QstCw0YLRjCDQvdCwINC60L7QvdGE0LU=?= =?UTF-8?B?0YDQtdC90YbQuNGOIMKr0LLQsNGIX9C00L7QvNC10L0ucnXCuw==?=
# To: =?UTF-8?B?dGVzdA==?= <devi.lstar@mail.ru>
# From: <devilstar@211.ru>
Reply-To: <devilstar@211.ru>
Return-Path: <forums.sk6@mail.ru>
Sender: <forums.sk6@mail.ru>
MIME-Version: 1.0
Message-ID: <80c77ebb26014452246b5a18f80ca4ba@forums.sk6.ru>
Date: Sun, 06 Apr 2008 07:31:09 +0400
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: PhpBB3
X-MimeOLE: phpBB3
X-phpBB-Origin: phpbb://forums.sk6.ru
X-AntiAbuse: Board servername - forums.sk6.ru
X-AntiAbuse: User_id - 1
X-AntiAbuse: Username - Anonymous
X-AntiAbuse: User IP - 192.168.111.1
# Добро пожаловать на конференцию «ваш_домен.ru»
Пожалуйста, сохраните это сообщение. Параметры вашей учётной записи таковы:
----------------------------
Имя пользователя: test
----------------------------
Не забывайте свой пароль: он хранится в нашей базе в зашифрованном виде, и
мы не сможем вам его выслать. Если вы всё же забудете пароль, то сможете
запросить новый, который придётся активировать таким же образом, как и вашу
учётную запись.
В данный момент ваша учётная запись отключена. Вы не сможете ее
использовать, пока не перейдёте по следующей ссылке:
http://forums.sk6.ru/ucp.php?mode=activate&u=54&k=2CUZNECDM4
Спасибо за регистрацию.
--
Cпасибо, Администрация
# .
LINE: 945 <- 550 Message was not accepted -- it contains invalid headers. More specially, 'From:' header must match user you are sending mail from. See http://www.mail.ru/pages/help/261.html for details.Добавлено спустя 19 минут 14 секунд:
Все, разобрался... Поля 'Контактный email-адрес:' и 'Обратный email-адрес:' должны быть одинаковыми... Хотя это странно, ведь функции у них разные. Ну да ладно, хоть заработало.
-
crash
- Former team member
- Сообщения: 6517
- Стаж: 22 года 2 месяца
- Откуда: Бердск
- Поблагодарили: 15 раз
это вы mail.ru объянитеdevilstar писал(а):Поля 'Контактный email-адрес:' и 'Обратный email-адрес:' должны быть одинаковыми... Хотя это странно, ведь функции у них разные. Ну да ладно, хоть заработало.
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
-
***Blaze***
- phpBB 2.0.7
- Сообщения: 583
- Стаж: 19 лет 8 месяцев
- Откуда: Данков
- Благодарил (а): 57 раз
- Поблагодарили: 25 раз
У меня так же возникает ошибка почты при массовой рассылки и рассылка не доходит ни кому, а раньше все доходило и ошибок не было. Вот такая ошибка в логах:
Код: Выделить всё
Ошибка почты
» EMAIL/PHP/mail()
/forum/adm/index.phpМой сайт http://ublaze.ru/
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
Пытаюсь ставить и 0 и 10 все равно ошибка продолжается.
А вот приходят несколько писем на почту:
Как я понимаю проблема с полем FROM, но вроде бы оно же прописано, ведь если рассылку сделать только администратору или модеаторам (которых 1 и 6 соответственно), то письма приходят.
А вот приходят несколько писем на почту:
Код: Выделить всё
The original message was received at Thu, 24 Apr 2008 04:24:44 +0400 (MSD)
from nobody@localhost
----- The following addresses had permanent fatal errors -----
undisclosed-recipients:;
----- Transcript of session follows -----
553 5.1.3 undisclosed-recipients:;... List:; syntax illegal for recipient addresses-
VVVas
- Former team member
- Сообщения: 4463
- Стаж: 21 год 10 месяцев
- Поблагодарили: 13 раз
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
-
VVVas
- Former team member
- Сообщения: 4463
- Стаж: 21 год 10 месяцев
- Поблагодарили: 13 раз
Stipendiat писал(а):Что где-то не прописано поле From.
Тут только про получателя говориться, а не про отправителя... Или хостер вам врет, и или вы про from сами придумали, или я вас не понимаю. Скрин с настройками почты давайте.Stipendiat писал(а):syntax illegal for recipient addresses
Вот это тоже смущает. Дайте технический заголовок письма которое приходит с вашего форума.Stipendiat писал(а):nobody@localhost
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
Вот меня именно это и смущает, что не прописано от кого...
Вот заголовки письма, которое приходт на ящик, если сделать массовую рассылку по всем пользователям.
(Другие сообщения с форума приходят отлично, проблема только при рассылке многим поьзователям.)
Добавлено спустя 4 минуты 30 секунд:
Если сделать рассылку по Администраторам (а он 1), то письмо приходит.
Вот заголовки письма, которое приходт на ящик, если сделать массовую рассылку по всем пользователям.
(Другие сообщения с форума приходят отлично, проблема только при рассылке многим поьзователям.)
Код: Выделить всё
Return-path: <>
Received: from [217.112.42.2] (port=3538 helo=mx5.valuehost.ru)
by mx64.mail.ru with esmtp
id 1Jp1P8-000KmP-00
for autoir@mail.ru; Thu, 24 Apr 2008 17:22:26 +0400
Received-SPF: none (mx64.mail.ru: 217.112.42.2 is neither permitted nor denied by domain of mx5.valuehost.ru)
client-ip=217.112.42.2; envelope-from=postmaster@mx5.valuehost.ru; helo=mx5.valuehost.ru;
Received: from v65.valuehost.ru (v65.valuehost.ru [217.112.35.28])
by mx5.valuehost.ru (Postfix) with ESMTP id E7F81751362
for <autoir@mail.ru>; Thu, 24 Apr 2008 17:22:30 +0400 (MSD)
(envelope-from "")
Received: from localhost (localhost)
by v65.valuehost.ru (8.13.6/8.11.6) id m3ODLNSr010168;
Thu, 24 Apr 2008 17:22:13 +0400 (MSD)
(envelope-from MAILER-DAEMON)
Date: Thu, 24 Apr 2008 17:22:13 +0400 (MSD)
From: Mail Delivery Subsystem <MAILER-DAEMON@v65.valuehost.ru>
Message-Id: <200804241322.m3ODLNSr010168@v65.valuehost.ru>
To: autoir@mail.ru
MIME-Version: 1.0
Content-Type: multipart/report; report-type=delivery-status;
boundary="m3ODLNSr010168.1209043333/v65.valuehost.ru"
Content-Transfer-Encoding: 8bit
Subject: Returned mail: see transcript for details
Auto-Submitted: auto-generated (failure)
X-Spam: Not detected
X-Mras: OKЕсли сделать рассылку по Администраторам (а он 1), то письмо приходит.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
VVVas
- Former team member
- Сообщения: 4463
- Стаж: 21 год 10 месяцев
- Поблагодарили: 13 раз
Stipendiat
Это с такой шапкой приходит одно письмо которое вы шлете администратору?
Добавлено спустя 24 минуты 14 секунд:
Это с такой шапкой приходит одно письмо которое вы шлете администратору?
Добавлено спустя 24 минуты 14 секунд:
Это должно заполняться сервером, хотя через php можно указать тут нужный тебе адрес. Как работает в phpBB не знаю, но когда я настраивал один скрипт рассылки, то правил это.Stipendiat писал(а):Return-path: <>
-
Stipendiat
- phpBB 1.4.4
- Сообщения: 163
- Стаж: 19 лет 8 месяцев
Нет, письма (примерно около 7) с такими заголовками приходят как ответ сервера на адрес, который указан в настройках сервера, если делать массовую рассылку для всех пользователей (адрес в настройках сервера и адрес в phpBB поля From одинаковые).
А как это править?VVVas писал(а):Это должно заполняться сервером, хотя через php можно указать тут нужный тебе адрес. Как работает в phpBB не знаю, но когда я настраивал один скрипт рассылки, то правил это.


