Обсуждаем phpBB 3.0.1

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
crash
Former team member
Сообщения: 6517
Стаж: 22 года 2 месяца
Откуда: Бердск
Поблагодарили: 15 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение crash »

Борис Бердичевский писал(а):Отсюда вытекает, что нужна утилита-скрипт, позволяющая делать бэкап-восстановление непосредственно на сервере.
я вам дал ссылку, а там можете делать из него скрипт или еще что-то
Как правильно задавать вопросы
Для особо одаренных: поиск - это есть круто.
FAQ v.2 | FAQ v.3 | Шаблон запроса
Ponosov
phpBB 1.0.0
Сообщения: 1
Стаж: 18 лет 3 месяца

Re: Обсуждаем phpBB 3.0.1

Сообщение Ponosov »

после установки апдейта перестала работать админка
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 215: Undefined index: KIB
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 215: Undefined index: KIB
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 210: Undefined index: MIB
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение rxu »

Русский лангпак обновите.
Изображение
Аватара пользователя
Амбирион
phpBB 1.2.0
Сообщения: 17
Стаж: 18 лет 7 месяцев
Откуда: Torrent City

Re: Обсуждаем phpBB 3.0.1

Сообщение Амбирион »

Для обновления с phpBB 3.0.0 используется Automatic Update Package с офсайта.
  • Обновление БД прошло успешно.
  • Сравнения файлов. Установщик выявил 2 конфликтных, для обоих был выбран варинт замены на новые.
  • На этапе обновления файлов возникли критические ошибки.
    На последнем этапе обновления (по ощущениям ^^) был выбран режим автоматического переноса файлов по FTP. Несколько секунд всё выглядело подобающе - "In progress..." затем в браузере вылезла следуюшая ошибка:
    Амбиэррор писал(а):Warning: main(./../includes/functions.php) [function.main]: failed to open stream: No such file or directory in *** install/index.php on line 151

    Warning: main(./../includes/functions.php) [function.main]: failed to open stream: No such file or directory in *** install/index.php on line 151

    Fatal error: main() [function.require]: Failed opening required './../includes/functions.php' (include_path='.:/home/dreamd/etc') in *** index.php on line 151
    • *** - цензура, фактически является корнем форума.
  • index.php on line 151 содержит это:

    Код: Выделить всё

    require($phpbb_root_path . 'includes/functions.' . $phpEx);
    Папка includes/functions у меня пуста.
В файлах нового олимпуса внутри includes вобще нету папки functions. Копии старой версии форума нет. Попытка запустить установку заново сразуже приводит к этой ошибке. Как быть?
You don`t need a reason to help people.
Аватара пользователя
Амбирион
phpBB 1.2.0
Сообщения: 17
Стаж: 18 лет 7 месяцев
Откуда: Torrent City

Re: Обсуждаем phpBB 3.0.1

Сообщение Амбирион »

Есть бекапы бд до попытки установить апдейт и после того, как она была обновлена. Вопрос, что за изменения в бд вносил автомтический апдейтер?
You don`t need a reason to help people.
Аватара пользователя
Амбирион
phpBB 1.2.0
Сообщения: 17
Стаж: 18 лет 7 месяцев
Откуда: Torrent City

Re: Обсуждаем phpBB 3.0.1

Сообщение Амбирион »

За ночь перепробывал много вариантов, опишу один, самый перспективный на мой взгляд.
  1. Залил на сервер все файлы phpBB 3.0.1 кроме папки istall.
  2. Создал новую базу с именем test, разрешил к ней доступ.
  3. При попытке импортировать в новую БД записи из доапдейтного бекапа PHPMyAdmin выдаёт ошибку #1062 - Duplicate entry '?' for key 2 (попытку повторил трижды, результат не изменился). В итоге в базе только 44 таблицы из положенных 64ёх.
  4. Очистил базу, импортировал в БД test все записи из бекапа снятого после неудачного апдейта. Импорт прошёл успешно, без ошибок.
  5. Заменил нулёвый config.php на тот, что был до апдейта и сменил имя старой базы данных на новое - test.
  6. Запустил форум, вижу ошибку, которая говорит о том, что я забыл установить русский языковой пакет. На официальном сайте из раздела Language files скачал соответствующий архив для phpBB 3.0.1. Содержимое залил в соответствующую папку. Очистил кэш.
  7. Главная отобразилась, но весьма странно (хех ^^), не смотря на то, что на момент экспорта бд была отключена, слетели описания форумов, у одних полностью, у других частично. При попытке сменить описание подфорумов вылетает SQL ошибка:

    Код: Выделить всё

    SQL ERROR [ mysql4 ]
    
    Unknown column 'display_subforum_list' in 'field list' [1054]
    + полное описание. Очень напрягет покоцаный вид, может что-то ещё так же косо отресторилось? Функция отображения модераторов форумов почему-то тоже оказалась включенной, хотя не должна была. Жутко напрягает, не смотря на то, что всё остальное выглядит нормально, пользователи, сообщения на месте. Дебаг мод говорит по этому поводу следующее:

    Код: Выделить всё

    [phpBB Debug] PHP Notice: in file /includes/functions_display.php on line 403: Undefined index: display_subforum_list
    ...
    ...
    [phpBB Debug] PHP Notice: in file /includes/functions_display.php on line 403: Undefined index: display_subforum_list
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3526: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3528: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3529: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /includes/functions.php on line 3530: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    В дебаг режиме не могу войти в админку, так и должно быть?

    Код: Выделить всё

    [phpBB Debug] PHP Notice: in file /includes/functions_admin.php on line 2430: unserialize() [function.unserialize]: Error at offset 11 of 15 bytes
    [phpBB Debug] PHP Notice: in file /includes/functions_admin.php on line 2430: unserialize() [function.unserialize]: Error at offset 48 of 70 bytes
    [phpBB Debug] PHP Notice: in file /adm/index.php on line 149: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /adm/index.php on line 151: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
    [phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
  8. В администраторском разделе на закладке Система светится 3.0.1 и в настройках вложений баг, всё как положено, если упустить из виду 2 факта:
    • В статистике в графе "Размер базы данных" отображается 240.61 KiB, должно быть около десятка MiB.
    • При попытке перейти на закладку Обслуживание вылезает ошибка:

      Код: Выделить всё

      [phpBB Debug] PHP Notice: in file /includes/functions_admin.php on line 2449: implode() [function.implode]: Bad arguments.
      [phpBB Debug] PHP Notice: in file /includes/functions_admin.php on line 2449: implode() [function.implode]: Bad arguments.
      [phpBB Debug] PHP Notice: in file /includes/functions_admin.php on line 2449: implode() [function.implode]: Bad arguments.
      [phpBB Debug] PHP Notice: in file /adm/index.php on line 149: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
      [phpBB Debug] PHP Notice: in file /adm/index.php on line 151: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
      [phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
      [phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2956)
      Закмоентировав строку includes/functions.php:2956 можно получить доступ к содержимому закладки Обслуживание.

      Код: Выделить всё

      echo '<b>[phpBB Debug] PHP Notice</b>: in file <b>' . $errfile . '</b> on line <b>' . $errline . '</b>: <b>' . $msg_text . '</b><br />' . "\n";
  9. Подложил резервную копию, сделаную за час до первых попыток апдейта, при попытке откататься на неё отображается очередная ошибка:
    Fatal error: Maximum execution time of 30 seconds exceeded in /home/dreamd/forum.dreamdevice.ru/docs/includes/acp/acp_database.php on line 2239
    За эти 30 секунд успевают восстановиться описания подфорумов, но попытка изменить их приводит всё к тойже SQL ошибке.
Пожалуйста, помогите справиться с задачкой, после бессонной ночи проблема не решена, я на грани отчаяния.
Нужно восстановить работоспособность конференции с сохранением всех данных. На ранее стоявшие моды наплевать, в свете недавних событий ими можно смело пожертвовать.
You don`t need a reason to help people.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение rxu »

1) Восстанавливаете БД от 3.0.0 без содержимого поисковых таблиц (только саму структуру этих таблиц).
2) Заливаете код от 3.0.1 в папку с тем же названием, в какой был установлен 3.0.0 (т.е. в ту же папку, предварительно очищенную).
3) Заливаете config.php от 3.0.1.
4) Заливаете файлы, аватары, смайлы и пр. контент, который был на 3.0.0.
5) запускаете install/database_update.php.
6) исследуете содержимое папки /cache и удаляете оттуда все файлы, кроме index.html и .htaccess.
7) удаляете или переименовываете папку /install.
8) пытаетесь войти на конференцию.

И - причем тут обсуждение 3.0.1, когда есть отдельная тема по обновлению версии? Все вопросы туда.
Изображение
Аватара пользователя
Борис Бердичевский
phpBB 3.0.0 RC1
Сообщения: 1457
Стаж: 18 лет 8 месяцев
Откуда: Израиль, Беэр-Шева
Благодарил (а): 45 раз
Поблагодарили: 81 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение Борис Бердичевский »

Хорошо, с переносом датабазы в принципе разобрались.
Но я нигде не нашёл упоминания об ещё одном глюке, который у меня встретился, а именно: не работает стиль prosilver. Не работает вообще, просто показывает тексты на сером фоне.
Это после чистой, с нуля, установки версии 3.0.1.
Неужели ни у кого не было замечено?
После нескольких лет общения здесь и техсопровождения форумов я наконец понял, что ничего не понимаю в phpBB!
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Re: Обсуждаем phpBB 3.0.1

Сообщение Палыч »

Борис Бердичевский
http://www.phpbbguru.net/community/topic20497-15.html
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Аватара пользователя
alexset
phpBB 1.2.1
Сообщения: 27
Стаж: 18 лет 3 месяца
Откуда: UA

Re: Обсуждаем phpBB 3.0.1

Сообщение alexset »

вопрос о русишь локализации.
при апдейте с 3.0.0 до 3.0.1 приходится менять кое какие языковые файлы.
на phpBB есть русишь локализация. если её добавить в 3.0.1 о вроде бы всё ок.
вопрос: 100% эти файлы подходят к 3.0.1 или лучше самому перевести?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение rxu »

В чём собственно состоит вопрос?
Изображение
Аватара пользователя
Палыч
Former team member
Сообщения: 9683
Стаж: 20 лет 4 месяца
Откуда: Питер
Благодарил (а): 3 раза
Поблагодарили: 454 раза

Re: Обсуждаем phpBB 3.0.1

Сообщение Палыч »

alexset
Если вы не доверяете указанным на оффсайте авторам перевода (Coagulant, rxu, Xpert), то
alexset писал(а):лучше самому перевести
8-)
Не все то WINDOWS, что висит... phpBB только учусь.
ICQ, email, ЛС - только для личных сообщений. Вопросы по phpbb только на форумах. По найму не работаю.
Impeck
phpBB 1.0.0
Сообщения: 1
Стаж: 18 лет 3 месяца

Re: Обсуждаем phpBB 3.0.1

Сообщение Impeck »

Может кому-нибудь поможет.
Automatic Update Packages.
Все сразу с рус. яз. и исправленным acp_attachments.php.
Просто загрузить на сервер выполнить install и все.

Automatic Update Packages c depositfiles.com
Аватара пользователя
alexset
phpBB 1.2.1
Сообщения: 27
Стаж: 18 лет 3 месяца
Откуда: UA

Re: Обсуждаем phpBB 3.0.1

Сообщение alexset »

у меня нет недоверия к оф ленг паку. прост мне не понятно для какой версии он сделан, для 3.0.0 или для 3.0.1 ?
потому как я поставил форум 3.0.0 руссифицировал, потом обновил до 3.0.1 , там он стал частично инглиш, и я снова заменил те файлы на русс.
Аватара пользователя
RedNaxi
Former team member
Сообщения: 933
Стаж: 19 лет 7 месяцев
Откуда: BeBoss.ru
Благодарил (а): 2 раза
Поблагодарили: 14 раз

Re: Обсуждаем phpBB 3.0.1

Сообщение RedNaxi »

официальный ленг пак сделан для последней версии.
очевидно что в инструкции по обновлению указываются изменения только для английского языка, русский язык предлагается обновить самостоятельно-или по аналогии с английским, или, если на форуме не стоит модов, просто заменить старые файлы новыми.

Вернуться в «Поддержка phpBB 3.0.х»