User Blog Mod

Поддержка старых модов или модов, созданных авторами не из нашего сообщества, а также любые вопросы, связанные с модами для phpBB 3.0.x, кроме относящихся к форуму Для авторов (phpBB 3.0.x).
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
mau
phpBB 2.0.0
Сообщения: 220
Стаж: 18 лет 4 месяца
Откуда: Россия
Благодарил (а): 6 раз
Поблагодарили: 12 раз

Re: User Blog Mod

Сообщение mau »

Все установил (кроме патчей в папке contrib, может из-за этого?) и работает нормально. Но обнаружил, что при при просмотре профиля форумчанина в админпанеле (АСP), вылетаю с форума (эффект как при неправильной настройке куков). В эту закладку встроен выбор шаблона и стиль для блога. Форум 3.04, версия блога 1.08. (PHP 5.2.5). Были ли у кого такие проблемы и как исправлять?

И это происходит с теми профилями у которых не созданы блоги.
Люди, которые и впрямь любят животных, всегда спрашивают их имена
Аватара пользователя
Warlock75
Former team member
Сообщения: 1429
Стаж: 18 лет 7 месяцев
Откуда: Москва
Благодарил (а): 50 раз
Поблагодарили: 95 раз

Re: User Blog Mod

Сообщение Warlock75 »

Debug включен?
Внимательно изучаем форум и чиаем FAQ. 95% всех ответов на возможные вопросы там уже есть!

Правила
Мини FAQ по phpBB 3.1.x/3.2.x/3.3.x
Как устанавливать расширения
Аватара пользователя
mau
phpBB 2.0.0
Сообщения: 220
Стаж: 18 лет 4 месяца
Откуда: Россия
Благодарил (а): 6 раз
Поблагодарили: 12 раз

Re: User Blog Mod

Сообщение mau »

если бы я знал, что это такое.. Но все что нужно для работы форума... делал.
Люди, которые и впрямь любят животных, всегда спрашивают их имена
Аватара пользователя
Warlock75
Former team member
Сообщения: 1429
Стаж: 18 лет 7 месяцев
Откуда: Москва
Благодарил (а): 50 раз
Поблагодарили: 95 раз

Re: User Blog Mod

Сообщение Warlock75 »

mau писал(а):если бы я знал, что это такое..
Time : 0.129s | 20 Queries | GZIP : On
Внимательно изучаем форум и чиаем FAQ. 95% всех ответов на возможные вопросы там уже есть!

Правила
Мини FAQ по phpBB 3.1.x/3.2.x/3.3.x
Как устанавливать расширения
velo
phpBB 2.0.1
Сообщения: 252
Стаж: 19 лет
Благодарил (а): 10 раз
Поблагодарили: 26 раз

Re: User Blog Mod

Сообщение velo »

Оффтоп конечно, но вот инструкция, надеюсь без перевода всё понятно :)

If you change /includes/functions.php
Search

Код: Выделить всё

    switch ($errno)
       {
          case E_NOTICE:
          case E_WARNING:

             // Check the error reporting level and return if the error level does not match
             // If DEBUG is defined the default level is E_ALL
             if (($errno & ((defined('DEBUG')) ? E_ALL : error_reporting())) == 0)
             {
                return;
             }
replace with

Код: Выделить всё

       switch ($errno)
       {
          case E_NOTICE:
          case E_WARNING:

             // Check the error reporting level and return if the error level does not match
             // If DEBUG is defined the default level is E_ALL
             if (($errno & ((defined('DEBUG')) ?  E_WARNING : error_reporting())) == 0)
             {
                return;
             }
All the notices disapppear but you get code warnings. If config.php has debug turned on (optional turn debug extra to on).

config.php

Код: Выделить всё

    @define('DEBUG', true);
    // @define('DEBUG_EXTRA', true);
You also get this to see:
Time : 1.110s | 37 Queries | GZIP : On | Memory Usage: 3.92 MB | Explain
WORK: phpBB3 3.0.8 + Portal XL 5.0 + MODs + Custom,
PHP Version 5.3.3-7+squeeze25, Apache/2.2.9 (Debian), MySQL(i) 5.1.73-1+deb6u1-log
nazar
phpBB 1.4.2
Сообщения: 73
Стаж: 19 лет
Откуда: org.ua

Re: User Blog Mod

Сообщение nazar »

кто нить знает почему плагины этого мода берут Ленг переменные дефолтные форума а не юзера?
Аватара пользователя
mau
phpBB 2.0.0
Сообщения: 220
Стаж: 18 лет 4 месяца
Откуда: Россия
Благодарил (а): 6 раз
Поблагодарили: 12 раз

Re: User Blog Mod

Сообщение mau »

Спасибо за советы и помощь. :) Все испробовал и сделал чуть по-другому. Проверил заново установку мода, но все в порядке. Блоги пользователей работают и жалоб не было. Тогда решил просто деитнсталировать вот эту строчку.
Open: adm/style/acp_users_profile.html
Find
Tip: This may be a partial find and not the whole line.

Код: Выделить всё

</fieldset>
Add after

Tip: Add these lines on a new blank line after the preceding line(s) to find.

Код: Выделить всё

<!-- INCLUDE acp_blog_users.html -->
Толку от нее ни какого не было на данном форуме.. шаблон для блогов все равно один для всех.
Люди, которые и впрямь любят животных, всегда спрашивают их имена
Gisher
phpBB 2.0.12
Сообщения: 857
Стаж: 19 лет 11 месяцев
Благодарил (а): 11 раз
Поблагодарили: 13 раз

Re: User Blog Mod

Сообщение Gisher »

mau
дайте им права на выбор шаблонов
Аватара пользователя
mau
phpBB 2.0.0
Сообщения: 220
Стаж: 18 лет 4 месяца
Откуда: Россия
Благодарил (а): 6 раз
Поблагодарили: 12 раз

Re: User Blog Mod

Сообщение mau »

Может выбирать стиль для использования в собственном блоге - да
там есть вот только такая строчка, которая отключена
Может внедрять в них собственный CSS код, чтобы настроить стиль своего блога по своему вкусу.
Но я пока не стал это включать... надо сделать хотя бы шаблоны и предложить форумчанам.. иначе для них это загадка.

На домашней странице мода почитал... пишут, что проблемы есть (свою не нашел :) ) и просят подождать с выходом новой версии
Люди, которые и впрямь любят животных, всегда спрашивают их имена
Аватара пользователя
Warlock75
Former team member
Сообщения: 1429
Стаж: 18 лет 7 месяцев
Откуда: Москва
Благодарил (а): 50 раз
Поблагодарили: 95 раз

Re: User Blog Mod

Сообщение Warlock75 »

mau писал(а):просят подождать с выходом новой версии
После 10 Января должна появиться 1.0.9. Новых фич в ней почти не будет, зато будет устранено множество мелких проблем.
Внимательно изучаем форум и чиаем FAQ. 95% всех ответов на возможные вопросы там уже есть!

Правила
Мини FAQ по phpBB 3.1.x/3.2.x/3.3.x
Как устанавливать расширения
nute
phpBB 1.0.0
Сообщения: 7
Стаж: 20 лет 4 месяца

Re: User Blog Mod

Сообщение nute »

Подскажите, можно ли установить стиль по умолчанию для блогов отличным от стиля по умолчанию форума? Нашел только вручную выбор стиля каждым пользователем.
Спасибо.
hate_me
phpBB 1.0.0
Сообщения: 2
Стаж: 17 лет 6 месяцев

Re: User Blog Mod

Сообщение hate_me »

Код: Выделить всё

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3762: page_header(./blog/header.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3762: page_header(./blog/header.php): failed to open stream: No such file or directory
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3762: page_header(): Failed opening './blog/header.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php')
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3765: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3766: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 3767: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3184)
Вверху шапки форума. вроде правильно всё сделал. а нефига не устанавливается..(( что эт такое вообще?
Gisher
phpBB 2.0.12
Сообщения: 857
Стаж: 19 лет 11 месяцев
Благодарил (а): 11 раз
Поблагодарили: 13 раз

Re: User Blog Mod

Сообщение Gisher »

а вы залили файл /blog/header.php?
hate_me
phpBB 1.0.0
Сообщения: 2
Стаж: 17 лет 6 месяцев

Re: User Blog Mod

Сообщение hate_me »

Я сделал так... залил всё что было в папке root(папку прям целиком залил) если не так делать то скажите как.
потом прописал в файлах всё что надо.. и всё..
Может это из-за того что я не понял как и что куда зиливать из папки root????
nute
phpBB 1.0.0
Сообщения: 7
Стаж: 20 лет 4 месяца

Re: User Blog Mod

Сообщение nute »

таки никто не знает можно ли при первом создании блога пользователем установить стиль по умолчанию для блога отличным от стиля по умолчанию форума?
а так же изменить стиль для файла blog.php отличный от стиля конференции.
Спасибо.

Вернуться в «Поддержка модов для phpBB 3.0.x»