Ошибка при восстановлении из бэкапа

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

Вообщем,

У меня взломали сайт, снесли все темы на форуме, но до этого за день я делал бэкап.
В результате сохранил сегодня бекап в папочку /store и запустил его для восстановления и выдает ошибку описанную выше.
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Проблема при восстановлении данных

Сообщение rxu »

А если попробовать

Код: Выделить всё

max_allowed_packet=32M
Изображение
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

в php.ini?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Проблема при восстановлении данных

Сообщение rxu »

sonsr
Конечно, нет. Это настройка MySQL сервера.
Изображение
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

Подскажите, где это ввести
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Проблема при восстановлении данных

Сообщение rxu »

Так... лучше к хостеру обратитесь с этой ошибкой. Да и с восстановлением БД хостеры иногда помогают.
Изображение
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

Вот что ответил хостер, если честно не допонимаю

Здравствуйте.
Вам следует сделать дамп с вашего сервера с данным ключем.
Информацию по использованию mysql вы можете найти в интернете.
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Проблема при восстановлении данных

Сообщение Rayden »

С каким с данным?
phpBB2 FAQ
phpBB3 FAQ
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

Я вот тоже не пойму) сделать дамп с ключем который указан мне в ошибке...

Если я все правильно понимаю, то дамп - это та же резервная копия, но если мне неизчего её делать, как быть?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: Проблема при восстановлении данных

Сообщение rxu »

Вы как вообще восстанавливаете? Какой размер дампа? Данные поисковых таблиц туда тоже включены?
Изображение
sonsr
phpBB 1.0.0
Сообщения: 7
Стаж: 17 лет 4 месяца

Re: Проблема при восстановлении данных

Сообщение sonsr »

Я делал резервную копию стандартными возможностями phpbb3
И восстановление делаю тоже используя функцию "восстановить" в админке phpbb3
Аватара пользователя
nissin
phpBB 3.0.4
Сообщения: 2229
Стаж: 18 лет 9 месяцев
Откуда: Астана
Благодарил (а): 7 раз
Поблагодарили: 344 раза

Re: Проблема при восстановлении данных

Сообщение nissin »

Попросите хостера увеличить max_allowed_packet.
Если нет, то придётся поднимать и создавать заново (уже с меньшим размером пакета) backup на localhost.
Аватара пользователя
ImageMaker
phpBB 1.0.0
Сообщения: 5
Стаж: 18 лет 11 месяцев

Re: Ошибка при восстановлении из бэкапа

Сообщение ImageMaker »

Пытаюсь восстановить базу (размер базы примерно 60 мег) с помощью dumper'а
Через какое-то время (примерно минута) вылетает ошибка
504 Gateway Time-out
как поправить?
Аватара пользователя
Лейтенант
phpBB 1.4.2
Сообщения: 59
Стаж: 17 лет 2 месяца
Благодарил (а): 2 раза
Поблагодарили: 2 раза

Re: Проблема при восстановлении данных

Сообщение Лейтенант »

При попытке начать восстановление базы данных появляется белая страничка с надписью

Код: Выделить всё

504 Gateway Time-out
Что это значит?
Аватара пользователя
Rayden
Former team member
Сообщения: 3739
Стаж: 21 год 2 месяца
Поблагодарили: 44 раза

Re: Проблема при восстановлении данных

Сообщение Rayden »

Это значит время, выделенное скрипту истекло. "Цигель, цигель, ай-лю-лю".
phpBB2 FAQ
phpBB3 FAQ

Вернуться в «Поддержка phpBB 3.0.х»