Настройка Jabber
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
anvm
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 16 лет 6 месяцев
Re: Настройка Jabber
Вопрос: можно ли заставить Jabber работать с портом 80 и незащищенным соединением?
Не удается подключить, ошибки и сообщения как указано выше. Проделал все рекомендации, оказалось
хостинг не позволяет выдавать исходящие сообщения по другим портам (кроме 80).
А если в клиенте Jabbera устанавливаю порт 80, то не удается подключиться.
Возможно напрямую к phpBB это не относится, но как-то же присутствующим удалось настроить?
Не удается подключить, ошибки и сообщения как указано выше. Проделал все рекомендации, оказалось
хостинг не позволяет выдавать исходящие сообщения по другим портам (кроме 80).
А если в клиенте Jabbera устанавливаю порт 80, то не удается подключиться.
Возможно напрямую к phpBB это не относится, но как-то же присутствующим удалось настроить?
phpBB3 3.0.7-PL1
-
anvm
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 16 лет 6 месяцев
Re: Настройка Jabber
Нестандартные порты нашел, кому интересно тут и тут и тут
Но теперь другая проблема, с помощью теста выявил, что у хостера что-то закрыто, не получает ответ от сервера джаббера.
Тест:
На localhost тест нормально отправляет сообщение, при запуске с хостинга:
Тоже самое выдает и форма настройки Jabbera в phpBB. 
Но теперь другая проблема, с помощью теста выявил, что у хостера что-то закрыто, не получает ответ от сервера джаббера.
Тест:
Код: Выделить всё
<?php
define('IN_PHPBB','ON');
include_once('utf_tools.php');
include_once('functions_jabber.php');
$subj = 'test jabbers';
$mesg = 'test jabbers';
function out_err($msg)
{
echo '<br />'.$msg;
}
function msg_jabber()
{
global $mesg, $subj;
$jab_host = 'allports.jabber.ru';
$jab_port = 80;
$jab_user = 'my@jabber.ru';
$jab_pass = 'пароль';
$address = 'other@ya.ru';
$jabber = new jabber($jab_host, $jab_port, $jab_user, $jab_pass, false);
if (!$jabber->connect())
{
out_err('Ошибка connect: <br/>' . $jabber->get_log());
return false;
}
if (!$jabber->login())
{
out_err('Ошибка login: <br/>' . $jabber->get_log());
return false;
}
$jabber->send_message($address, $mesg, $subj);
$jabber->disconnect();
return true;
}
msg_jabber();
echo '<br />send: '.$mesg;
?>Код: Выделить всё
Ошибка login:
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='jabber.ru' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
Timeout, no response from server.
Error: No feature information from server available.
send: test jabbersphpBB3 3.0.7-PL1
-
anvm
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 16 лет 6 месяцев
Re: Настройка Jabber - сервера
Насколько понял это можно сделать через транспорт сервера Jabber, что-то типа 123456@icq.jabber.ru
phpBB3 3.0.7-PL1
-
Rezaka™
- phpBB 1.4.2
- Сообщения: 71
- Стаж: 17 лет 2 месяца
- Откуда: phpBB 3.1.9
- Благодарил (а): 1 раз
Re: Настройка Jabber
anvm, как я писал выше, у меня раньше работало на 80 порту на gmail.com, но с недавнего времени перестало :( Может гугл порт закрыл, может мой хостер, без понятия. В итоге пришлось обратится к хостеру, чтобы он открыл порт 5222 для исходящих сообщений для сервера Jabber.ru. Теперь наконецто все работает.
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
Подскажите, как быть?
У меня сервер поднят свой: OpenFire
Из ЛВС в интернет доступа нет
как в таком случае настроить Jabber?
З.Ы.: у меня установлен phpBB-3.0.7-PL1
У меня сервер поднят свой: OpenFire
Из ЛВС в интернет доступа нет
как в таком случае настроить Jabber?
З.Ы.: у меня установлен phpBB-3.0.7-PL1
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
уже вбил, лог могу приложитьnissin писал(а):Вбить IP адрес сервера в настройках не судьба?
P.S.: даже в файле function_jabber.php ковырялся и исправлят jabber.com на свой ip.
Сообщение об ошибке стало короче - и всё.
P.S.: может я не знаю о каких то других настройках - подскажи, буду очень благодарен.
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
Не удалось войти на сервер Jabber.
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
RECV: <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="ip-srv.lan" id="99664d2c" xml:lang="en" version="1.0">
RECV: <stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><m ... sion><auth xmlns="http://jabber.org/features/iq-auth"/></stream:features>
Switching to TLS.
SEND: <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
RECV: <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
RECV: <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="ip-srv.lan" id="99664d2c" xml:lang="en" version="1.0"><stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><m ... sion><auth xmlns="http://jabber.org/features/iq-auth"/></stream:features>
SEND: <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='DIGEST-MD5'/>
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09ImlwLXNydi5rcm5zLmxhbiIsbm9uY2U9Ii9OTU53Ui9jZDRsMVAzclNtcDNVbTdabHAwc1g3WGNNMGwydGh1R1MiLHFvcD0iYXV0aCIsY2hhcnNldD11dGYtOCxhbGdvcml0aG09bWQ1LXNlc3M=</challenge>
SEND: <response xmlns='urn:ietf:params:xml:ns:xmpp-sasl'>dXNlcm5hbWU9ImZvcnVtIixyZXNwb25zZT0iZTA3MjQxY2UxMjU5YTMzZjkwYWFkMTBhYWFmMzY0YTciLGNoYXJzZXQ9InV0Zi04IixuYz0iMDAwMDAwMDEiLHFvcD0iYXV0aCIsbm9uY2U9Ii9OTU53Ui9jZDRsMVAzclNtcDNVbTdabHAwc1g3WGNNMGwydGh1R1MiLGRpZ2VzdC11cmk9InhtcHAvMTcyLjE3LjUyLjE5IixyZWFsbT0iaXAtc3J2LmtybnMubGFuIixjbm9uY2U9Ik9XUTFPVEZtTkRrME9UTTRNalEwT1RrME9XVTBOV1EwTkRZM1pqYzRNakE9Ig==</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure>
Error: Server sent "failure".
SEND: </stream:stream>
После редактирования файла:function_jabber.php
Информация
Не удалось войти на сервер Jabber.
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='192.168.0.54' version='1.0'>
RECV: </stream:stream>
Error: No feature information from server available.
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
RECV: <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="ip-srv.lan" id="99664d2c" xml:lang="en" version="1.0">
RECV: <stream:features><starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"></starttls><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><m ... sion><auth xmlns="http://jabber.org/features/iq-auth"/></stream:features>
Switching to TLS.
SEND: <starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
RECV: <proceed xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='http://etherx.jabber.org/streams' version='1.0'>
RECV: <?xml version='1.0' encoding='UTF-8'?><stream:stream xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client" from="ip-srv.lan" id="99664d2c" xml:lang="en" version="1.0"><stream:features><mechanisms xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><mechanism>DIGEST-MD5</mechanism><mechanism>PLAIN</mechanism><mechanism>CRAM-MD5</mechanism></mechanisms><compression xmlns="http://jabber.org/features/compress"><m ... sion><auth xmlns="http://jabber.org/features/iq-auth"/></stream:features>
SEND: <auth xmlns='urn:ietf:params:xml:ns:xmpp-sasl' mechanism='DIGEST-MD5'/>
RECV: <challenge xmlns="urn:ietf:params:xml:ns:xmpp-sasl">cmVhbG09ImlwLXNydi5rcm5zLmxhbiIsbm9uY2U9Ii9OTU53Ui9jZDRsMVAzclNtcDNVbTdabHAwc1g3WGNNMGwydGh1R1MiLHFvcD0iYXV0aCIsY2hhcnNldD11dGYtOCxhbGdvcml0aG09bWQ1LXNlc3M=</challenge>
SEND: <response xmlns='urn:ietf:params:xml:ns:xmpp-sasl'>dXNlcm5hbWU9ImZvcnVtIixyZXNwb25zZT0iZTA3MjQxY2UxMjU5YTMzZjkwYWFkMTBhYWFmMzY0YTciLGNoYXJzZXQ9InV0Zi04IixuYz0iMDAwMDAwMDEiLHFvcD0iYXV0aCIsbm9uY2U9Ii9OTU53Ui9jZDRsMVAzclNtcDNVbTdabHAwc1g3WGNNMGwydGh1R1MiLGRpZ2VzdC11cmk9InhtcHAvMTcyLjE3LjUyLjE5IixyZWFsbT0iaXAtc3J2LmtybnMubGFuIixjbm9uY2U9Ik9XUTFPVEZtTkRrME9UTTRNalEwT1RrME9XVTBOV1EwTkRZM1pqYzRNakE9Ig==</response>
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure>
Error: Server sent "failure".
SEND: </stream:stream>
После редактирования файла:function_jabber.php
Информация
Не удалось войти на сервер Jabber.
SEND: <?xml version='1.0' encoding='UTF-8' ?>
SEND: <stream:stream to='192.168.0.54' xmlns='jabber:client' xmlns:stream='192.168.0.54' version='1.0'>
RECV: </stream:stream>
Error: No feature information from server available.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Настройка Jabber
А обычный jabber клиент с такими настройками заходит?
Я не совсем уверен, что Вы правильно указали Jabber ID (forum@192.168.0.54).
Я не совсем уверен, что Вы правильно указали Jabber ID (forum@192.168.0.54).
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
Да, я специально создал пользователя forum
я использую клиент - Spark, с него с этим именем и паролем я захожу - вижу пользователей. могу им написать и т.п.
192.168.0.54 - ip-адрес сервера на котором стоит OpenFire
я использую клиент - Spark, с него с этим именем и паролем я захожу - вижу пользователей. могу им написать и т.п.
192.168.0.54 - ip-адрес сервера на котором стоит OpenFire
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
единственное, что я нашёл в логах на сервере OpenFire:
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
nissin
- phpBB 3.0.4
- Сообщения: 2229
- Стаж: 18 лет 9 месяцев
- Откуда: Астана
- Благодарил (а): 7 раз
- Поблагодарили: 344 раза
Re: Настройка Jabber
К сожалению с OpenFire не знаком совершенно. Но в логах должна быть причина, по которой не прошёл challenge и сервер ответил:
Добавлено спустя 11 минут 35 секунд:
Но судя по:
http://developer.pidgin.im/ticket/5008
У Вас не указан домен(хотя бы внутренний) в настройках OpenFire.
Код: Выделить всё
RECV: <failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure>Но судя по:
http://developer.pidgin.im/ticket/5008
У Вас не указан домен(хотя бы внутренний) в настройках OpenFire.
-
Kobudo
- phpBB 1.2.0
- Сообщения: 10
- Стаж: 16 лет 5 месяцев
Re: Настройка Jabber
Первый лог с непоправленным файлом - домен не указан.
Правлю файл (указываю IP-адрес) - второй лог.
Сходил по ссылке - добавил рекомендованную там строчку - никаких изменений.
Правлю файл (указываю IP-адрес) - второй лог.
Сходил по ссылке - добавил рекомендованную там строчку - никаких изменений.

