Белые (пустые) страницы
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
PAW
- phpBB 1.4.3
- Сообщения: 93
- Стаж: 16 лет 6 месяцев
- Благодарил (а): 14 раз
Re: Белые (пустые) страницы
Здравствуйте.
Описание проблемы: после чистки кэша форума захожу на форум,ввожу логин,пароль и попадаю на белую пустую страницу.Восстанавливаю форум до чистки кэша-всё нормально,но приходит письмо при регистрации пользователя практически без данных,стОит очистить кэш-письмо с регистрацией становится корректным,но появляются белые пустые страницы.Права доступа на папки расставил как написано.Error_log сервера пустой. Что ж теперь кэш вообще не чистить?
Произведенные изменения, после которых начались неполадки: чистка кэша
Версия phpBB*:phpBB 3.0.7-PL
Используемые шаблоны:prosilver
Используемые моды: ???
Версия PHP: PHP 5
Используемая СУБД и её версия: Версия MySQL-клиента: 5.0.26
Ссылка на конференцию:----
Есть ли у вас тестовый аккаунт**:----
Использовался ли поиск для решения проблемы:да
Если да, то какие запросы вы использовали:белые страницы
Каким браузером вы пользовались и есть ли проблема с другими браузерами:IE,Mozilla,Google везде одинаковая проблема.
Описание проблемы: после чистки кэша форума захожу на форум,ввожу логин,пароль и попадаю на белую пустую страницу.Восстанавливаю форум до чистки кэша-всё нормально,но приходит письмо при регистрации пользователя практически без данных,стОит очистить кэш-письмо с регистрацией становится корректным,но появляются белые пустые страницы.Права доступа на папки расставил как написано.Error_log сервера пустой. Что ж теперь кэш вообще не чистить?
Произведенные изменения, после которых начались неполадки: чистка кэша
Версия phpBB*:phpBB 3.0.7-PL
Используемые шаблоны:prosilver
Используемые моды: ???
Версия PHP: PHP 5
Используемая СУБД и её версия: Версия MySQL-клиента: 5.0.26
Ссылка на конференцию:----
Есть ли у вас тестовый аккаунт**:----
Использовался ли поиск для решения проблемы:да
Если да, то какие запросы вы использовали:белые страницы
Каким браузером вы пользовались и есть ли проблема с другими браузерами:IE,Mozilla,Google везде одинаковая проблема.
-
MIT
- Former team member
- Сообщения: 2500
- Стаж: 17 лет 6 месяцев
- Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
- Благодарил (а): 3 раза
- Поблагодарили: 351 раз
Re: Белые (пустые) страницы
Проблема не в очистке кеша, а в том, что какая-то ранее закешированная информация повреждена в своём источнике.
Какая — вопрос сложный, но стоит вспомнить что вообще делалось в последнее время с форумом, какие файлы правились, может какие-то заменялись.
Например, может быть поврежден файл config.php или в нём неверна указана версия базы данных.
Какая — вопрос сложный, но стоит вспомнить что вообще делалось в последнее время с форумом, какие файлы правились, может какие-то заменялись.
Например, может быть поврежден файл config.php или в нём неверна указана версия базы данных.
-
Юрий Лукашов
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 16 лет 6 месяцев
- Откуда: п. Тюльган
Re: Белые (пустые) страницы
Прочитав всю ветку так и ненашел решения своей проблемы.
Поиск по форуму. После того как набрал слово в поиске и нажал искать выходит пустая страница. Если в поиск вводишь 2 символа, то открывается страница с сообщением о том что необходимо ввести минимум 3 знака. Так же не работают (Сообщения без ответов • Непрочитанные сообщения • Новые сообщения • Активные темы). Что может быть и где копать?
error.log
tpl_prosilver_search_results.html.php
Поиск по форуму. После того как набрал слово в поиске и нажал искать выходит пустая страница. Если в поиск вводишь 2 символа, то открывается страница с сообщением о том что необходимо ввести минимум 3 знака. Так же не работают (Сообщения без ответов • Непрочитанные сообщения • Новые сообщения • Активные темы). Что может быть и где копать?
error.log
Код: Выделить всё
[Wed Mar 31 20:13:19 2010] [error] [client xxx.xxx.xxx.171] PHP Parse error: syntax error, unexpected $end in /home/w/xxxx/xxxx/public_html/forumm/cache/tpl_prosilver_search_results.html.php on line 181, referer: http://xxxx.ru/forumm/search.php
Код: Выделить всё
179 <?php } else { ?>
180 <div class="panel">
181 <div class="inner"><span class="corners-top"><span></span></span>
182 <strong><?php echo ((isset($this->_rootref['L_NO_SEARCH_RESULTS'])) ? $this->_rootref['L_NO_SEARCH_RESULTS'] : ((isset($user->lang['NO_SEARCH_RESULTS'])) ? $user->lang['NO_SEARCH_RESULTS'] : '{ NO_SEARCH_RESULTS }')); ?></strong>
183 <span class="corners-bottom"><span></span></span></div>
184 </div>-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
Re: Белые (пустые) страницы
Это означает Битый кэш. Админка - очистить кэш, даст вам счастье
Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
Юрий Лукашов
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 16 лет 6 месяцев
- Откуда: п. Тюльган
-
Поручик
- Former team member
- Сообщения: 3942
- Стаж: 21 год 4 месяца
- Откуда: Оренбург (Южный Урал)
- Благодарил (а): 24 раза
- Поблагодарили: 54 раза
Re: Белые (пустые) страницы
Тогда начинаем терморектальный анализ.
У вас ошибка в шаблоне prosilver/search_results.html, именно в нём, а не в файле tpl_prosilver_search_results.html.php кэша. Моды разумеется не ставили, всё произошло само собой.
Попробуйте ещё раз залить на сервер файлы шаблона.
У вас ошибка в шаблоне prosilver/search_results.html, именно в нём, а не в файле tpl_prosilver_search_results.html.php кэша. Моды разумеется не ставили, всё произошло само собой.
Попробуйте ещё раз залить на сервер файлы шаблона.
Профессионал - тот же дилетант, только знающий, где ошибётся.
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
Генератор db_update.php для phpBB2 с некоторыми удобствами. Многие моды я беру или ищу здесь, здесь, тут
Все консультации только на форуме, приваты и стук в аську по таким вопросам игнорируются!
FAQ-phpBB3 | Ошибки новичков, или как не поссориться с модератором | Правила конференции
наш форум http://forum.aeroion.ru/cat1.html
-
Юрий Лукашов
- phpBB 1.0.0
- Сообщения: 5
- Стаж: 16 лет 6 месяцев
- Откуда: п. Тюльган
Re: Белые (пустые) страницы
Моды ставил и много, удалял и опять ставил. Сейчас буду сравнивать файлы с оригиналами, отпишу к чему это привело. Спасибо за быстрые ответы.
Добавлено спустя 13 минут 7 секунд:
Будем решать теперь свою вторую проблему, но это другая тема.
Добавлено спустя 13 минут 7 секунд:
Огромное спасибо, файл был битый, перезалил и все заработало.Поручик писал(а):У вас ошибка в шаблоне prosilver/search_results.html
Будем решать теперь свою вторую проблему, но это другая тема.
-
AndyPoll
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 16 лет 4 месяца
Re: Белые (пустые) страницы
Здравствуйте!
Все перечитал. Ответ не нашел.
В админке очистил кэш для изображений шаблона...
После этого белый экран.
[Wed Apr 28 16:38:46 2010] [error] [client 193.107.184.192] PHP Fatal error: Call to undefined method garage::add_garage_images() in D:\\htdocs\\hotwheels.com.ua\\forum\\includes\\session.php on line 1804
Все перепробывал... помогите пожалуйста!
Все перечитал. Ответ не нашел.
В админке очистил кэш для изображений шаблона...
После этого белый экран.
[Wed Apr 28 16:38:46 2010] [error] [client 193.107.184.192] PHP Fatal error: Call to undefined method garage::add_garage_images() in D:\\htdocs\\hotwheels.com.ua\\forum\\includes\\session.php on line 1804
Все перепробывал... помогите пожалуйста!
-
AndyPoll
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 16 лет 4 месяца
Re: Белые (пустые) страницы
Давно ставил, вроде очищал, даже переезжал на другой хостинг...
Такая проблема не может быть из-за того что удалил копирайт phpbb?
Такая проблема не может быть из-за того что удалил копирайт phpbb?
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
-
svendialog
- phpBB 1.0.0
- Сообщения: 1
- Стаж: 16 лет 4 месяца
Re: Белые (пустые) страницы
попробуй в своем браузере покопать, может проблема как раз в нем самом...
-
Rayden
- Former team member
- Сообщения: 3739
- Стаж: 21 год 2 месяца
- Поблагодарили: 44 раза
Re: Белые (пустые) страницы
svendialog
Что конкретно копать в браузере? Куда лопату втыкать? Давай точный совет.
Что конкретно копать в браузере? Куда лопату втыкать? Давай точный совет.
-
dauren300
- phpBB 1.0.0
- Сообщения: 7
- Стаж: 16 лет 4 месяца
Re: Белые (пустые) страницы
Здравствуйте, у меня стоит движок phpbb 3.0.6 , вчера утром форум работал нормально, захожу через 5 часов вместо форума появляется белый лист. Что делать?
Я сделал:
1. Написал хостеру, я им говорю что возможно из за нехватки дискового пространства у меня такие проблемы, попросил их почистить у себя, они говорят что проблема у меня со скриптом, хотя я ничего не делал со скриптом, не ковырялся в нем, в админке экспериментами не занимался и т.д
2. Почистил кэш с ftp, удалил все кроме .htaccess.
Результат: Ничего не изменилось, как были белые страницы так они и остались.
Подскажите пож-ста как лечить это? что делать , желательно пошагово. Всем спасибо!
Я сделал:
1. Написал хостеру, я им говорю что возможно из за нехватки дискового пространства у меня такие проблемы, попросил их почистить у себя, они говорят что проблема у меня со скриптом, хотя я ничего не делал со скриптом, не ковырялся в нем, в админке экспериментами не занимался и т.д
2. Почистил кэш с ftp, удалил все кроме .htaccess.
Результат: Ничего не изменилось, как были белые страницы так они и остались.
Подскажите пож-ста как лечить это? что делать , желательно пошагово. Всем спасибо!

