UCP, проблема при регистрации пользователя

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Oktja
phpBB 1.2.0
Сообщения: 17
Стаж: 21 год 6 месяцев
Благодарил (а): 4 раза

Re: UCP, проблема при регистрации пользователя

Сообщение Oktja »

У меня точно такая же ошибка, как у geo5. С той разницей, что форум новый, никаких ошибок с базой данных не было.

Версия phpBB*: 3.0.7
Используемые шаблоны: eTech Green
Используемые моды: нет
Версия PHP: 5
Используемая СУБД и её версия: MySql5

Еще раз об ошибке: В админке было создано доп. поле тип integer , обязательное к заполнению при регистрации. Через некоторое время я его в админке отключила вообще.
После отключения при регистрации выдавалась ошибка базы данных.
"SQL ERROR [ mysql4 ]
Incorrect integer value: ''" for column 'id_spiel' at row 1 [1366]

Подозреваю, что это из-за того, что поле было обязательным для заполнения, а после отключения оно стало просто недоступным, но все еще обязательным для заполнения (надеюсь, понятно выразилась)

Удаление дополнительных полей в админке помогло, но мне может понадобиться, чтобы доп. поле включалось на время, потом отключалось(в админке).
Спасибо.
KPEM
phpBB 1.2.0
Сообщения: 17
Стаж: 17 лет 3 месяца
Благодарил (а): 2 раза

Re: UCP, проблема при регистрации пользователя

Сообщение KPEM »

У меня похожая ошибка. При вводе любого кириллического символа в любую форуму phpBB из IE9 или Chrome, форум валится, например, с такой ошибкой:

Код: Выделить всё

SQL ERROR [ mysql4 ]

Incorrect string value: '\xD0\x9E\xD0\xBF\xD0\xB8...' for column 'config_value' at row 1 [1366]

SQL

UPDATE phpbb_config SET config_value = 'Описание сайта' WHERE config_name = 'site_desc'

BACKTRACE


FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions.php
LINE: 149
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_board.php
LINE: 478
CALL: set_config()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_board->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
Чувствую, что дело как-то связано с кодировками клиента или сервера. Если в браузере руками менять кодировку на 1251, то ошибка пропадает, но текст из форм не сохраняется.

Сразу обращаю внимание на то, что хостинг американский (управление через cPanel).

Установка 3.0.9 методом апгрейда с 3.0.8. Патчей, аддонов и прочих вещей не ставил. Активности на форуме не было. То есть, речь идет о фактически девственно чистом форуме.

Большая просьба помочь.

И есть это важно, то вот инфа из phpMyAdmin:

MySQL charset: UTF-8 Unicode (utf8)
MySQL connection collation: utf8_general_ci

Хотя на другом американском хостинге 3.0.7-PL1 работает с настройками по-умолчанию. И жрет кириллицу от браузеров в UTF-8 без всяких вопросов.

Вернуться в «Поддержка phpBB 3.0.х»