SQL ошибка при назначении прав модератору в админке

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

Здравствуйте, уважаемые гуру.
Прошу помочь разобраться с возникшей ошибкой.
В админке иду в в Пользователи и группы - Права групп - хочу разрешить модераторам блокировать пользователей т.к. что-то стали часто спамеры заходить.
Выбираю "Блокировать" и при применении появляется следующая ошибка:
Общая ошибка

Код: Выделить всё

SQL ERROR [ mysql4 ]

The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay [1104]

SQL

SELECT a.forum_id, ug.user_id, g.group_id FROM (phpbb_acl_options o, phpbb_user_group ug, phpbb_groups g, phpbb_acl_groups a) LEFT JOIN phpbb_acl_roles_data r ON (a.auth_role_id = r.role_id) WHERE (o.auth_option_id = a.auth_option_id OR o.auth_option_id = r.auth_option_id) AND ((a.auth_setting = 0 AND r.auth_setting IS NULL) OR r.auth_setting = 0) AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ug.user_id IN (2, 261, 284, 53, 267, 67, 69, 289, 60) AND ug.user_pending = 0 AND o.auth_option LIKE 'm\\_%'

BACKTRACE

FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_admin.php
LINE: 2395
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_permissions.php
LINE: 730
CALL: cache_moderators()

FILE: includes/acp/acp_permissions.php
LINE: 313
CALL: acp_permissions->set_permissions()

FILE: includes/functions_module.php
LINE: 507
CALL: acp_permissions->main()

FILE: adm/index.php
LINE: 74
CALL: p_master->load_active()
Но при этом права на блокировку присвоились.
Пожалуйста помогите разобраться о чем в этой ошибке говориться и что нужно сделать чтоб ее устранить?
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение rxu »

Egoz
Попросите хостера увеличить значение памаметра MAX_JOIN_SIZE сервера MySQL.
Изображение
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

rxu
а не могли бы вы в кратце объяснить что это значит? о чем я буду просить хостера? чтоб я хоть немного был в курсе.
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение rxu »

Это переменная окружения сервера БД.
max_join_size.
Изображение
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

Переписка с хостером:
как можно решить мой вопрос?
16:52:31На самом сервере увеличить данный параметр не получится. Единственный вариант - это добавить в скрипт перед запросом такую строку:
mysql_query ("SET SQL_BIG_SELECTS=1");
16:53:10а в какой скрипт и что это добавление даст?
16:53:23и почему не получится увеличить?
16:54:04Непосредственно в тот скрипт, который обращается к БД с запросом MAX_JOIN_SIZE rows ....
16:54:37Не верно Вам запрос написал. На странице, где выдается такого рода ошибка идут запросы к БД
16:54:52После подключения к БД скриптом пропишите данную строку.
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение rxu »

Egoz
Если делать так, как сказал хостер, то в common.php перед закрывающим тегом файла ?> добавить код

Код: Выделить всё

$db->sql_query('SET SQL_BIG_SELECTS=1');
Если ошибка возникает только с этой страницей и этим запросом, попробуйте добавить приведенный выше код в файл /includes/functions_admin.php в функции cache_moderators() перед строкой

Код: Выделить всё

// Remove users who have group memberships with DENY moderator permissions
Изображение
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

rxu писал(а):Если ошибка возникает только с этой страницей и этим запросом
ну вообще-то не только. еще похожая ошибка

Код: Выделить всё

SQL ERROR [ mysql4 ]

The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay [1104]
Может, как вариант, поискать в Ректутинге кто возьмется проанализировать работу форума, а точнее самой БД и этих ошибок и устранит их?
Переустановка же тут не поможет? Тем более что БД останется таже
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17272
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 632 раза
Поблагодарили: 2412 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение rxu »

Проблема не на стороне скрипта, скорее всего. Попробуйте вариант номер 1 (с common.php).
Изображение
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

rxu
Спасибо большое. 1 вариант эти 2 ошибки исправил. Все работает на "Ура"!
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

rxu
здравствуйте еще раз. быть может не совсем по теме, но не хочется создавать еще тему.
не могли бы вы мне подсказать файл в админке, отвечающий за эту страницу:
Админка - Стили - Шаблоны - prosilver - Oбновить
при этом действии выходит ошибка:

Код: Выделить всё

Could not open ./../styles/prosilver/template/announcement_centre.html
вот я и хочу понять что вызывает эта ошибка - что это за мод я в свое время ставил и где ошибка: или в файлике в этом в стиле не доудалил что-то или быть может в БД надо какую таблицу убить лишнюю.
помогите пожалуйста. а то все время приходится делать так Кеш - Выделить все - Удалить вместо Обновить.
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Айдар »

Egoz, собственно, мод, видимо, этот: ACP Announcement Centre (объявления) для phpBB3
Сам шаблон присутствует на сервере? Проверьте доступ к этому файлу (атрибуты)
З.Ы. "Обновить" и "Очистить кэш" - это разные функции.
Ваша ошибка к мускулу не имеет никакого отношения.
In Web We Trust
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

Айдар
шаблон имеете ввиду просильвер? да, присутствует. а мод получается я этот давно ставил и он видимо мне не подошел и я его удалил, проделав все операции установки в обратном порядке (вроде бы так надо делать для удаления модов).
и вот после этого стала появляться ошибка?
а разве вот тут:
prosilver Изменить | Кэш | Информация Обновить | Экспорт | Удалить
Обновить не означает обновить/очистить кэш? надо именно заходить в Кэш, выделять и удалять?
Сейчас получается надо скачать мод, открыть файл установки и все тщательно проверить - все ли я удалил от него или нет? так?
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста
Аватара пользователя
Айдар
Former team member
Сообщения: 1687
Стаж: 15 лет 9 месяцев
Откуда: KZN
Благодарил (а): 93 раза
Поблагодарили: 189 раз

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Айдар »

Egoz писал(а):проделав все операции установки в обратном порядке
Видимо, ошибочное слово в этой фразе "все", само отсутствие шаблона ошибку вызывать не должно, видимо, что-то еще осталось, что вызывает этот шаблон - проверьте еще раз по инструкции отсутствие лишних файлов и кодов?
Egoz писал(а):не означает обновить/очистить кэш?
Прошу прощения, сам только что попробовал обновить шаблон - кэш очистился. Был не прав!
In Web We Trust
Аватара пользователя
Egoz
phpBB 1.4.4
Сообщения: 126
Стаж: 20 лет 8 месяцев
Откуда: Биробиджан
Благодарил (а): 10 раз
Поблагодарили: 3 раза

Re: SQL ошибка при назначении прав модератору в админке

Сообщение Egoz »

Айдар
оставлю наверное на выходные, качну мод и попробую отследить что еще осталось от него. т.к. так гораздо удобней очищать кэш :-)
так то оно так, а вот случись что-либо нечто, вот тебе и пожалуйста

Вернуться в «Поддержка phpBB 3.0.х»