500 - Internal server error. на медленном канале

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
moto
phpBB 1.2.0
Сообщения: 18
Стаж: 16 лет 1 месяц
Благодарил (а): 5 раз

500 - Internal server error. на медленном канале

Сообщение moto »

Здравствуйте господа.
Задолбался уже в конец. Преамбула:
- в корпоративной сети сервер с установленным phpBB 3.0.7-PL1

- Связка Win2008Srv + PHP 5.2.14 + MySQL + IIS 7.0

- сделано так, что пользователи могут обмениваться файлами между собой размером до 250Мб, все настроено, таймауты, размеры и т.п. Пользователи меняются без каких-либо проблем, если между ними канал 10Мбитс и больше...

Ну вот появился филиал в сети с каналом до сервера в 2Мбитс, пользователь пытается на сервак закачать файл размером 20Мб, по прошествии 3-5 минут(индикатор загрузки в эксплорере внизу доходит до конца, проходит еще пол-минуты) видит ошибку в эксплорере
"500 - Internal Server Error. There is a problem with the resource you are looking for, and it cannot be displayed." Ошибку выдает IIS.

В общем я даже не знаю куда теперь посмотреть, есть какие-нибудь мысли или советы? Как отследить или локализовать?

Добавлено спустя 31 минуту 23 секунды:
В общем дело не в канале, а во времени загрузки файла. Если грузить файл 3-5 минут, то индикатор доходит до 100% и эксплорер пишет такую ошибку, вот такие параметры у меня выставлены:
IIS:
- web.config - <requestLimits maxAllowedContentLength="1677721600"/>
- CGI Timeout - 1 час
- Connetion Timeout - 1 час

PHP.ini:
- max_input_time = 1000
- memory_limit = 2000M
- post_max_size = 1700M
- file_uploads = On
- upload_max_filesize = 1500M
- max_execution_time=3000

в общем я не знаю как уточнить, кто же все-таки меня отрубает IIS или не IIS как можно отловить это?
Shredder
Former team member
Сообщения: 2266
Стаж: 17 лет 9 месяцев
Благодарил (а): 283 раза
Поблагодарили: 584 раза

Re: 500 - Internal server error. на медленном канале

Сообщение Shredder »

http://www.google.ru/search?hl=ru&sourc ... =&aql=&oq=

Третья снизу ссылка на phpbb.com, там что-то про web.config
Аватара пользователя
moto
phpBB 1.2.0
Сообщения: 18
Стаж: 16 лет 1 месяц
Благодарил (а): 5 раз

Re: 500 - Internal server error. на медленном канале

Сообщение moto »

Что-то пока ничего удобоваримого не нашел, проблема осталась...
Включил на IISе расширенную информацию об ошибках и вот что он мне пишет:

HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred.

Detailed Error Information

Module FastCgiModule
Notification ExecuteRequestHandler
Handler PHP_via_FastCGI
Error Code 0x80004005

Добавлено спустя 37 минут 26 секунд:
В общем, вопрос решен. Все дело оказалось в том, что надо было установить PHP Non Threade-Safe mode. С этой версией никаких ошибок не возникает - Ура.
Вот здесь вышел на решение своего вопроса:
http://forums.iis.net/p/1160158/1914307.aspx#1914307

Вернуться в «Поддержка phpBB 3.0.х»