Ошибка при вставке в MYSQL

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
dinya_1
phpBB 1.0.0
Сообщения: 3
Стаж: 15 лет 1 месяц
Благодарил (а): 1 раз

Ошибка при вставке в MYSQL

Сообщение dinya_1 »

Здравствуйте!
С phpBB 3.0.х раньше не имел дел.
Локально Установка прошла отлично! Залил базу на Сервер(на хостинг)- работает. А вот с Сервера на локальный - выдает ошибки:

Код: Выделить всё

Error

SQL query: 

INSERT INTO `phpbb_search_wordlist` 
VALUES ( 2, 0xeff0e8ece5f0, 0, 1 ) ;


MySQL said:  
 #1062 - Duplicate entry '' for key 'wrd_txt'

База хостинга
phpMyAdmin 2.6.2
MySQL 5.0.70

Локальная
phpMyAdmin 3.2.3
MySQL 5.1.4

Подскажите пожалуйста кто сталкивался?
Аватара пользователя
rxu
phpBB Guru
phpBB Guru
Сообщения: 17273
Стаж: 20 лет 4 месяца
Откуда: Красноярск
Благодарил (а): 633 раза
Поблагодарили: 2413 раз

Re: Ошибка при вставке в MYSQL

Сообщение rxu »

dinya_1 писал(а):А вот с Сервера на локальный
Не понял этот момент.
А вообще, содержимое поисковых таблиц (phpbb_search_results, phpbb_search_wordlist, phpbb_search_wordmatch) переносить не надо, только структуру.
Изображение
Аватара пользователя
dinya_1
phpBB 1.0.0
Сообщения: 3
Стаж: 15 лет 1 месяц
Благодарил (а): 1 раз

Re: Ошибка при вставке в MYSQL

Сообщение dinya_1 »

rxu
>А вот с Сервера на локальный
>Не понял этот момент.

Я говорю о том, что вовремя вставки данных, экспортюрованных из интернета(с хостинга), происходит олшибка с указанием на таблицы : phpbb_search_wordlist

>А вообще, содержимое поисковых таблиц (phpbb_search_results, phpbb_search_wordlist, phpbb_search_wordmatch) переносить не надо, только структуру.
а если у меня сохранена вся база, в месте с таблицами поиска, и нужно её вставить на локальный комп , тогда как быть, если они выдают ошибки,при вставке...
\Может поисковые таблицы должны быть пустыми?
Попробывал экспортировать локальную базу в файл, вставить назад в локально - вставляется без ошибок. А когда экспортирую с хостинга выдает ошибки...

Вернуться в «Поддержка phpBB 3.0.х»