User Blog Mod
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
veleg
- phpBB 1.0.0
- Сообщения: 8
- Стаж: 15 лет 3 месяца
Re: User Blog Mod
ставил 13 и 14 версию, одна и та же проблема.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Последний раз редактировалось владимир1983 09.06.2011 8:57, всего редактировалось 1 раз.
Причина: перезалил файл
Причина: перезалил файл
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: User Blog Mod
Создайте в папке форума папку test
Создайте в этой папке два файла,
В файле .htaccess пропишите:
В файле index.php пропишите:
Обратитесь к папке test через браузер http://mydomain.ru/forum/test
Что будет?
p.s скачайте вложение файла .htaccess в вашем сообщении, замените тот который используется сейчас.
Создайте в этой папке два файла,
.htaccess и index.php. В файле .htaccess пропишите:
Код: Выделить всё
RewriteEngine On
RewriteRule ^.*$ index.phpКод: Выделить всё
<?php
print 'mod_rewrite ok!';
?>Что будет?
p.s скачайте вложение файла .htaccess в вашем сообщении, замените тот который используется сейчас.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
veleg
- phpBB 1.0.0
- Сообщения: 8
- Стаж: 15 лет 3 месяца
Re: User Blog Mod
Все сделал.
При обращении к папке /forum/test/
вывод ошибку 500
При обращении к папке /forum/test/
вывод ошибку 500
Код: Выделить всё
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@sweb.ru and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: User Blog Mod
Обратитесь к хостеру.
Модуль apache mod_rewrite у вас не работает.
Модуль apache mod_rewrite у вас не работает.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
veleg
- phpBB 1.0.0
- Сообщения: 8
- Стаж: 15 лет 3 месяца
Re: User Blog Mod
Пока что сделал откат. Сегодня ночью поковыряю, заново установлю блог.
На счет mod_rewrite, возможно кому-то полезно будет.
Если работаете под виндовс, то необходимо сохранять файл .htaccess в формате utf8(без BOM). Проблема была как раз в этом.
На счет mod_rewrite, возможно кому-то полезно будет.
Если работаете под виндовс, то необходимо сохранять файл .htaccess в формате utf8(без BOM). Проблема была как раз в этом.
-
veleg
- phpBB 1.0.0
- Сообщения: 8
- Стаж: 15 лет 3 месяца
Re: User Blog Mod
Сделал, все работает. Есть пара вопросов, задавал их в соседней ветки дня три назад, ни кто не отвечает в ней. Продублирую здесь:
Код: Выделить всё
на 14 версии работает транслитерация?
а то все ссылки как были на кириллице так и остались вида /forum/blog/логин
Еще такой вопрос можно ли убрать из адресной строки слово форум, что бы было http://mysite.ru/blog/login-
iМаньяк
- phpBB 2.0.0
- Сообщения: 200
- Стаж: 16 лет 1 месяц
- Благодарил (а): 32 раза
- Поблагодарили: 3 раза
Re: User Blog Mod
подскажите, какой файл в данном моде отвечает за ссылки? я сделал блог на субдомене, а ссылки при входе (http://blog.site.ru/) вида (http://site.ru/forum/blog.php) где искать?
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: User Blog Mod
Админ. раздел > Настройки сервера > Настройки URL сервера что тут?
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
iМаньяк
- phpBB 2.0.0
- Сообщения: 200
- Стаж: 16 лет 1 месяц
- Благодарил (а): 32 раза
- Поблагодарили: 3 раза
Re: User Blog Mod
владимир1983
объясняю http://site.ru/forum/ форум, http://site.ru/ сайт, http://site.ru/blog/ БЛОГ... и в нем ссылки http://site.ru/forum/blog.php?траляля... а мне надо чтобы были http://site.ru/blog/index.php?тралялял
объясняю http://site.ru/forum/ форум, http://site.ru/ сайт, http://site.ru/blog/ БЛОГ... и в нем ссылки http://site.ru/forum/blog.php?траляля... а мне надо чтобы были http://site.ru/blog/index.php?тралялял
-
bambarbeya
- phpBB 1.2.0
- Сообщения: 15
- Стаж: 15 лет 2 месяца
- Благодарил (а): 3 раза
Re: User Blog Mod
Установил данный мод , права выставлены . Создаю в админке в настройках мода категорию , как в неё добавлять ? Ни кнопок ничего нет . Личные дневники создаются отлично и из профиля и так
-
Пчелкин
- phpBB 3.3.0
- Сообщения: 11361
- Стаж: 16 лет 8 месяцев
- Благодарил (а): 1832 раза
- Поблагодарили: 1358 раз
Re: User Blog Mod
Не связывайтесь вы с категориями..они и на фиг не нужны..и на создание блогов пользователями - не влияют..потом тока морока - распределять ихние блоги по категориям и на вопросы лишние отвечать..пусть блоги валяются у них просто так - без категорий...
Да и категории не появятся, если вы сделаете на главной странице дневников вывод списка дневников, а не стандартную его страницу...увы.
Да и категории не появятся, если вы сделаете на главной странице дневников вывод списка дневников, а не стандартную его страницу...увы.
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
-
bambarbeya
- phpBB 1.2.0
- Сообщения: 15
- Стаж: 15 лет 2 месяца
- Благодарил (а): 3 раза
Re: User Blog Mod
Пчелкин спасибо за ответ ! Но мне интересно почему невозможно даже создать блог в созданой категории ..
где собака порылась ?
-
Пчелкин
- phpBB 3.3.0
- Сообщения: 11361
- Стаж: 16 лет 8 месяцев
- Благодарил (а): 1832 раза
- Поблагодарили: 1358 раз
Re: User Blog Mod
В строках - заготовках для категорий, которые пока закомментированы у авторов..видели скока там " //" ?
Я тож сначала не понял что и к чему..а потом у автора почитал что это тока задумка для распределения блогов по категориям, но не доведенная до ума...увы.
Добавлено спустя 23 минуты 18 секунд:
В каком месте потом их видно? Да почти ни в каком...
Я тож сначала не понял что и к чему..а потом у автора почитал что это тока задумка для распределения блогов по категориям, но не доведенная до ума...увы.
Добавлено спустя 23 минуты 18 секунд:
Почему? Выбор категории присутствует при создании блога..внизу вкладка "категории"..только толку от этого?bambarbeya писал(а):невозможно даже создать блог в созданой категории
В каком месте потом их видно? Да почти ни в каком...
NIKON-D90, AF-S 18-105, AF-S 14-24, AF-S 24-70
-
bambarbeya
- phpBB 1.2.0
- Сообщения: 15
- Стаж: 15 лет 2 месяца
- Благодарил (а): 3 раза
Re: User Blog Mod
Пчелкин я посмотрел как сделано у вас на форуме , очень удобно . А у меня вылазят последние и случайные записи , как убрать ?

