Ошибка при чистке кэша

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
deadromeo
phpBB 2.0.0
Сообщения: 237
Стаж: 15 лет 4 месяца
Благодарил (а): 28 раз
Поблагодарили: 41 раз
Забанен: Бессрочно

Ошибка при чистке кэша

Сообщение deadromeo »

Описание проблемы: вылетает ошибка при попытке очистить кэш в админке
Произведенные изменения, после которых начались неполадки: был удален через админку один стиль и создан турнир по phpbb arcade
Версия phpBB: 3.0.9
Используемые стили: X-static
Используемые моды:
Версия PHP: PHP Version 5.2.14
Используемая СУБД и её версия: MySQL 5.0.67
Ссылка на конференцию: http://hello-vitebsk.ru
Есть ли у вас тестовый аккаунт: login --- piton password ---- 1234567
Использовался ли поиск для решения проблемы: да
Если да, то какие запросы вы использовали:
вот текст самой ошибки

Код: Выделить всё

Общая ошибка
SQL ERROR [ mysql4 ]

The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay [1104]

SQL

SELECT a.forum_id, ug.user_id, g.group_id FROM (phpbb_acl_options o, phpbb_user_group ug, phpbb_groups g, phpbb_acl_groups a) LEFT JOIN phpbb_acl_roles_data r ON (a.auth_role_id = r.role_id) WHERE (o.auth_option_id = a.auth_option_id OR o.auth_option_id = r.auth_option_id) AND ((a.auth_setting = 0 AND r.auth_setting IS NULL) OR r.auth_setting = 0) AND a.group_id = ug.group_id AND g.group_id = ug.group_id AND NOT (ug.group_leader = 1 AND g.group_skip_auth = 1) AND ug.user_id IN (109, 88, 86, 59, 106, 150, 2) AND ug.user_pending = 0 AND o.auth_option LIKE 'm\\_%'

BACKTRACE

FILE: includes/db/mysql.php
LINE: 175
CALL: dbal->sql_error()

FILE: includes/functions_admin.php
LINE: 2423
CALL: dbal_mysql->sql_query()

FILE: includes/acp/acp_main.php
LINE: 344
CALL: cache_moderators()

FILE: includes/functions_module.php
LINE: 516
CALL: acp_main->main()

FILE: adm/index.php
LINE: 75
CALL: p_master->load_active()
Мои расширения: TopicLinks, TopicDesc, BannedUser, AllowedExt, NumPosts, PMRead, GoogleTranslator, BoardStartDate, CountDownBB, VKWigets, TimeHeader.
deadromeo
phpBB 2.0.0
Сообщения: 237
Стаж: 15 лет 4 месяца
Благодарил (а): 28 раз
Поблагодарили: 41 раз
Забанен: Бессрочно

Re: Ошибка при чистке кэша

Сообщение deadromeo »

хмм попытался решить проблему сделав запрос в БД

Код: Выделить всё

SET SQL_BIG_SELECTS=1
ошибка исчезла но вот правильно ли я сделал ???
Мои расширения: TopicLinks, TopicDesc, BannedUser, AllowedExt, NumPosts, PMRead, GoogleTranslator, BoardStartDate, CountDownBB, VKWigets, TimeHeader.
deadromeo
phpBB 2.0.0
Сообщения: 237
Стаж: 15 лет 4 месяца
Благодарил (а): 28 раз
Поблагодарили: 41 раз
Забанен: Бессрочно

Re: Ошибка при чистке кэша

Сообщение deadromeo »

ошибка вновь появилась но решил ее другим способом. может кому пригодится(если конечно я все правильно сделал)
в файлике /includes/db/mysql.php
после строки

Код: Выделить всё

@mysql_query("SET NAMES 'utf8'", $this->db_connect_id);
добавил

Код: Выделить всё

@mysql_query("SET SQL_BIG_SELECTS=1");
хех светит мне предупреждение но ребята, кто разбирается в этом, прокомментируйте мои действия
Мои расширения: TopicLinks, TopicDesc, BannedUser, AllowedExt, NumPosts, PMRead, GoogleTranslator, BoardStartDate, CountDownBB, VKWigets, TimeHeader.
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Ошибка при чистке кэша

Сообщение MIT »

deadromeo, всё правильно сделал! (с).

Вернуться в «Поддержка phpBB 3.0.х»