Хостер открыл доступ к настройкам php но предварительно их отключил, проинформировав меня следующим письмом:
Так же, несколько настроек апача:Для повышения безопасности пользователей, в панель управления
хостингом, раздел "Настройка php" добавлена возможность управления
наиболее не безопасными функциями, такими как
eval,exec,passthru,shell_exec,escapeshellarg,escapeshellcmd,system,proc_open,
proc_get_status,proc_close,popen,show_source,chmod,symlink,fsocket,pfsockopen,
sockopen,mail.
C 26/12/2011 все перечисленные функции, кроме mail() будут по умолчанию отключены.
Поэтому, если Вы используете одну из перечисленных функций, пожалуйста,
зайдите в панель управления хостингом и включите необходимые.
Например Вам может понадобиться функция mail(), если Ваш сайт отправляет
почту, либо функция exec() если Вы используете библиотеку imagemagic
для работы с изображениями.
Если Ваши скрипт не используют системные вызовы, отключение данных
функций никак не повлияет на работу Ваших скриптов.
Мы не рекомендуем без необходимости включать данные функции,
поскольку это может стать причиной взлома Вашего аккаунта.
CGI, Options +ExecCGI, Options +ExecCGI, Options +Includes, Options +FollowSymLinks, Options +Multiviews, AddDefaultCharset
Общие настройки:
register_globals, safe_mode, zlib.output_compression, output_buffering, xmlrpc_errors, magic_quotes_runtime, magic_quotes_sybase, magic_quotes_gpc, allow_url_fopen, allow_url_include
Настройка сессий:
session.auto_start, session.cache_expire=180, session.cache_expire=0, session.cookie_secure, session.gc_maxlifetime=1440, session.use_cookies, session.use_only_cookies, session.use_trans_sid
Форум стал соответственно работать плохо, по большому счету - при загрузке страниц недогружаеться стиль форума. Посему вопрос - какие из перечисленных функций я мог бы включить для нормальной работы?
Логи апача показывают примерно следующее:
Код: Выделить всё
...
[Wed Dec 28 11:12:57 2011] [error] [client 91.х.х.х] ALERT - function within blacklist called: chmod() (attacker '91.х.х.х', file '/sata1/home/users/ir172/www/www.172ir.kiev.ua/forum/includes/functions.php', line 703), referer: http://www.172ir.kiev.ua/forum/viewforum.php?f=6
[Wed Dec 28 11:12:57 2011] [error] [client 91.х.х.х] ALERT - function within blacklist called: chmod() (attacker '91.х.х.х', file '/sata1/home/users/ir172/www/www.172ir.kiev.ua/forum/includes/functions_messenger.php', line 645), referer: http://www.172ir.kiev.ua/forum/viewforum.php?f=6
...
