Добрый день.
Есть такой плагин PHPBB Single Sign On, для интеграции phpbb и wordpress.
Пагин на первый взгляд отличный, и на денвере работает абсолютно без нареканий.
Но вот после установки на хостинг (чистая установка, как и на денвер), в админке после выполнения некоторых действий (например при попытке настроить разрешения для аватар или вложений) выдает такую ошибку:
> [phpBB Debug] PHP Warning: in file [ROOT]/common.php(87) : eval()'d code on
> line 479: include_once(./../includes/auth/auth_.php) [function.include-once]:
> failed to open stream: No such file or directory
> [phpBB Debug] PHP Warning: in file [ROOT]/common.php(87) : eval()'d code on
> line 479: include_once() [function.include]: Failed opening
> './../includes/auth/auth_.php' for inclusion
> (include_path='.:/opt/php5/lib/php:/opt/php5/lib/ZendFramework/library')
Я так понял что проблема в 87 строке модифицированного common.php, вот эта строка:
eval($include_common_contents);
Она подгружает оригинальный common.php
Так же я понял что скрипт пытается инклюдить файл с недописанным названием auth_.php
Я попробовал в папке includes/auth создать этот файл (с содержанием, как в auth_wpbb.php), после этого ошибку скрипт не выдает, вместо этого пишет, что я не имею прав для доступа в админку.
Надеюсь что кто-то сможет мне помочь. Здесь были сообщения о том что плагин не работает на определенных хостингах, но в той ветке ошибка была другая, и помочь в итоге никто не смог.
Гугл тоже не помог. В русском сегменте почти ничего нет, ковыряние буржунета с переводчиком тоже ничего не дало.
PHPBB Single Sign On на хостинге sweb
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
ZedsDead
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 14 лет 7 месяцев
-
владимир1983
- phpBB 3.2.6
- Сообщения: 5954
- Стаж: 16 лет 4 месяца
- Откуда: Сергиев Посад
- Благодарил (а): 373 раза
- Поблагодарили: 727 раз
Re: PHPBB Single Sign On на хостинге sweb
Версия phPBB? Версия плагина? Дай ссылки где качал всё это добро.
За ваши деньги решу ваши проблемы. Стучи в ЛС.
Нет человека - нет проблемы. (c)
Нет человека - нет проблемы. (c)
-
ZedsDead
- phpBB 1.0.0
- Сообщения: 2
- Стаж: 14 лет 7 месяцев
Re: PHPBB Single Sign On на хостинге sweb
PHPBB 3.0.10 отсюда http://www.phpbbguru.net/files/base/phpbb3-ru/
Wordpress 3.3.1 отсюда http://ru.wordpress.org/
PHPBB Single Sign On 0.8.5 из официального репозитория
Wordpress 3.3.1 отсюда http://ru.wordpress.org/
PHPBB Single Sign On 0.8.5 из официального репозитория

