Возможно ли исправить данный баг до выхода новой версии? С чем это связано? Пользователей просто выводит из себя такая некорректная авторизация.rxu писал(а):Планируется так.
Сообщаем об ошибках phpBB 3.0.x разработчикам
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
).
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды
Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение
-
Петрович
- phpBB 2.0.0
- Сообщения: 244
- Стаж: 19 лет 10 месяцев
- Откуда: НСО, п. Витаминка
- Благодарил (а): 10 раз
- Поблагодарили: 14 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
-
modulx
- phpBB 1.0.0
- Сообщения: 3
- Стаж: 14 лет 7 месяцев
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
При удалении сообщения на форуме выпадает ошибка:
Общая ошибка
SQL ERROR [ mysql4 ]
[0]
SQL
No values specified for SQL IN comparison
BACKTRACE
Подскажите как можно исправить?
phpbb 3.0.9
prosilver.
Общая ошибка
SQL ERROR [ mysql4 ]
[0]
SQL
No values specified for SQL IN comparison
BACKTRACE
Подскажите как можно исправить?
phpbb 3.0.9
prosilver.
У вас нет необходимых прав для просмотра вложений в этом сообщении.
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
modulx
В этой теме сообщают об ошибках в оригинальном коде, которые воспроизводятся на свежеустановленных форумах.
Ваш случай не имеет отношения к этому. Создайте отдельную тему в форуме поддержки, и не забудьте заполнить шаблон запроса. Только не спрашивайте, что это такое.
В этой теме сообщают об ошибках в оригинальном коде, которые воспроизводятся на свежеустановленных форумах.
Ваш случай не имеет отношения к этому. Создайте отдельную тему в форуме поддержки, и не забудьте заполнить шаблон запроса. Только не спрашивайте, что это такое.
-
MIT
- Former team member
- Сообщения: 2500
- Стаж: 17 лет 6 месяцев
- Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
- Благодарил (а): 3 раза
- Поблагодарили: 351 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Структура таблицы
К проблемам в работе данный недочёт не приводит, но создать флаги
phpbb_forums (MySQL) описывает поле forum_flags как tinyint(4), однако тип tinyint не поддерживает таких больших значений. Надо бы изменить на smallint.К проблемам в работе данный недочёт не приводит, но создать флаги
FORUM_FLAG_* выше, чем FORUM_FLAG_QUICK_REPLY, не получится.-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
MIT
А зачем создавать флаги? Есть конкретный пример?
А зачем создавать флаги? Есть конкретный пример?
-
MIT
- Former team member
- Сообщения: 2500
- Стаж: 17 лет 6 месяцев
- Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
- Благодарил (а): 3 раза
- Поблагодарили: 351 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Есть. Разрабатываю модификацию, нужен дополнительный флаг. Длина поля создать его позволяет, а тип — нет.
-
mitko
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 14 лет 6 месяцев
- Откуда: Saint-Petersburg, Russia
- Благодарил (а): 1 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Добрый день!
Похоже есть баг в системе уведомлений. Пользователю был наложен временный бан (семь суток). По истечению этого срока бан автоматически снялся, но теперь ему перестали приходить автоматические уведомления по e-mail (на личные сообщения и на подписанные темы). В настройках проверил - все установлено правильно. Попробовал из админки сделать ему тестовую рассылку через Система/Массовая рассылка почты - письмо дошло нормально. Версия 3.0.9.
Судя по всему проблема не только у меня Уведомления после бана.
Похоже есть баг в системе уведомлений. Пользователю был наложен временный бан (семь суток). По истечению этого срока бан автоматически снялся, но теперь ему перестали приходить автоматические уведомления по e-mail (на личные сообщения и на подписанные темы). В настройках проверил - все установлено правильно. Попробовал из админки сделать ему тестовую рассылку через Система/Массовая рассылка почты - письмо дошло нормально. Версия 3.0.9.
Судя по всему проблема не только у меня Уведомления после бана.
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
mitko
По какому параметру банили (имя, IP, email)?
По какому параметру банили (имя, IP, email)?
-
mitko
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 14 лет 6 месяцев
- Откуда: Saint-Petersburg, Russia
- Благодарил (а): 1 раз
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
mitko
Посмотрите, в таблице банов запись в отношении данного пользователя осталась?
Посмотрите, в таблице банов запись в отношении данного пользователя осталась?
-
mitko
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 14 лет 6 месяцев
- Откуда: Saint-Petersburg, Russia
- Благодарил (а): 1 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
В базе вижу это:
ban_id ban_userid ban_ip ban_email ban_start ban_end ban_exclude ban_reason ban_give_reason
356 3509 1330103216 1330708016 0
ban_id ban_userid ban_ip ban_email ban_start ban_end ban_exclude ban_reason ban_give_reason
356 3509 1330103216 1330708016 0
-
rxu
- phpBB Guru

- Сообщения: 17272
- Стаж: 20 лет 4 месяца
- Откуда: Красноярск
- Благодарил (а): 632 раза
- Поблагодарили: 2412 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
mitko
3509 - идентификатор того самого юзера? если да, Попробуйте удалить эту запись из базы.
Добавлено спустя 1 час 52 минуты 26 секунд:
Баг действительно имеет место, спасибо за сообщение.
http://tracker.phpbb.com/browse/PHPBB3-10684
3509 - идентификатор того самого юзера? если да, Попробуйте удалить эту запись из базы.
Добавлено спустя 1 час 52 минуты 26 секунд:
Баг действительно имеет место, спасибо за сообщение.
http://tracker.phpbb.com/browse/PHPBB3-10684
-
mitko
- phpBB 1.0.0
- Сообщения: 4
- Стаж: 14 лет 6 месяцев
- Откуда: Saint-Petersburg, Russia
- Благодарил (а): 1 раз
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
После удаления юзера из бан-листа все заработало. Спасибо за подсказку, будем ждать исправления.
-
Alecto
- phpBB 3.0.12
- Сообщения: 2857
- Стаж: 16 лет 9 месяцев
- Откуда: Украина! Харьков
- Благодарил (а): 80 раз
- Поблагодарили: 292 раза
Re: Сообщаем об ошибках phpBB 3.0.x разработчикам
Сегодня пролистываю одну из тем столкнулся с ошибкой:
Автор сообщения (далее автор1) выполнял правки, что было указано в причине, внизу сообщения (отредакторовано тем-то... тогда-то...).
Затем первоначальный автор сообщения был заменен другим (далее автор2, замена скорее всего выполнялась модератором).
Затем автор1 был удален вместе со всеми его сообщениями.
Но, осталось сообщение, автором которого на тот момент уже был автор2.
После удаления автора1 в информации о редакции - стало указываться ГОСТЬ (логично, поскольку автор1 - уже был удален).
Но, при просмотре данной страницы темы (с сообщением, отредактированным удаленным пользователем автор1) появилась ошибка в файле viewtopic.php (сразу не сообразил и не записал лог ошибки), что-то типа несуществующего индекса с ID удаленного пользователя.
С одной стороны - не смертельно, пролечилось удаление поста в редакции ГОСТЬ.
С другой стороны - ситуация с заменой авторов - штатная и весьма распространенная, поэтому ошибка на мой взгляд подлежит учету и по возможности - исправлению.
Автор сообщения (далее автор1) выполнял правки, что было указано в причине, внизу сообщения (отредакторовано тем-то... тогда-то...).
Затем первоначальный автор сообщения был заменен другим (далее автор2, замена скорее всего выполнялась модератором).
Затем автор1 был удален вместе со всеми его сообщениями.
Но, осталось сообщение, автором которого на тот момент уже был автор2.
После удаления автора1 в информации о редакции - стало указываться ГОСТЬ (логично, поскольку автор1 - уже был удален).
Но, при просмотре данной страницы темы (с сообщением, отредактированным удаленным пользователем автор1) появилась ошибка в файле viewtopic.php (сразу не сообразил и не записал лог ошибки), что-то типа несуществующего индекса с ID удаленного пользователя.
С одной стороны - не смертельно, пролечилось удаление поста в редакции ГОСТЬ.
С другой стороны - ситуация с заменой авторов - штатная и весьма распространенная, поэтому ошибка на мой взгляд подлежит учету и по возможности - исправлению.

