Проблема с созданием новых тем (SQL Error)

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Courage777
phpBB 1.0.0
Сообщения: 5
Стаж: 14 лет 4 месяца

Проблема с созданием новых тем (SQL Error)

Сообщение Courage777 »

Здравствуйте.
Неожиданно возникла проблема с созданием новых тем на моем форуме.
После того, как нажимаем "создать тему" и заполняем соответствующие поля (название темы и сообщение) возникает такая ошибка:

Код: Выделить всё

SQL ERROR [ mysql4 ]

Field 'topic_last_post_subject' doesn't have a default value [1364]

SQL

INSERT INTO phpbb_1topics (topic_poster, topic_time, forum_id, icon_id, topic_approved, topic_title, topic_first_poster_name, topic_first_poster_colour, topic_type, topic_time_limit, topic_attachment) VALUES (4, 1337066448, 2, 0, 1, 'test', 'Dj3000', 'AA0000', 0, 0, 0)

BACKTRACE

FILE: includes/db/mysql.php
LINE: 158
CALL: dbal->sql_error()

FILE: includes/functions_posting.php
LINE: 1809
CALL: dbal_mysql->sql_query()

FILE: posting.php
LINE: 1010
CALL: submit_post()
Скрин: http://s2.hostingkartinok.com/uploads/i ... c17c65.jpg

Версия phpbb: 3.0.1
Конфа: http://fcpsg.ru/forum/
Из модов установлен mchat + антиспам-вопрос.
Стиль: 4poziomSEO_red
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Проблема с созданием новых тем (SQL Error)

Сообщение MIT »

Courage777 писал(а):Версия phpbb: 3.0.1
Не поддерживается несколько лет. Обновиться не помешало бы.
Courage777 писал(а):Field 'topic_last_post_subject' doesn't have a default value [1364]
А я знаю что поиск знает что это значит. Поиск, ты знаешь, на удивление потрясная штука, особенно если им пользоваться.
Courage777
phpBB 1.0.0
Сообщения: 5
Стаж: 14 лет 4 месяца

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Courage777 »

Спасибо.
Удалось найти вот это: FAQ по phpBB 3.0 Olympus - ПРОЧТИТЕ НАКОНЕЦ! (пункт 17).
Однако проблема в том, что при нажатии на "For 3.0.1 download this copy" ничего не скачивается. А просто перекидывает на сайт.

Что касается обновления, то с этим тоже проблема.
http://www.phpbb.com/downloads/olympus.php?update=1 - тут нет файлов для обновления 3.0.1. Только начиная с 3.0.2...
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Проблема с созданием новых тем (SQL Error)

Сообщение MIT »

Courage777, на языке вертится что-то вроде «где ж ты раньше был?», но...

В общем, если у тебя не стоит модов на форуме, обнови форум заменой файлов до последней версии и запусти database_update.php для обновления базы. Если моды стоят, то всё довольно грустно, учитывая то, что пакетов автоматического обновления с версии 3.0.1 тоже нет.

Добавлено спустя 1 минуту 18 секунд:
Хотя можешь и не обновляться, а просто исправить ошибки в структуре базы данных.
Так, например, для устранения ошибки «doesn't have a default value» достаточно задать стандартное значение для этого поля через инструменты типа phpMyAdmin.
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

Проблема с созданием новых тем (SQL Error)

Сообщение МайскийЖук »

Что касается обновления, то с этим тоже проблема.
Тоже мне проблема. Вот вам ссылка.

[ Скачать ]

Это архив для обновления версии 3.0.1 до версии 3.0.2. После применения этого обновления можете спокойно скачивать архив обновления с версии 3.0.2 до актуальной версии с официального сайта движка.
Любовь и боль, покой и бой я как любой несу с собой…
Courage777
phpBB 1.0.0
Сообщения: 5
Стаж: 14 лет 4 месяца

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Courage777 »

Да как-то особой необходимости не было. Главное - форум стабильно работает. Вот и не обновлялись.
У нас установлен mchat, антиспам-вопрос... Возможно еще какие-то мелочи.
Печально конечно, если всё настолько глухо. Впрочем, на данный момент главное - устранить ошибку. А там уже будем думать, что делать дальше :) Видимо, придется искать специалиста.
MIT писал(а):Так, например, для устранения ошибки «doesn't have a default value» достаточно задать стандартное значение для этого поля через инструменты типа phpMyAdmin.
Если вас не затруднит, подскажите пожалуйста, как это сделать. С базами данных раньше почти не работал.
Нашел колонку topic_last_post_subject:http://s2.hostingkartinok.com/uploads/i ... da41f5.jpg Как в ней задать стандартное значение?
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Sheer »

Courage777 писал(а):Печально конечно
Куда уж там! FAQ
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

Проблема с созданием новых тем (SQL Error)

Сообщение МайскийЖук »

Печально конечно, если всё настолько глухо.
Почему глухо-то? Вы по моей ссылке выше архив скачали? Обновились или нет?
Любовь и боль, покой и бой я как любой несу с собой…
Courage777
phpBB 1.0.0
Сообщения: 5
Стаж: 14 лет 4 месяца

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Courage777 »

МайскийЖук писал(а):Почему глухо-то? Вы по моей ссылке выше архив скачали? Обновились или нет?
Спасибо за ссылочку.
Сделал все по инструкции (автообновление), но теперь стало еще хуже.
При нажатии на любую тему: http://s2.hostingkartinok.com/uploads/i ... 5f8c5e.jpg
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Sheer »

Courage777
1. Вы провели обновление структуры БД?
2. Включите debug
3. Не надо пихать тут скрины с ошибками, достаточно скопировать текст сообщения, и разместить его в теле поста, заключив в соответствующие теги bb-кода.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Courage777
phpBB 1.0.0
Сообщения: 5
Стаж: 14 лет 4 месяца

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Courage777 »

Включил debug - полетела вся кодировка и стили...
а в админке:

Код: Выделить всё

[phpBB Debug] PHP Notice: in file /includes/functions.php on line 210: Undefined index: MIB
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 215: Undefined index: KIB
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 210: Undefined index: MIB
[phpBB Debug] PHP Notice: in file /adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at /includes/functions.php:2975)
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 210: Undefined index: MIB
Обновление структуры БД? Как я понял, при автоматическом обновлении до 3.0.2 там все само обновилось...
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Проблема с созданием новых тем (SQL Error)

Сообщение Sheer »

Courage777 писал(а):там все само обновилось...
С чего бы это?
http://www.phpbb.com/kb/article/doesnt- ... ue-errors/ mysql_upgrader.php
Undefined index: MIB - обновите языковой пакет.
Courage777 писал(а):а в админке:
А что в "неадминке",
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
МайскийЖук
phpBB 3.0.7-PL1
Сообщения: 2535
Стаж: 16 лет 11 месяцев
Благодарил (а): 17 раз
Поблагодарили: 366 раз

Проблема с созданием новых тем (SQL Error)

Сообщение МайскийЖук »

При нажатии на любую тему
А у вас действительно префикс для таблиц форума такой — phpbb_1? А не просто phpbb_?
Любовь и боль, покой и бой я как любой несу с собой…

Вернуться в «Поддержка phpBB 3.0.х»