Изменил config.php и простился с форумом :(

Проблемы с установкой или работой phpBB 3.0.x? Получите помощь здесь!
С 1 января 2017 года phpBB Group прекращает поддержку phpBB версии 3.0.
Сайт официальной русской поддержки phpBB Guru продолжит поддержку phpBB 3.0 до 1 июля 2017 года.
Подробнее: Окончание поддержки phpBB 3.0.
Правила форума
Местная Конституция | Шаблон запроса | Документация (phpBB3) | Переход на 3.0.6 и выше | FAQ-3 (phpbb3) | Как задавать вопросы | Как устанавливать моды

Ваш вопрос может быть удален без объяснения причин, если на него есть ответы по приведённым ссылкам (а вы рискуете получить предупреждение ;) ).
Аватара пользователя
OilGasMan
phpBB 1.4.0
Сообщения: 32
Стаж: 13 лет 10 месяцев
Откуда: Украина
Благодарил (а): 14 раз

Изменил config.php и простился с форумом :(

Сообщение OilGasMan »

Код: Выделить всё

General Error
SQL ERROR [ mysql4 ]

����������� �� �����������, �.�. �������� ��������� ������ ������ �� �����������. [2002]

BACKTRACE

FILE: [ROOT]/includes/db/mysql.php
LINE: 93
CALL: dbal->sql_error()

FILE: [ROOT]/common.php
LINE: 110
CALL: dbal_mysql->sql_connect()

FILE: [ROOT]/portal.php
LINE: 76
CALL: include('[ROOT]/common.php')
вот такие вот делы, конфиг настроен нормально..
Аватара пользователя
MIT
Former team member
Сообщения: 2500
Стаж: 17 лет 6 месяцев
Откуда: 56°20′02″ с. ш. 36°42′45″ в. д.
Благодарил (а): 3 раза
Поблагодарили: 351 раз

Re: Изменил config.php и простился с форумом :(

Сообщение MIT »

Вот нельзя было хоть кодировку нормальную сделать?

Проверяй настройки подключения к базе. Ошибка означает невозможность установки соединения с сервером.
Аватара пользователя
OilGasMan
phpBB 1.4.0
Сообщения: 32
Стаж: 13 лет 10 месяцев
Откуда: Украина
Благодарил (а): 14 раз

Re: Изменил config.php и простился с форумом :(

Сообщение OilGasMan »

я как бы догадывался, строки после косячной кодировки меня пугали, ибо я хз что они могут значить. спс.. как это нету, я пытаюсь зайти по своему домену - оно мне тыць и на папку инстала, которуя я удалял еще в прошлом году :geek:

з.ы: кстати по поводу кодировки я тоже хз что с ней. была норм, это вот сейчас: utf-8 general_ci стоит... посоветуйте лучше :)
Аватара пользователя
Sheer
Former team member
Сообщения: 12113
Стаж: 19 лет 7 месяцев
Откуда: Калининград не Кенигсберг
Благодарил (а): 54 раза
Поблагодарили: 2756 раз

Re: Изменил config.php и простился с форумом :(

Сообщение Sheer »

Чё менял-то? Структура и восстановление файла config.php

Добавлено спустя 1 минуту 4 секунды:
OilGasMan писал(а):кстати по поводу кодировки
В этом случае просто в браузере смени кодировку.
Изображение
Общие ошибки новичков (07.11.2005) & Как задавать вопросы
Мини FAQ
Если ничто другое не помогает, прочтите, наконец, инструкцию!
"Никакая инструкция не может перечислить всех обязанностей должностного лица, предусмотреть все отдельные случаи и дать вперёд соответствующие указания, а поэтому господа инженеры должны проявить инициативу и, руководствуясь знаниями своей специальности и пользой дела, принять все усилия для оправдания своего назначения".
Циркуляр Морского технического комитета №15 от 29.11.1910 г.
Аватара пользователя
OilGasMan
phpBB 1.4.0
Сообщения: 32
Стаж: 13 лет 10 месяцев
Откуда: Украина
Благодарил (а): 14 раз

Re: Изменил config.php и простился с форумом :(

Сообщение OilGasMan »

Да, я его шифровал. Потом удалил сертификат пользователя который шифровал, короче config снесся сам, я его восстановил, а проблему уже нашел: кто-то (очень умный), поставил firewall на режим политики, преднамеренно не описав правила для apache и mysql. В общем-с спасибо, буду обращаться к вам за советами в случае возникновения новых проблем...

Вернуться в «Поддержка phpBB 3.0.х»